aboutsummaryrefslogtreecommitdiff
path: root/deskutils/treeline
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-06-22 06:36:25 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-06-22 06:36:25 +0000
commitc904bae5fcff770f098cab3916710d6b5cc9d3c7 (patch)
treecfb9a8485fb1a0a3b37d3b5ea9d24556e7bd37db /deskutils/treeline
parent3102f0363f81bfda1b984aaecd2b0096042cd3c0 (diff)
downloadports-c904bae5fcff770f098cab3916710d6b5cc9d3c7.tar.gz
ports-c904bae5fcff770f098cab3916710d6b5cc9d3c7.zip
Notes
Diffstat (limited to 'deskutils/treeline')
-rw-r--r--deskutils/treeline/Makefile16
-rw-r--r--deskutils/treeline/distinfo9
-rw-r--r--deskutils/treeline/pkg-plist1
3 files changed, 20 insertions, 6 deletions
diff --git a/deskutils/treeline/Makefile b/deskutils/treeline/Makefile
index ab0285ccb1bf..509298a9350b 100644
--- a/deskutils/treeline/Makefile
+++ b/deskutils/treeline/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= treeline
-PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTVERSION= 1.0.2
CATEGORIES= deskutils python
MASTER_SITES= http://www.bellz.org/treeline/ \
http://depot.fsck.ch/mirror/distfiles/
@@ -22,7 +21,8 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
OPTIONS= ASPELL "install with aspell support" off \
ISPELL "install with ispell support" off \
PYXML "use pythons py-xml instead of textproc/expat2" on \
- HTTPLOAD "install httpLoad plugin" off
+ HTTPLOAD "install httpLoad plugin" off \
+ TYPESEARCH "install typesearch plugin" off
WRKSRC= ${WRKDIR}/TreeLine
USE_QT_VER= 3
@@ -50,12 +50,22 @@ PLIST_SUB+= HTTPLOAD=""
PLIST_SUB+= HTTPLOAD="@comment "
.endif
+.if defined(WITH_TYPESEARCH)
+DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} typesearch.py
+PLIST_SUB+= TYPESEARCH=""
+.else
+PLIST_SUB+= TYPESEARCH="@comment "
+.endif
+
do-install:
@cd ${WRKSRC} && ${PYTHON_CMD} install.py \
-p ${PREFIX} -d ${DOCSDIR} -i ${DATADIR}/icons -x
.if defined(WITH_HTTPLOAD)
@${INSTALL_DATA} ${DISTDIR}/httpload.py ${PREFIX}/lib/${PORTNAME}/plugins/
.endif
+.if defined(WITH_TYPESEARCH)
+ @${INSTALL_DATA} ${DISTDIR}/typesearch.py ${PREFIX}/lib/${PORTNAME}/plugins/
+.endif
post-install:
${RM} ${DOCSDIR}/INSTALL ${DOCSDIR}/LICENSE
diff --git a/deskutils/treeline/distinfo b/deskutils/treeline/distinfo
index 36939c052ef0..6241b2c3cf72 100644
--- a/deskutils/treeline/distinfo
+++ b/deskutils/treeline/distinfo
@@ -1,6 +1,9 @@
-MD5 (treeline-1.0.0.tar.gz) = dbfd250aa07924011aeeec4dd59efd90
-SHA256 (treeline-1.0.0.tar.gz) = 522b95a5fc4119e0a9edac3d05f85aaa50b0f0b7509e673c7406ec5053b69803
-SIZE (treeline-1.0.0.tar.gz) = 331039
+MD5 (treeline-1.0.2.tar.gz) = a37be34ae9e495364547485233b4c75d
+SHA256 (treeline-1.0.2.tar.gz) = df6cc44842eadfd01e73037a6b611088bc19f44cbbe4e78844ad9638fbda4104
+SIZE (treeline-1.0.2.tar.gz) = 332001
MD5 (httpload.py) = 9680667db5496366c9fc040edab44618
SHA256 (httpload.py) = f3da52451a415d4f445ba9179f54ddf73175bdc583d892f70ed0db4b6e897922
SIZE (httpload.py) = 1735
+MD5 (typesearch.py) = c8e3b1db30ba30ccb24bcb6b4617446b
+SHA256 (typesearch.py) = 3c71751703f4a7d3f47c2354c6a4bda5df826fe41b08a5a8b90c016748ee3ef2
+SIZE (typesearch.py) = 2962
diff --git a/deskutils/treeline/pkg-plist b/deskutils/treeline/pkg-plist
index e916006c69c8..1374dea8d153 100644
--- a/deskutils/treeline/pkg-plist
+++ b/deskutils/treeline/pkg-plist
@@ -74,6 +74,7 @@ lib/treeline/treexmlparse.pyc
lib/treeline/undo.py
lib/treeline/undo.pyc
%%HTTPLOAD%%lib/treeline/plugins/httpload.py
+%%TYPESEARCH%%lib/treeline/plugins/typesearch.py
%%DATADIR%%/icons/anchor.png
%%DATADIR%%/icons/arrow_1.png
%%DATADIR%%/icons/arrow_2.png