aboutsummaryrefslogtreecommitdiff
path: root/deskutils/treeline
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-07-10 19:41:30 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-07-10 19:41:30 +0000
commite482e392f687b2248d2975d68327324a858e1273 (patch)
treef00883f68004a81b9e525ad5cc94de309898b666 /deskutils/treeline
parent5183b406511b98ffef72263a3609234aaaa0d4fb (diff)
downloadports-e482e392f687b2248d2975d68327324a858e1273.tar.gz
ports-e482e392f687b2248d2975d68327324a858e1273.zip
Convert my ports to current standards
- Switch USE_GMAKE to USES=gmake - Define supported options so users can see them in config dialogs - Use OPTIONS_SUB for plist alteration - Convert to options macros for better readability - Use PORTDOCS where it makes sense
Notes
Notes: svn path=/head/; revision=322729
Diffstat (limited to 'deskutils/treeline')
-rw-r--r--deskutils/treeline/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/deskutils/treeline/Makefile b/deskutils/treeline/Makefile
index f8c3b4a1a643..f6c55034ac14 100644
--- a/deskutils/treeline/Makefile
+++ b/deskutils/treeline/Makefile
@@ -39,16 +39,12 @@ ISPELL_DESC= Install with ispell support
PYXML_DESC= Use pythons py-xml instead of textproc/expat2
OPTIONS_DEFAULT= ASPELL PYXML
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MASPELL}
-BUILD_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
-.endif
+ASPELL_BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+ISPELL_BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
-.if ${PORT_OPTIONS:MISPELL}
-BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
-.endif
+.include <bsd.port.options.mk>
.if !${PORT_OPTIONS:MPYXML}
LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2
@@ -56,9 +52,6 @@ LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2
.if ${PORT_OPTIONS:MHTTPLOAD}
DISTFILES+= httpload2.py:plugins
-PLIST_SUB+= HTTPLOAD=""
-.else
-PLIST_SUB+= HTTPLOAD="@comment "
.endif
do-install: