aboutsummaryrefslogtreecommitdiff
path: root/deskutils/treesheets
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-10-26 18:15:12 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-10-26 18:15:12 +0000
commit916e86692eee7e7fd2059dbeae3ab77223c4812c (patch)
tree27ad46ec8ec4d89f33c78cc5c98aeb6ec7996fab /deskutils/treesheets
parent366618aa5134d4432195e756f70aa85ab733bc3e (diff)
Notes
Diffstat (limited to 'deskutils/treesheets')
-rw-r--r--deskutils/treesheets/Makefile71
-rw-r--r--deskutils/treesheets/distinfo2
-rw-r--r--deskutils/treesheets/pkg-descr14
3 files changed, 87 insertions, 0 deletions
diff --git a/deskutils/treesheets/Makefile b/deskutils/treesheets/Makefile
new file mode 100644
index 000000000000..4fab4cccdd57
--- /dev/null
+++ b/deskutils/treesheets/Makefile
@@ -0,0 +1,71 @@
+# Created by: lightside <lightside@gmx.com>
+# $FreeBSD$
+
+PORTNAME= treesheets
+PORTVERSION= 0.0.20141016
+CATEGORIES= deskutils
+
+MAINTAINER= lightside@gmx.com
+COMMENT= Free form data organizer
+
+LICENSE= ZLIB
+LICENSE_FILE= ${WRKSRC}/ZLIB_LICENSE.txt
+
+USE_GITHUB= yes
+GH_ACCOUNT= aardappel
+GH_PROJECT= ${PORTNAME}
+GH_COMMIT= 2cca487
+GH_TAGNAME= ${GH_COMMIT}
+
+BUILD_WRKSRC= ${WRKSRC}/src
+EXTRACT_AFTER_ARGS= --exclude .gitignore
+
+USES= compiler:c++11-lang
+USE_WX= 3.0+
+WX_UNICODE= yes
+
+PORTDATA= images
+PORTDOCS= docs *.html
+PORTEXAMPLES= *
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+
+DESKTOP_ENTRIES="TreeSheets" "${COMMENT}" \
+ "${PORTNAME}" "${PORTNAME}" \
+ "Office;Utility;" true
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 900014
+CXXFLAGS+= -D__LONG_LONG_SUPPORTED
+.endif
+
+post-patch: .SILENT
+ ${REINPLACE_CMD} -e 's|c++|${CXX}|; \
+ s|-O3|${CXXFLAGS}| ; \
+ s|wx-config|${WX_CONFIG}| ; \
+ /^mv treesheets/d' \
+ ${BUILD_WRKSRC}/build.sh
+ ${REINPLACE_CMD} -e 's|sys->frame->exepath+L"|L"${DOCSDIR}|' \
+ ${BUILD_WRKSRC}/document.h
+ ${REINPLACE_CMD} -e 's|wxFileName(exename).GetPath()|L"${DATADIR}"|' \
+ ${BUILD_WRKSRC}/myframe.h
+ ${REINPLACE_CMD} -e 's|frame->exepath+L"/examples|L"${EXAMPLESDIR}|' \
+ ${BUILD_WRKSRC}/system.h
+
+do-build:
+ (cd ${BUILD_WRKSRC} && ${SH} build.sh)
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ (cd ${WRKSRC}/TS && ${COPYTREE_SHARE} "${PORTDATA}" ${STAGEDIR}${DATADIR})
+ (cd ${WRKSRC}/TS && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
+ (cd ${WRKSRC}/TS/examples && ${COPYTREE_SHARE} "${PORTEXAMPLES}" \
+ ${STAGEDIR}${EXAMPLESDIR})
+ ${INSTALL_DATA} ${WRKSRC}/TS/images/icon32.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/treesheets/distinfo b/deskutils/treesheets/distinfo
new file mode 100644
index 000000000000..8705533f745a
--- /dev/null
+++ b/deskutils/treesheets/distinfo
@@ -0,0 +1,2 @@
+SHA256 (treesheets-0.0.20141016.tar.gz) = d9e11711f5908dd61493faaf8f593e029db89b8c7fed15fbc7ee2d97a6d2e684
+SIZE (treesheets-0.0.20141016.tar.gz) = 1792312
diff --git a/deskutils/treesheets/pkg-descr b/deskutils/treesheets/pkg-descr
new file mode 100644
index 000000000000..4f36cdba7277
--- /dev/null
+++ b/deskutils/treesheets/pkg-descr
@@ -0,0 +1,14 @@
+The ultimate replacement for spreadsheets, mind mappers, outliners, PIMs, text
+editors and small databases.
+
+Suitable for any kind of data organization, such as Todo lists, calendars,
+project management, brainstorming, organizing ideas, planning, requirements
+gathering, presentation of information, etc.
+
+It's like a spreadsheet, immediately familiar, but much more suitable for
+complex data because it's hierarchical.
+It's like a mind mapper, but more organized and compact.
+It's like an outliner, but in more than one dimension.
+It's like a text editor, but with structure.
+
+WWW: http://treesheets.com