aboutsummaryrefslogtreecommitdiff
path: root/deskutils/wmpinboard
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-04-19 08:54:31 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-04-19 08:54:31 +0000
commitfdd13a819c067d54d0b9c4f763c032a54f8f764f (patch)
tree7da1d0c81f43452f0eebf109036852ce634ba31e /deskutils/wmpinboard
parentcfb4b331001c7888efa1723c48b2645e0d71473c (diff)
downloadports-fdd13a819c067d54d0b9c4f763c032a54f8f764f.tar.gz
ports-fdd13a819c067d54d0b9c4f763c032a54f8f764f.zip
Notes
Diffstat (limited to 'deskutils/wmpinboard')
-rw-r--r--deskutils/wmpinboard/Makefile11
-rw-r--r--deskutils/wmpinboard/distinfo2
-rw-r--r--deskutils/wmpinboard/files/patch-ac16
-rw-r--r--deskutils/wmpinboard/files/patch-configure11
-rw-r--r--deskutils/wmpinboard/files/patch-src::Makefile.in11
-rw-r--r--deskutils/wmpinboard/files/patch-src::getopt.c30
-rw-r--r--deskutils/wmpinboard/files/patch-src::misc.c10
-rw-r--r--deskutils/wmpinboard/files/patch-src::wmpinboard.c24
-rw-r--r--deskutils/wmpinboard/files/patch-src::xmisc.c11
9 files changed, 102 insertions, 24 deletions
diff --git a/deskutils/wmpinboard/Makefile b/deskutils/wmpinboard/Makefile
index b699c7113639..dbe3d1fba67f 100644
--- a/deskutils/wmpinboard/Makefile
+++ b/deskutils/wmpinboard/Makefile
@@ -6,22 +6,19 @@
#
PORTNAME= wmpinboard
-PORTVERSION= 0.10
+PORTVERSION= 1.0
CATEGORIES= deskutils afterstep windowmaker
MASTER_SITES= http://www.tu-ilmenau.de/~gomar/stuff/wmpinboard/ \
http://soupnazi.org/FreeBSD/ports/distfiles/
MAINTAINER= jim@FreeBSD.org
-WRKSRC= ${WRKDIR}/wmpinboard.app
-
USE_BZIP2= yes
-USE_IMAKE= yes
USE_XPM= yes
+GNU_CONFIGURE= yes
-MAN1= wmpinboard.1
+INSTALL_TARGET= install-strip
-post-extract:
- (cd ${WRKSRC}; ${CP} -p wmpinboard.1 wmpinboard.man)
+MAN1= wmpinboard.1
.include <bsd.port.mk>
diff --git a/deskutils/wmpinboard/distinfo b/deskutils/wmpinboard/distinfo
index 0eea91dab0b6..1071136de319 100644
--- a/deskutils/wmpinboard/distinfo
+++ b/deskutils/wmpinboard/distinfo
@@ -1 +1 @@
-MD5 (wmpinboard-0.10.tar.bz2) = 3517fe843867ae8c3c925e1328b22f4a
+MD5 (wmpinboard-1.0.tar.bz2) = 5a270397f7765b3416abae43d020a0c9
diff --git a/deskutils/wmpinboard/files/patch-ac b/deskutils/wmpinboard/files/patch-ac
deleted file mode 100644
index c3f125a407bb..000000000000
--- a/deskutils/wmpinboard/files/patch-ac
+++ /dev/null
@@ -1,16 +0,0 @@
---- Imakefile.orig Sat Oct 23 19:49:37 1999
-+++ Imakefile Wed Nov 1 09:24:28 2000
-@@ -36,9 +36,9 @@
- all::
- @test -e ./ReleaseNotes && cat ReleaseNotes || true
-
--install::
-- $(INSTALL) -m 0644 wmpinboard.1 $(DESTDIR)/man/man1
-+#install::
-+# $(INSTALL) -m 0644 wmpinboard.1 $(DESTDIR)/man/man1
-
--DESTDIR = /usr/local
--BINDIR = /bin
-+#DESTDIR = /usr/local
-+#BINDIR = /bin
-
diff --git a/deskutils/wmpinboard/files/patch-configure b/deskutils/wmpinboard/files/patch-configure
new file mode 100644
index 000000000000..689b5289d6e4
--- /dev/null
+++ b/deskutils/wmpinboard/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Wed Apr 18 13:02:06 2001
++++ configure Wed Apr 18 13:02:10 2001
+@@ -1035,7 +1035,7 @@
+ cross_compiling=$ac_cv_prog_cc_cross
+
+
+-CFLAGS="$CFLAGS -D_BSD_SOURCE -D_POSIX_SOURCE=199506L"
++#CFLAGS="$CFLAGS -D_BSD_SOURCE -D_POSIX_SOURCE=199506L"
+
+ if test x$GCC = xyes; then
+ CFLAGS="$CFLAGS -Wall -ansi -pedantic"
diff --git a/deskutils/wmpinboard/files/patch-src::Makefile.in b/deskutils/wmpinboard/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..eaec98af446f
--- /dev/null
+++ b/deskutils/wmpinboard/files/patch-src::Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Wed Apr 18 13:15:59 2001
++++ src/Makefile.in Wed Apr 18 13:16:06 2001
+@@ -86,7 +86,7 @@
+ X_LIBS = @X_LIBS@
+ X_EXTRA_LIBS = @X_EXTRA_LIBS@
+ X_PRE_LIBS = @X_PRE_LIBS@
+-wmpinboard_OBJECTS = misc.o notes.o wmpinboard.o xmisc.o
++wmpinboard_OBJECTS = misc.o notes.o wmpinboard.o xmisc.o getopt.o getopt1.o
+ wmpinboard_LDADD = $(LDADD)
+ wmpinboard_DEPENDENCIES =
+ wmpinboard_LDFLAGS =
diff --git a/deskutils/wmpinboard/files/patch-src::getopt.c b/deskutils/wmpinboard/files/patch-src::getopt.c
new file mode 100644
index 000000000000..6bc5c28e2cca
--- /dev/null
+++ b/deskutils/wmpinboard/files/patch-src::getopt.c
@@ -0,0 +1,30 @@
+--- getopt.c.orig Wed Sep 1 17:49:35 1999
++++ src/getopt.c Wed Apr 18 13:26:19 2001
+@@ -73,9 +73,9 @@
+
+ #ifdef VMS
+ #include <unixlib.h>
+-#if HAVE_STRING_H - 0
+-#include <string.h>
+ #endif
++#if HAVE_STRING_H
++#include <string.h>
+ #endif
+
+ #if defined (WIN32) && !defined (__CYGWIN32__)
+@@ -650,6 +650,7 @@
+ else
+ {
+ if (opterr)
++ {
+ if (argv[optind - 1][1] == '-')
+ /* --option */
+ fprintf(stderr,
+@@ -660,6 +661,7 @@
+ fprintf(stderr,
+ _("%s: option `%c%s' doesn't allow an argument\n"),
+ argv[0], argv[optind - 1][0], pfound->name);
++ }
+
+ nextchar += strlen(nextchar);
+
diff --git a/deskutils/wmpinboard/files/patch-src::misc.c b/deskutils/wmpinboard/files/patch-src::misc.c
new file mode 100644
index 000000000000..4d9576b834c1
--- /dev/null
+++ b/deskutils/wmpinboard/files/patch-src::misc.c
@@ -0,0 +1,10 @@
+--- misc.c.orig Thu Mar 16 19:54:45 2000
++++ src/misc.c Wed Apr 18 12:45:21 2001
+@@ -8,6 +8,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <time.h>
++#include <sys/types.h>
+ #include <sys/stat.h>
+
+ #include "wmpinboard.h"
diff --git a/deskutils/wmpinboard/files/patch-src::wmpinboard.c b/deskutils/wmpinboard/files/patch-src::wmpinboard.c
new file mode 100644
index 000000000000..90606f1723e9
--- /dev/null
+++ b/deskutils/wmpinboard/files/patch-src::wmpinboard.c
@@ -0,0 +1,24 @@
+--- wmpinboard.c.orig Thu Apr 13 15:01:17 2000
++++ src/wmpinboard.c Wed Apr 18 13:06:36 2001
+@@ -10,6 +10,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <time.h>
++#include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+
+@@ -1141,13 +1142,7 @@
+ void
+ timer(unsigned int intv)
+ {
+-#ifndef __GLIBC__
+- struct itimerval val = { { 0, intv }, { 0, intv } };
+-
+- setitimer(ITIMER_REAL, &val, 0);
+-#else
+ ualarm(intv, intv);
+-#endif
+ }
+
+ /*
diff --git a/deskutils/wmpinboard/files/patch-src::xmisc.c b/deskutils/wmpinboard/files/patch-src::xmisc.c
new file mode 100644
index 000000000000..e8e4582cf328
--- /dev/null
+++ b/deskutils/wmpinboard/files/patch-src::xmisc.c
@@ -0,0 +1,11 @@
+--- xmisc.c.orig Wed Apr 18 13:23:16 2001
++++ src/xmisc.c Wed Apr 18 13:23:22 2001
+@@ -298,7 +298,7 @@
+ if (cb_buffer) free(cb_buffer);
+ l = len < 0 ? strlen(text) : len;
+ cb_buffer = smalloc(l+1);
+- strncpy(cb_buffer, text, l);
++ strncpy((char *)cb_buffer, text, l);
+ cb_buffer[l] = 0;
+
+ XSetSelectionOwner(display, XA_PRIMARY, win, CurrentTime);