aboutsummaryrefslogtreecommitdiff
path: root/deskutils/wyrd
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-04-11 08:34:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-04-11 08:34:17 +0000
commit8d27ddb9bd993385ce5d7a9b17e2fe231ec8c69f (patch)
tree82565381028ebd8b5a674bafdecce3a45c5c2e6d /deskutils/wyrd
parent0a59b351f616abe849539bc2afbc8eba4abe8004 (diff)
Add a new macro to deal with conflict between ncurses from base and ncurses from ports.
If a ports is linked against ncurses from base or from the ports, it should then add: USE_NCURSES=yes it is also possible to specify the hard dependency on the ports ncurses or one the base one adding the following macros: WITH_NCURSES_PORT=yes or WITH_NCURSES_BASE=yes PR: ports/155269 Submitted by: me Reviwed by: pav@ Approved by: portmgr (pav@) Exp-run by: portmgr (pav@)
Notes
Notes: svn path=/head/; revision=272515
Diffstat (limited to 'deskutils/wyrd')
-rw-r--r--deskutils/wyrd/Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/deskutils/wyrd/Makefile b/deskutils/wyrd/Makefile
index 4d5521d46a3c..53653d62fbac 100644
--- a/deskutils/wyrd/Makefile
+++ b/deskutils/wyrd/Makefile
@@ -22,29 +22,19 @@ OPTIONS= UTF8 "Enable UTF-8 support" off
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_NCURSES= yes
MAN1= wyrd.1
MAN5= wyrdrc.5
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 602107 || (${OSVERSION} > 700000 && ${OSVERSION} < 700033)
-WITH_NCURSES_PORT=yes
-.endif
-
.if defined(WITH_UTF8)
CONFIGURE_ARGS+=--enable-utf8
-.if defined(WITH_NCURSES_PORT)
-LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
-NCURSES_INC= ncurses/
-.endif
.else
CONFIGURE_ARGS+=--disable-utf8
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|ncursesw/|${NCURSES_INC}|' ${WRKSRC}/configure
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wyrd.opt ${PREFIX}/bin/wyrd
${INSTALL_DATA} ${WRKSRC}/wyrdrc ${PREFIX}/etc/wyrdrc