aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xfce4-calendar
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-01-15 08:38:59 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-01-15 08:38:59 +0000
commit23578a1604a79de62fb44f5133d5a95eaf03825d (patch)
tree1ae14a4c36a147603ae5736003a0fc7b684247ac /deskutils/xfce4-calendar
parent59336fe39cef4e06b739e9f918a21c8796bf7a11 (diff)
downloadports-23578a1604a79de62fb44f5133d5a95eaf03825d.tar.gz
ports-23578a1604a79de62fb44f5133d5a95eaf03825d.zip
Notes
Diffstat (limited to 'deskutils/xfce4-calendar')
-rw-r--r--deskutils/xfce4-calendar/Makefile28
-rw-r--r--deskutils/xfce4-calendar/distinfo1
-rw-r--r--deskutils/xfce4-calendar/pkg-descr4
-rw-r--r--deskutils/xfce4-calendar/pkg-plist5
4 files changed, 38 insertions, 0 deletions
diff --git a/deskutils/xfce4-calendar/Makefile b/deskutils/xfce4-calendar/Makefile
new file mode 100644
index 000000000000..6930557bb0dc
--- /dev/null
+++ b/deskutils/xfce4-calendar/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: xfce4-calendar
+# Date created: 2003-01-14
+# Whom: Matt Lancereau <matt@rimasec.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-calendar
+PORTVERSION= 0.1.5
+CATEGORIES= deskutils xfce
+MASTER_SITES= http://xfce.org/archive/xfce-4.0.3.1/src/
+DISTNAME= xfcalendar-${PORTVERSION}
+DIST_SUBDIR= xfce4
+
+MAINTAINER= matt@rimasec.net
+COMMENT= A calendar application to manage your time with XFce 4
+
+BUILD_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui
+
+USE_GNOME= gtk20 libxml2
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>
diff --git a/deskutils/xfce4-calendar/distinfo b/deskutils/xfce4-calendar/distinfo
new file mode 100644
index 000000000000..869ad2ecca59
--- /dev/null
+++ b/deskutils/xfce4-calendar/distinfo
@@ -0,0 +1 @@
+MD5 (xfce4/xfcalendar-0.1.5.tar.gz) = e08db4fa5f2486f3bbb8414036be22e4
diff --git a/deskutils/xfce4-calendar/pkg-descr b/deskutils/xfce4-calendar/pkg-descr
new file mode 100644
index 000000000000..7d6550f13e0c
--- /dev/null
+++ b/deskutils/xfce4-calendar/pkg-descr
@@ -0,0 +1,4 @@
+A calendar application to manage your time with XFce 4.
+
+Author: Mickael Graf <korbinus@linux.se>
+WWW: http://xfce.org/archive/xfce-4.0.3.1/src/
diff --git a/deskutils/xfce4-calendar/pkg-plist b/deskutils/xfce4-calendar/pkg-plist
new file mode 100644
index 000000000000..4b6c148345fe
--- /dev/null
+++ b/deskutils/xfce4-calendar/pkg-plist
@@ -0,0 +1,5 @@
+bin/xfcalendar
+lib/xfce4/mcs-plugins/xfcalendar_plugin.so
+lib/xfce4/mcs-plugins/xfcalendar_plugin.la
+lib/xfce4/mcs-plugins/xfcalendar_plugin.a
+@unexec rmdir %D/lib/xfce4/mcs-plugins 2>/dev/null || true