aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xfce4-notes-plugin
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2007-01-22 16:45:10 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2007-01-22 16:45:10 +0000
commit307bdced85efa099cb28882bf2904d68809a7547 (patch)
treea8d9f0fef2ab3a02971ab0000c95884bb3b29557 /deskutils/xfce4-notes-plugin
parent7f941ef93ab911655cb1a2e6b7c89f115be1318c (diff)
downloadports-307bdced85efa099cb28882bf2904d68809a7547.tar.gz
ports-307bdced85efa099cb28882bf2904d68809a7547.zip
Notes
Diffstat (limited to 'deskutils/xfce4-notes-plugin')
-rw-r--r--deskutils/xfce4-notes-plugin/Makefile25
-rw-r--r--deskutils/xfce4-notes-plugin/distinfo9
-rw-r--r--deskutils/xfce4-notes-plugin/files/patch-configure21
-rw-r--r--deskutils/xfce4-notes-plugin/pkg-descr2
-rw-r--r--deskutils/xfce4-notes-plugin/pkg-plist27
5 files changed, 40 insertions, 44 deletions
diff --git a/deskutils/xfce4-notes-plugin/Makefile b/deskutils/xfce4-notes-plugin/Makefile
index 1be7b2a693a0..592379d2ff0d 100644
--- a/deskutils/xfce4-notes-plugin/Makefile
+++ b/deskutils/xfce4-notes-plugin/Makefile
@@ -6,23 +6,24 @@
#
PORTNAME= xfce4-notes-plugin
-PORTVERSION= 0.9.7
-PORTREVISION= 8
+PORTVERSION= 1.4.1
CATEGORIES= deskutils xfce
-MASTER_SITES= http://download.berlios.de/xfce-goodies/
+MASTER_SITES= http://goodies.xfce.org/releases/${PORTNAME}/
DIST_SUBDIR= xfce4
+PATCH_SITES= http://people.freebsd.org/~oliver/xfce/
+PATCHFILES= gcc295-xfce4-notes-plugin.patch
MAINTAINER= thorsten.greiner@web.de
COMMENT= Sticky notes panel plugin for XFce4
-BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
-LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
- xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui
-RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
-
-USE_GNOME= gtk20 libxml2
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
+USE_XFCE= configenv libgui libutil panel
+USE_XLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
+.include <bsd.port.post.mk>
diff --git a/deskutils/xfce4-notes-plugin/distinfo b/deskutils/xfce4-notes-plugin/distinfo
index 4c2d1ed78aeb..f406e7e92925 100644
--- a/deskutils/xfce4-notes-plugin/distinfo
+++ b/deskutils/xfce4-notes-plugin/distinfo
@@ -1,3 +1,6 @@
-MD5 (xfce4/xfce4-notes-plugin-0.9.7.tar.gz) = d043d4f5b00b4a7f3d5107b65d81de8e
-SHA256 (xfce4/xfce4-notes-plugin-0.9.7.tar.gz) = c86290c6058ce22e56794028ca2b9b3e03063073f4b39a85c967a0d20e236e8f
-SIZE (xfce4/xfce4-notes-plugin-0.9.7.tar.gz) = 326290
+MD5 (xfce4/xfce4-notes-plugin-1.4.1.tar.bz2) = 6f20d84bf3aadd6c974f226c04f33050
+SHA256 (xfce4/xfce4-notes-plugin-1.4.1.tar.bz2) = 7683bb239fea66cd03895504d9311608b00a3e024a568465e84fe52adb35860e
+SIZE (xfce4/xfce4-notes-plugin-1.4.1.tar.bz2) = 157811
+MD5 (xfce4/gcc295-xfce4-notes-plugin.patch) = 415d28a7a121d8df6dcf18a9ce35343d
+SHA256 (xfce4/gcc295-xfce4-notes-plugin.patch) = a0c213dd93f493fd68a85116cff76aa039f7631c1f14e36305679d82e7b3ba7b
+SIZE (xfce4/gcc295-xfce4-notes-plugin.patch) = 1188
diff --git a/deskutils/xfce4-notes-plugin/files/patch-configure b/deskutils/xfce4-notes-plugin/files/patch-configure
deleted file mode 100644
index 53b00d19c534..000000000000
--- a/deskutils/xfce4-notes-plugin/files/patch-configure
+++ /dev/null
@@ -1,21 +0,0 @@
---- configure.orig Sun Oct 5 02:45:14 2003
-+++ configure Mon Oct 6 20:22:50 2003
-@@ -19530,7 +19530,8 @@
-
-
- # This can be used to rebuild libtool when needed
--LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS="--disable-ltlibs /usr/local/share/libtool13/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -19824,7 +19825,7 @@
-
- echo "$as_me:$LINENO: checking where to install panel plugins" >&5
- echo $ECHO_N "checking where to install panel plugins... $ECHO_C" >&6
-- XFCE4_PANEL_PLUGINSDIR=`$PKG_CONFIG --variable=pluginsdir xfce4-panel-1.0`
-+ XFCE4_PANEL_PLUGINSDIR=${prefix}/lib/xfce4/panel-plugins
-
- echo "$as_me:$LINENO: result: $XFCE4_PANEL_PLUGINSDIR" >&5
- echo "${ECHO_T}$XFCE4_PANEL_PLUGINSDIR" >&6
diff --git a/deskutils/xfce4-notes-plugin/pkg-descr b/deskutils/xfce4-notes-plugin/pkg-descr
index b81ce3efe202..a83a3c336c62 100644
--- a/deskutils/xfce4-notes-plugin/pkg-descr
+++ b/deskutils/xfce4-notes-plugin/pkg-descr
@@ -1,3 +1,3 @@
A sticky notes panel plugin for XFce4.
-WWW: http://www.xfce.org
+WWW: http://www.xfce.org/
diff --git a/deskutils/xfce4-notes-plugin/pkg-plist b/deskutils/xfce4-notes-plugin/pkg-plist
index 88a5c98e1089..1f405ebcc41a 100644
--- a/deskutils/xfce4-notes-plugin/pkg-plist
+++ b/deskutils/xfce4-notes-plugin/pkg-plist
@@ -1,8 +1,21 @@
-lib/xfce4/panel-plugins/libnotes.a
-lib/xfce4/panel-plugins/libnotes.la
-lib/xfce4/panel-plugins/libnotes.so
-share/xfce4/notes/note.png
-@dirrmtry lib/xfce4/panel-plugins
-@dirrmtry lib/xfce4
-@dirrmtry share/xfce4/notes
+bin/xfce4-popup-notes
+libexec/xfce4/panel-plugins/xfce4-notes-plugin
+share/icons/hicolor/16x16/apps/xfce4-notes-plugin.png
+share/icons/hicolor/22x22/apps/xfce4-notes-plugin.png
+share/icons/hicolor/24x24/apps/xfce4-notes-plugin.png
+share/icons/hicolor/32x32/apps/xfce4-notes-plugin.png
+share/icons/hicolor/scalable/apps/xfce4-notes-plugin.svg
+share/locale/ca/LC_MESSAGES/xfce4-notes-plugin.mo
+share/locale/cs/LC_MESSAGES/xfce4-notes-plugin.mo
+share/locale/de/LC_MESSAGES/xfce4-notes-plugin.mo
+share/locale/eu/LC_MESSAGES/xfce4-notes-plugin.mo
+share/locale/fr/LC_MESSAGES/xfce4-notes-plugin.mo
+share/locale/hu/LC_MESSAGES/xfce4-notes-plugin.mo
+share/locale/nl/LC_MESSAGES/xfce4-notes-plugin.mo
+share/locale/pl/LC_MESSAGES/xfce4-notes-plugin.mo
+share/locale/zh_TW/LC_MESSAGES/xfce4-notes-plugin.mo
+share/xfce4/panel-plugins/xfce4-notes-plugin.desktop
+@dirrmtry share/xfce4/panel-plugins
@dirrmtry share/xfce4
+@dirrmtry libexec/xfce4/panel-plugins
+@dirrmtry libexec/xfce4