aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xfce4-notifyd
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2009-10-22 12:11:46 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2009-10-22 12:11:46 +0000
commit74c3e17cb2c3f7b9ce0d09bbc200028e56c6bbc4 (patch)
tree621debf4694ea94ec84117285c46282bfbde2c9b /deskutils/xfce4-notifyd
parentb1beaacd92babbe1d3883658fb878e1877466e14 (diff)
downloadports-74c3e17cb2c3f7b9ce0d09bbc200028e56c6bbc4.tar.gz
ports-74c3e17cb2c3f7b9ce0d09bbc200028e56c6bbc4.zip
Notes
Diffstat (limited to 'deskutils/xfce4-notifyd')
-rw-r--r--deskutils/xfce4-notifyd/Makefile46
-rw-r--r--deskutils/xfce4-notifyd/distinfo3
-rw-r--r--deskutils/xfce4-notifyd/pkg-descr9
-rw-r--r--deskutils/xfce4-notifyd/pkg-plist28
4 files changed, 86 insertions, 0 deletions
diff --git a/deskutils/xfce4-notifyd/Makefile b/deskutils/xfce4-notifyd/Makefile
new file mode 100644
index 000000000000..ead5a342f09e
--- /dev/null
+++ b/deskutils/xfce4-notifyd/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: xfce4-notifyd
+# Date created: 22 Oct 2009
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-notifyd
+PORTVERSION= 0.1.0
+CATEGORIES= deskutils xfce
+MASTER_SITES= http://spuriousinterrupt.org/files/xfce4-notifyd/ \
+ CRITICAL
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Visually-appealing notification daemon for Xfce
+
+LIB_DEPENDS= sexy.2:${PORTSDIR}/x11-toolkits/libsexy \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= intltool
+USE_XFCE= configenv libutil libgui
+INSTALLS_ICONS= yes
+
+CONFLICTS= notification-daemon-[0-9]* xfce4-notification-daemon-[0-9]*
+
+OPTIONS= NLS "Enable Native Language Support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch: .SILENT
+.if defined(WITHOUT_NLS)
+ ${REINPLACE_CMD} -e 's|\(USE_NLS=\)yes|\1no|' ${WRKSRC}/configure
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/xfce4-notifyd/distinfo b/deskutils/xfce4-notifyd/distinfo
new file mode 100644
index 000000000000..0f48830a04f1
--- /dev/null
+++ b/deskutils/xfce4-notifyd/distinfo
@@ -0,0 +1,3 @@
+MD5 (xfce4-notifyd-0.1.0.tar.bz2) = 659ecaf37f0f7ee9e31f7b25f9813778
+SHA256 (xfce4-notifyd-0.1.0.tar.bz2) = 989b0e9ae9ff5bdbdbf56368a44eca039236033f84d05001e311c21c988bd0e1
+SIZE (xfce4-notifyd-0.1.0.tar.bz2) = 165593
diff --git a/deskutils/xfce4-notifyd/pkg-descr b/deskutils/xfce4-notifyd/pkg-descr
new file mode 100644
index 000000000000..879753d0975c
--- /dev/null
+++ b/deskutils/xfce4-notifyd/pkg-descr
@@ -0,0 +1,9 @@
+A simple, visually-appealing notification daemon for Xfce that implements the
+Freedesktop.org Desktop Notifications Specification.
+
+Features:
+ * Themable using the GTK+ theming mechanism
+ * Visually appealing: rounded corners, shaped windows
+ * Supports transparency and fade effects
+
+WWW: http://spuriousinterrupt.org/projects/xfce4-notifyd
diff --git a/deskutils/xfce4-notifyd/pkg-plist b/deskutils/xfce4-notifyd/pkg-plist
new file mode 100644
index 000000000000..bf841845a4a9
--- /dev/null
+++ b/deskutils/xfce4-notifyd/pkg-plist
@@ -0,0 +1,28 @@
+bin/xfce4-notifyd-config
+libexec/xfce4-notifyd
+share/applications/xfce4-notifyd-config.desktop
+share/dbus-1/services/org.freedesktop.Notifications.service
+share/icons/hicolor/48x48/apps/xfce4-notifyd.png
+share/themes/Default/xfce-notify-4.0/gtkrc
+share/themes/Smoke/xfce-notify-4.0/gtkrc
+share/themes/ZOMG-PONIES!/xfce-notify-4.0/gtkrc
+%%NLS%%share/locale/ca/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/el/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/id/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xfce4-notifyd.mo
+@dirrm share/themes/ZOMG-PONIES!/xfce-notify-4.0
+@dirrm share/themes/ZOMG-PONIES!
+@dirrm share/themes/Smoke/xfce-notify-4.0
+@dirrm share/themes/Smoke
+@dirrm share/themes/Default/xfce-notify-4.0
+@dirrmtry share/themes/Default
+@dirrmtry share/applications