aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xfce4-taskbar-plugin/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-05-07 13:08:36 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-05-07 13:08:36 +0000
commit1e94fc4ae32ac3041606443fc9d17e38ad21e1ac (patch)
tree39451c1bf4b87dd24eeac5c778c6ece8e7fd1031 /deskutils/xfce4-taskbar-plugin/Makefile
parent3e7a3ca7508c1de1f69194fd69152543da67f1ce (diff)
Add xfce4-taskbar-plugin 0.1.0, a taskbar plugin for xfce4-panel.
PR: ports/65984 Submitted by: Matt Lancereau <matt@rimasec.net>
Notes
Notes: svn path=/head/; revision=108616
Diffstat (limited to 'deskutils/xfce4-taskbar-plugin/Makefile')
-rw-r--r--deskutils/xfce4-taskbar-plugin/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/deskutils/xfce4-taskbar-plugin/Makefile b/deskutils/xfce4-taskbar-plugin/Makefile
new file mode 100644
index 000000000000..497068162654
--- /dev/null
+++ b/deskutils/xfce4-taskbar-plugin/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xfce4-taskbar-plugin
+# Date created: 2003-04-26
+# Whom: Matt Lancereau <matt@rimasec.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-taskbar-plugin
+PORTVERSION= 0.1.0
+CATEGORIES= deskutils xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/ \
+ http://www.bsd-blax.org/ports/mirrors/
+DISTNAME= xfce4-taskbar-plugin-${PORTVERSION}
+
+MAINTAINER= matt@rimasec.net
+COMMENT= A taskbar plugin for xfce4-panel
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+
+USE_GNOME= gtk20 libxml2
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=13
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.mk>