aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xfce4-volumed-pulse
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2014-11-21 13:07:14 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2014-11-21 13:07:14 +0000
commit3981b8c7d2eb5cd8e1742bd89e80ea8277a815fc (patch)
tree4aa83a071cfc2d2ea6de95590615b06520640358 /deskutils/xfce4-volumed-pulse
parent59c942ef4d12e739247ba0d72118237d6687d28c (diff)
downloadports-3981b8c7d2eb5cd8e1742bd89e80ea8277a815fc.tar.gz
ports-3981b8c7d2eb5cd8e1742bd89e80ea8277a815fc.zip
Notes
Diffstat (limited to 'deskutils/xfce4-volumed-pulse')
-rw-r--r--deskutils/xfce4-volumed-pulse/Makefile29
-rw-r--r--deskutils/xfce4-volumed-pulse/distinfo2
-rw-r--r--deskutils/xfce4-volumed-pulse/pkg-descr8
-rw-r--r--deskutils/xfce4-volumed-pulse/pkg-plist2
4 files changed, 41 insertions, 0 deletions
diff --git a/deskutils/xfce4-volumed-pulse/Makefile b/deskutils/xfce4-volumed-pulse/Makefile
new file mode 100644
index 000000000000..159dd2bba6d9
--- /dev/null
+++ b/deskutils/xfce4-volumed-pulse/Makefile
@@ -0,0 +1,29 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= xfce4-volumed-pulse
+PORTVERSION= 0.2.0
+CATEGORIES= deskutils xfce
+MASTER_SITES= https://launchpadlibrarian.net/133628016/ \
+ https://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= xfce@FreeBSD.org
+COMMENT= Volume management daemon for Xfce using PulseAudio
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio \
+ libnotify.so:${PORTSDIR}/devel/libnotify \
+ libkeybinder.so:${PORTSDIR}/x11/keybinder
+
+USES= pkgconfig gmake tar:bz2
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 gtk20
+USE_XFCE= configenv xfconf
+INSTALL_TARGET= install-strip
+
+CONFIGURE_ARGS=--enable-libnotify
+
+.include <bsd.port.mk>
diff --git a/deskutils/xfce4-volumed-pulse/distinfo b/deskutils/xfce4-volumed-pulse/distinfo
new file mode 100644
index 000000000000..849db437eb3b
--- /dev/null
+++ b/deskutils/xfce4-volumed-pulse/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xfce4/xfce4-volumed-pulse-0.2.0.tar.bz2) = 6930034a30bfa54106f3c76ea8e50f578426f5e6151c0e82fda04e6d127de550
+SIZE (xfce4/xfce4-volumed-pulse-0.2.0.tar.bz2) = 282403
diff --git a/deskutils/xfce4-volumed-pulse/pkg-descr b/deskutils/xfce4-volumed-pulse/pkg-descr
new file mode 100644
index 000000000000..e564d835d6db
--- /dev/null
+++ b/deskutils/xfce4-volumed-pulse/pkg-descr
@@ -0,0 +1,8 @@
+This daemon is responsible of making the volume up/down and mute keys of
+the keyboard work automatically. It uses PulseAudio for chosing which
+card/sink/track to act on.
+
+This is a fork of the original xfce4-volumed to drop GStreamer support
+and use PulseAudio instead.
+
+WWW: https://launchpad.net/xfce4-volumed-pulse
diff --git a/deskutils/xfce4-volumed-pulse/pkg-plist b/deskutils/xfce4-volumed-pulse/pkg-plist
new file mode 100644
index 000000000000..5f430c151e47
--- /dev/null
+++ b/deskutils/xfce4-volumed-pulse/pkg-plist
@@ -0,0 +1,2 @@
+bin/xfce4-volumed-pulse
+etc/xdg/autostart/xfce4-volumed-pulse.desktop