aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xmdiary
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-12-03 19:12:34 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-12-03 19:12:34 +0000
commitfa8d0e026665c58d1fe362433eeff17f7a3e3dce (patch)
treeb9cea2e59be324a47724381f06bf291a2febdad3 /deskutils/xmdiary
parentb517565d8c99205978f67808fea0b17c7f448e0c (diff)
downloadports-fa8d0e026665c58d1fe362433eeff17f7a3e3dce.tar.gz
ports-fa8d0e026665c58d1fe362433eeff17f7a3e3dce.zip
- Remove USE_GCC and fix build with clang.
- Replace nomalloc script with REINPLACE_CMD. - Remove noextradepend script. It is no longer needed. PR: ports/181820 Approved by: maintainer timeout (3 months)
Notes
Notes: svn path=/head/; revision=335588
Diffstat (limited to 'deskutils/xmdiary')
-rw-r--r--deskutils/xmdiary/Makefile10
-rw-r--r--deskutils/xmdiary/files/patch-warnings18
-rw-r--r--deskutils/xmdiary/scripts/noextradepend15
-rw-r--r--deskutils/xmdiary/scripts/nomalloc15
4 files changed, 16 insertions, 42 deletions
diff --git a/deskutils/xmdiary/Makefile b/deskutils/xmdiary/Makefile
index 934ef03e52fa..76821b1505bb 100644
--- a/deskutils/xmdiary/Makefile
+++ b/deskutils/xmdiary/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmdiary
PORTVERSION= 3.0.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= office
@@ -15,7 +15,6 @@ COMMENT= Personal and group calendar utility
NO_CDROM= Don't sell for profit
EXTRACT_ONLY= ${DISTNAME}.tar.gz
USES= imake motif
-USE_GCC= any
USE_XORG= x11 xext xp xpm xt
MAN1= xdaclunix.1 xdalarm.1 xdcustom.1 xddump.1 xdiary.1 xdinitdb.1 \
xdlight.1 xdnotify.1 xdprformat.1 xdremind.1 xdremove.1 \
@@ -23,10 +22,9 @@ MAN1= xdaclunix.1 xdalarm.1 xdcustom.1 xddump.1 xdiary.1 xdinitdb.1 \
NO_STAGE= yes
post-patch:
- @${ECHO_MSG} removing the "malloc.h" includes
- ${SH} ${SCRIPTDIR}/nomalloc $(WRKSRC) 2>&1 > /dev/zero
- @${ECHO_MSG} removing unnecessary DependTarget from Imakefile-s
- ${SH} ${SCRIPTDIR}/noextradepend $(WRKSRC) 2>&1 > /dev/zero
+ @${REINPLACE_CMD} -e 's/malloc\.h/stdlib.h/' \
+ ${WRKSRC}/tools/LstLinked.c ${WRKSRC}/tools/System.c \
+ ${WRKSRC}/xtools/xitClipboard.c ${WRKSRC}/xtools/xitInfoFile.c
${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' \
-e 's|CcCmd gcc|CcCmd ${CC}|' '${WRKSRC}/XDiary.tmpl'
diff --git a/deskutils/xmdiary/files/patch-warnings b/deskutils/xmdiary/files/patch-warnings
index bcad085bab14..69e01c64a19d 100644
--- a/deskutils/xmdiary/files/patch-warnings
+++ b/deskutils/xmdiary/files/patch-warnings
@@ -524,8 +524,9 @@
----------------------------------------------------------------------------*/
-void
+- main( unsigned int argc, char *argv[] )
+int
- main( unsigned int argc, char *argv[] )
++ main( int argc, char *argv[] )
{
--- xdalarm/xtmAlarmProc.c 1997-05-04 18:02:19.000000000 -0400
+++ xdalarm/xtmAlarmProc.c 2013-03-27 21:54:22.000000000 -0400
@@ -533,8 +534,9 @@
----------------------------------------------------------------------------*/
-void
+- main( unsigned int argc, char *argv[] )
+int
- main( unsigned int argc, char *argv[] )
++ main( int argc, char *argv[] )
{
--- xdcustom/xtmCustom.c 1997-05-04 18:02:16.000000000 -0400
+++ xdcustom/xtmCustom.c 2013-03-27 21:55:45.000000000 -0400
@@ -542,8 +544,9 @@
----------------------------------------------------------------------------*/
-void
+- main( unsigned int argc, char *argv[] )
+int
- main( unsigned int argc, char *argv[] )
++ main( int argc, char *argv[] )
{
@@ -616,5 +616,5 @@
@@ -586,8 +589,9 @@
----------------------------------------------------------------------------*/
-void
+- main( unsigned int argc, char **argv )
+int
- main( unsigned int argc, char **argv )
++ main( int argc, char **argv )
{
--- xdnotify/xtmNotify.c 1997-05-04 18:02:15.000000000 -0400
+++ xdnotify/xtmNotify.c 2013-03-27 21:57:28.000000000 -0400
@@ -595,8 +599,9 @@
----------------------------------------------------------------------------*/
-void
+- main( unsigned int argc, char *argv[] )
+int
- main( unsigned int argc, char *argv[] )
++ main( int argc, char *argv[] )
{
--- xdprformat/xtmPrFormat.c 1997-05-04 18:02:15.000000000 -0400
+++ xdprformat/xtmPrFormat.c 2013-03-27 21:58:19.000000000 -0400
@@ -612,8 +617,9 @@
----------------------------------------------------------------------------*/
-void
+- main( unsigned int argc, char *argv[] )
+int
- main( unsigned int argc, char *argv[] )
++ main( int argc, char *argv[] )
{
--- xdrestore/xtmRestore.c 1997-05-04 18:02:14.000000000 -0400
+++ xdrestore/xtmRestore.c 2013-03-27 21:59:54.000000000 -0400
diff --git a/deskutils/xmdiary/scripts/noextradepend b/deskutils/xmdiary/scripts/noextradepend
deleted file mode 100644
index 526c1556b5a2..000000000000
--- a/deskutils/xmdiary/scripts/noextradepend
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-for f in `find $1 -type f -name Imakefile -print | xargs grep -l Library.tmpl`
-do
-
-patch -p << END_OF_PATCH
---- $f.orig
-+++ $f
-@@ -30,1 +30,1 @@
--DependTarget()
-+/* DependTarget() -- Library.tmpl contains this now */
-
-END_OF_PATCH
-
-done
diff --git a/deskutils/xmdiary/scripts/nomalloc b/deskutils/xmdiary/scripts/nomalloc
deleted file mode 100644
index 7a49b3d2999d..000000000000
--- a/deskutils/xmdiary/scripts/nomalloc
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-for f in `find $1 -type f -name \*.\[ch\] -print | xargs grep -l malloc.h`
-do
-
-patch -p0 << END_OF_PATCH
-+++ $f
-@@ -10,1 +10,1 @@
--#include <malloc.h>
-+#include <stdlib.h>
-
-END_OF_PATCH
-
-done
-