aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xpad3
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2018-07-27 15:56:57 +0000
committerJason Helfman <jgh@FreeBSD.org>2018-07-27 15:56:57 +0000
commit021a97a2a6b919cfe4440be3745e921ea65bfb59 (patch)
treef9a7399a85e52bb03ca16212ab9dcaa15ac15c23 /deskutils/xpad3
parent564f4e3d977d9bf173ba1499314ea3da840c83e2 (diff)
downloadports-021a97a2a6b919cfe4440be3745e921ea65bfb59.tar.gz
ports-021a97a2a6b919cfe4440be3745e921ea65bfb59.zip
- bring in missing dependencies, bump portrevision
- modernize options helper usage - while here pet portlint
Notes
Notes: svn path=/head/; revision=475445
Diffstat (limited to 'deskutils/xpad3')
-rw-r--r--deskutils/xpad3/Makefile13
-rw-r--r--deskutils/xpad3/files/patch-src-xpad-pad.c6
2 files changed, 10 insertions, 9 deletions
diff --git a/deskutils/xpad3/Makefile b/deskutils/xpad3/Makefile
index ef6109127b96..92b4dc23ec7e 100644
--- a/deskutils/xpad3/Makefile
+++ b/deskutils/xpad3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xpad
PORTVERSION= 3.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= deskutils
MASTER_SITES= http://launchpad.net/xpad/stable/${PORTVERSION}/+download/
PKGNAMESUFFIX= 3
@@ -13,14 +13,17 @@ COMMENT= Virtual note-pad system for your X11 desktop
LICENSE= GPLv3
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
CONFLICTS_INSTALL= xpad-[0-9]*
-USE_XORG= x11 sm
-USE_GNOME= gtk20 intltool
USES= pkgconfig gmake tar:bzip2
+USE_XORG= x11 sm ice
+USE_GNOME= gtk20 intltool cairo
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
@@ -31,10 +34,8 @@ NLS_CONFIGURE_ENABLE= nls
.include <bsd.port.options.mk>
-post-patch:
-.if ! ${PORT_OPTIONS:MNLS}
+post-patch-NLS-off:
@${REINPLACE_CMD} -e 's|SUBDIRS = autopackage doc src images po|SUBDIRS = autopackage doc src images|' \
${WRKSRC}/Makefile.in
-.endif
.include <bsd.port.mk>
diff --git a/deskutils/xpad3/files/patch-src-xpad-pad.c b/deskutils/xpad3/files/patch-src-xpad-pad.c
index 90d9923f9d63..c5c4817c7a26 100644
--- a/deskutils/xpad3/files/patch-src-xpad-pad.c
+++ b/deskutils/xpad3/files/patch-src-xpad-pad.c
@@ -1,6 +1,6 @@
---- src/xpad-pad.c.orig 2010-06-05 15:18:08.000000000 +0200
-+++ src/xpad-pad.c 2010-06-05 15:18:28.000000000 +0200
-@@ -274,7 +274,7 @@
+--- src/xpad-pad.c.orig 2009-01-11 16:27:39 UTC
++++ src/xpad-pad.c
+@@ -274,7 +274,7 @@ xpad_pad_init (XpadPad *pad)
"gravity", GDK_GRAVITY_STATIC, /* static gravity makes saving pad x,y work */
"skip-pager-hint", !xpad_settings_get_has_decorations (xpad_settings ()),
"skip-taskbar-hint", !xpad_settings_get_has_decorations (xpad_settings ()),