aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xpad
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2014-12-30 18:36:31 +0000
committerJason Helfman <jgh@FreeBSD.org>2014-12-30 18:36:31 +0000
commit589d7c3b963ade98fc83c4d7eae9592f837b79d9 (patch)
tree541987426b7e7d80f6273acec6184b0563c8ba49 /deskutils/xpad
parent87fffb2da7aaebb9566a49a7617bab451be50189 (diff)
Notes
Diffstat (limited to 'deskutils/xpad')
-rw-r--r--deskutils/xpad/Makefile44
-rw-r--r--deskutils/xpad/distinfo2
-rw-r--r--deskutils/xpad/pkg-descr17
-rw-r--r--deskutils/xpad/pkg-plist33
4 files changed, 96 insertions, 0 deletions
diff --git a/deskutils/xpad/Makefile b/deskutils/xpad/Makefile
new file mode 100644
index 000000000000..ddaf4ea70d2e
--- /dev/null
+++ b/deskutils/xpad/Makefile
@@ -0,0 +1,44 @@
+# Created by: Jaosn Helfman <jgh@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xpad
+PORTVERSION= 4.5.0
+CATEGORIES= deskutils
+MASTER_SITES= http://launchpad.net/${PORTNAME}/trunk/4.5/+download/
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Virtual note-pad system for your X11 desktop
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= icons-tango>=0:${PORTSDIR}/x11-themes/icons-tango
+
+OPTIONS_DEFINE= NLS DOCS
+OPTIONS_SUB= yes
+
+CONFLICTS_INSTALL= xpad3-[0-9]*
+USE_XORG= x11 sm
+USE_GNOME= gtk30 intltool gtksourceview3
+USES= pkgconfig gmake tar:bzip2 autoreconf
+INSTALLS_ICONS= yes
+CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
+PORTDOCS= *
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|glib/glist.h|glib.h|g' \
+ ${WRKSRC}/src/xpad-undo.c
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for doc in AUTHORS ChangeLog INSTALL NEWS README TODO THANKS
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/deskutils/xpad/distinfo b/deskutils/xpad/distinfo
new file mode 100644
index 000000000000..aebb9cec4bb2
--- /dev/null
+++ b/deskutils/xpad/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xpad-4.5.0.tar.bz2) = f870cefc92593febf266bb0f90ceb0feeb4af7eb1033625fca50933701a7b9e8
+SIZE (xpad-4.5.0.tar.bz2) = 1907957
diff --git a/deskutils/xpad/pkg-descr b/deskutils/xpad/pkg-descr
new file mode 100644
index 000000000000..e53f99d7be90
--- /dev/null
+++ b/deskutils/xpad/pkg-descr
@@ -0,0 +1,17 @@
+xpad is a sticky note application written using GTK+ 3.0 that strives to be
+simple, fault-tolerant, and customizable. xpad consists of independent pad
+windows; each is basically a text box in which notes can be written. Despite
+being called xpad, all that is needed to run or compile it is the GTK+ 3.0
+libraries. Here is a list of major features in the current xpad current
+release:
+
+ * GTK+ 3.0 powered text view.
+ * Fault tolerant. All information is kept on the hard drive, not memory.
+ * xpad is very customizable. The color scheme (text, background, and window
+ borders) and the font can be changed.
+ * A customizable toolbar puts the most frequently used commands at your
+ fingertips.
+ * Support for the X session management protocol.
+ * Support for the www.freedesktop.org system tray proposal.
+
+WWW: https://launchpad.net/xpad
diff --git a/deskutils/xpad/pkg-plist b/deskutils/xpad/pkg-plist
new file mode 100644
index 000000000000..df6735a1ac66
--- /dev/null
+++ b/deskutils/xpad/pkg-plist
@@ -0,0 +1,33 @@
+bin/xpad
+man/man1/xpad.1.gz
+share/applications/xpad.desktop
+share/icons/hicolor/scalable/apps/xpad.svg
+%%DATADIR%%/help/xpad-user-help.txt
+%%NLS%%share/locale/af/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/et/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/th/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xpad.mo