aboutsummaryrefslogtreecommitdiff
path: root/deskutils/yank
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-06-09 23:32:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-06-09 23:32:16 +0000
commitaa6153a5c0e413e50e194a8e9e7d929c7b9a2eba (patch)
tree991c1a762d8c75b893b1d81aa9f149713f9bea9a /deskutils/yank
parent2564e013ecd2e935b721d64cebda4157b3afa8e8 (diff)
Notes
Diffstat (limited to 'deskutils/yank')
-rw-r--r--deskutils/yank/Makefile20
-rw-r--r--deskutils/yank/distinfo6
-rw-r--r--deskutils/yank/files/patch-aa20
-rw-r--r--deskutils/yank/files/patch-src__fileio.c15
-rw-r--r--deskutils/yank/files/patch-src__preferences.c79
-rw-r--r--deskutils/yank/files/patch-src__util.c12
-rw-r--r--deskutils/yank/files/patch-src__yank.schemas29
-rw-r--r--deskutils/yank/pkg-descr3
-rw-r--r--deskutils/yank/pkg-plist14
9 files changed, 159 insertions, 39 deletions
diff --git a/deskutils/yank/Makefile b/deskutils/yank/Makefile
index 1ae41b42c155..966eabf68a3a 100644
--- a/deskutils/yank/Makefile
+++ b/deskutils/yank/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= yank
-PORTVERSION= 0.2.0
-PORTREVISION= 2
+PORTVERSION= 0.2.1
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= yank
@@ -15,20 +14,23 @@ MASTER_SITE_SUBDIR= yank
MAINTAINER= ports@FreeBSD.org
COMMENT= A simple notekeeper and todo-list manager for GNOME
-PLIST_SUB= PORTVERSION=${PORTVERSION}
+BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+RUN_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_GNOME= gal gconf gnomehack gnomeprefix gnomeprint
+USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnomelibs gnomehack gnomeprefix
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+GCONF_SCHEMAS= yank.schemas
post-patch:
- @${REINPLACE_CMD} -E 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC}/src/Plugins -name "Makefile.in" | \
- ${XARGS} ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|_la_LDFLAGS =|& -avoid-version|g'
.include <bsd.port.mk>
diff --git a/deskutils/yank/distinfo b/deskutils/yank/distinfo
index 89394c28af6f..696b51671b36 100644
--- a/deskutils/yank/distinfo
+++ b/deskutils/yank/distinfo
@@ -1,3 +1,3 @@
-MD5 (yank-0.2.0.tar.bz2) = 7813887fda8a8e6b2b95d60046a7d985
-SHA256 (yank-0.2.0.tar.bz2) = 2e808411bbf6c0d18d516613af3763e6d9b1f4f38060c30ae6b16c66b3e0c946
-SIZE (yank-0.2.0.tar.bz2) = 268389
+MD5 (yank-0.2.1.tar.bz2) = e490f4be72a6e3728d0eed8a03bd4c55
+SHA256 (yank-0.2.1.tar.bz2) = a7241ceba0adc9f0577b223604fb935d7e626f69bccc3be23d3c5771dcb0773a
+SIZE (yank-0.2.1.tar.bz2) = 316939
diff --git a/deskutils/yank/files/patch-aa b/deskutils/yank/files/patch-aa
deleted file mode 100644
index 68eb6d6fdeb4..000000000000
--- a/deskutils/yank/files/patch-aa
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/util.h.orig Wed Jan 24 14:12:54 2001
-+++ src/util.h Sun Feb 25 14:06:03 2001
-@@ -28,6 +28,9 @@
- #include <config.h>
- #endif /* HAVE_CONFIG_H */
-
-+/* needed for inet stuff */
-+#include <sys/types.h>
-+#include <sys/socket.h>
-
- /* this gives errors */
- /* #include <sys/param.h> */
-@@ -45,6 +48,7 @@
- #include <string.h>
- #include <time.h>
-
-+#include <netinet/in.h>
- #include <arpa/inet.h>
- #include <netdb.h>
-
diff --git a/deskutils/yank/files/patch-src__fileio.c b/deskutils/yank/files/patch-src__fileio.c
new file mode 100644
index 000000000000..799bae709d70
--- /dev/null
+++ b/deskutils/yank/files/patch-src__fileio.c
@@ -0,0 +1,15 @@
+--- src/fileio.c.orig Wed Oct 10 15:01:40 2001
++++ src/fileio.c Sat Apr 15 23:53:31 2006
+@@ -1414,6 +1414,12 @@
+ gchar *txt;
+ gint stat;
+
++ if (filename != NULL)
++ {
++ return;
++ /* notreached */
++ }
++
+ files = recent_files_get_list();
+ if (files == NULL)
+ {
diff --git a/deskutils/yank/files/patch-src__preferences.c b/deskutils/yank/files/patch-src__preferences.c
new file mode 100644
index 000000000000..43638ae53849
--- /dev/null
+++ b/deskutils/yank/files/patch-src__preferences.c
@@ -0,0 +1,79 @@
+--- src/preferences.c.orig Thu Jun 21 12:24:14 2001
++++ src/preferences.c Sat Apr 15 23:53:31 2006
+@@ -631,10 +631,22 @@
+ client, "/apps/yank/global/no_icons_in_tree", NULL);
+ preferences.note_font = gconf_client_get_string(
+ client, "/apps/yank/global/note_font", NULL);
++ if (preferences.note_font == "0") {
++ g_free(preferences.note_font);
++ preferences.note_font = NULL;
++ }
+ preferences.note_tree_font = gconf_client_get_string(
+ client, "/apps/yank/global/note_tree_font", NULL);
++ if (preferences.note_tree_font == "0") {
++ g_free(preferences.note_tree_font);
++ preferences.note_tree_font = NULL;
++ }
+ preferences.todolist_font = gconf_client_get_string(
+ client, "/apps/yank/global/todolist_font", NULL);
++ if (preferences.todolist_font == "0") {
++ g_free(preferences.todolist_font);
++ preferences.todolist_font = NULL;
++ }
+ preferences.use_custom_font = gconf_client_get_int(
+ client, "/apps/yank/global/use_custom_font", NULL);
+ preferences.sorting_mode = gconf_client_get_int(
+@@ -1468,11 +1480,14 @@
+ {
+ gnome_font_picker_set_font_name(GNOME_FONT_PICKER(b_note_fontp),
+ preferences.note_font);
+- }
++ } else {
++ gnome_font_picker_set_font_name(GNOME_FONT_PICKER(b_note_fontp),
++ NULL);
++ }
+ gnome_font_picker_set_title(GNOME_FONT_PICKER(b_note_fontp),
+ _("Note font"));
+- gnome_font_picker_set_mode(GNOME_FONT_PICKER(b_note_fontp),
+- GNOME_FONT_PICKER_MODE_FONT_INFO);
++// gnome_font_picker_set_mode(GNOME_FONT_PICKER(b_note_fontp),
++// GNOME_FONT_PICKER_MODE_FONT_INFO);
+ gtk_box_pack_start(GTK_BOX(hbox2), b_note_fontp, FALSE, TRUE, 0);
+
+ hbox2 = gtk_hbox_new(FALSE, 4);
+@@ -1486,11 +1501,14 @@
+ {
+ gnome_font_picker_set_font_name(GNOME_FONT_PICKER(b_note_tree_fontp),
+ preferences.note_tree_font);
+- }
++ } else {
++ gnome_font_picker_set_font_name(GNOME_FONT_PICKER(b_note_tree_fontp),
++ NULL);
++ }
+ gnome_font_picker_set_title(GNOME_FONT_PICKER(b_note_tree_fontp),
+ _("NoteTree font"));
+- gnome_font_picker_set_mode(GNOME_FONT_PICKER(b_note_tree_fontp),
+- GNOME_FONT_PICKER_MODE_FONT_INFO);
++// gnome_font_picker_set_mode(GNOME_FONT_PICKER(b_note_tree_fontp),
++// GNOME_FONT_PICKER_MODE_FONT_INFO);
+ gtk_box_pack_start(GTK_BOX(hbox2), b_note_tree_fontp, FALSE, TRUE, 0);
+
+ hbox2 = gtk_hbox_new(FALSE, 4);
+@@ -1504,11 +1522,14 @@
+ {
+ gnome_font_picker_set_font_name(GNOME_FONT_PICKER(b_todolist_fontp),
+ preferences.todolist_font);
+- }
++ } else {
++ gnome_font_picker_set_font_name(GNOME_FONT_PICKER(b_todolist_fontp),
++ NULL);
++ }
+ gnome_font_picker_set_title(GNOME_FONT_PICKER(b_todolist_fontp),
+ _("Todolist font"));
+- gnome_font_picker_set_mode(GNOME_FONT_PICKER(b_todolist_fontp),
+- GNOME_FONT_PICKER_MODE_FONT_INFO);
++// gnome_font_picker_set_mode(GNOME_FONT_PICKER(b_todolist_fontp),
++// GNOME_FONT_PICKER_MODE_FONT_INFO);
+ gtk_box_pack_start(GTK_BOX(hbox2), b_todolist_fontp, FALSE, TRUE, 0);
+
+ gtk_widget_show_all(vbox);
diff --git a/deskutils/yank/files/patch-src__util.c b/deskutils/yank/files/patch-src__util.c
new file mode 100644
index 000000000000..8167b766666e
--- /dev/null
+++ b/deskutils/yank/files/patch-src__util.c
@@ -0,0 +1,12 @@
+--- src/util.c.orig Sun May 27 00:04:25 2001
++++ src/util.c Sat Apr 15 20:51:09 2006
+@@ -32,8 +32,8 @@
+ #include <time.h>
+
+ #include <sys/types.h>
+-#include <netinet/in.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
+
diff --git a/deskutils/yank/files/patch-src__yank.schemas b/deskutils/yank/files/patch-src__yank.schemas
new file mode 100644
index 000000000000..f9afedb65f18
--- /dev/null
+++ b/deskutils/yank/files/patch-src__yank.schemas
@@ -0,0 +1,29 @@
+--- src/yank.schemas.orig Thu Jun 21 12:24:14 2001
++++ src/yank.schemas Sat Apr 15 23:53:31 2006
+@@ -392,7 +392,7 @@
+ <applyto>/apps/yank/global/note_font</applyto>
+ <owner>yank</owner>
+ <type>string</type>
+- <default>0</default>
++ <default></default>
+ <locale name="C">
+ <short>Note font</short>
+ <long>Font used for notes.</long>
+@@ -404,7 +404,7 @@
+ <applyto>/apps/yank/global/note_tree_font</applyto>
+ <owner>yank</owner>
+ <type>string</type>
+- <default>0</default>
++ <default></default>
+ <locale name="C">
+ <short>Note tree font</short>
+ <long>Font used for tree.</long>
+@@ -416,7 +416,7 @@
+ <applyto>/apps/yank/global/todolist_font</applyto>
+ <owner>yank</owner>
+ <type>string</type>
+- <default>0</default>
++ <default></default>
+ <locale name="C">
+ <short>Todolist font</short>
+ <long>Font used for the todolist.</long>
diff --git a/deskutils/yank/pkg-descr b/deskutils/yank/pkg-descr
index 601270bf8c7c..3d85571d8c35 100644
--- a/deskutils/yank/pkg-descr
+++ b/deskutils/yank/pkg-descr
@@ -8,6 +8,3 @@ Features include:
* drag & drop support
WWW: http://yank.sourceforge.net/
-
-- Chris D. Faulhaber
- <jedgar@FreeBSD.org>
diff --git a/deskutils/yank/pkg-plist b/deskutils/yank/pkg-plist
index 43f71be543a7..70a8b2c35b8c 100644
--- a/deskutils/yank/pkg-plist
+++ b/deskutils/yank/pkg-plist
@@ -1,13 +1,19 @@
bin/yank
-lib/yank/plugins/%%PORTVERSION%%/libPgp5.a
-lib/yank/plugins/%%PORTVERSION%%/libPgp5.la
-lib/yank/plugins/%%PORTVERSION%%/libPgp5.so
+lib/yank/plugins/%%VERSION%%/libGpg.a
+lib/yank/plugins/%%VERSION%%/libGpg.la
+lib/yank/plugins/%%VERSION%%/libGpg.so
+lib/yank/plugins/%%VERSION%%/libGtkSpell.a
+lib/yank/plugins/%%VERSION%%/libGtkSpell.la
+lib/yank/plugins/%%VERSION%%/libGtkSpell.so
+lib/yank/plugins/%%VERSION%%/libPgp5.a
+lib/yank/plugins/%%VERSION%%/libPgp5.la
+lib/yank/plugins/%%VERSION%%/libPgp5.so
share/gnome/apps/Applications/yank.desktop
share/gnome/pixmaps/yank.png
share/locale/de/LC_MESSAGES/yank.mo
share/locale/ja/LC_MESSAGES/yank.mo
share/locale/sv/LC_MESSAGES/yank.mo
share/locale/uk/LC_MESSAGES/yank.mo
-@dirrm lib/yank/plugins/%%PORTVERSION%%
+@dirrm lib/yank/plugins/%%VERSION%%
@dirrm lib/yank/plugins
@dirrm lib/yank