aboutsummaryrefslogtreecommitdiff
path: root/deskutils/zanshin
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-08-01 18:04:33 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-08-01 18:04:33 +0000
commitdac4c7447b47666c2231a2ddcf56d7645610e839 (patch)
treee7c4d5cbc0dcc4d3e42d76298c19dc1aed615101 /deskutils/zanshin
parent40583ab0316f3bdac6ecb17b5595000a6de9d007 (diff)
downloadports-dac4c7447b47666c2231a2ddcf56d7645610e839.tar.gz
ports-dac4c7447b47666c2231a2ddcf56d7645610e839.zip
Notes
Diffstat (limited to 'deskutils/zanshin')
-rw-r--r--deskutils/zanshin/Makefile27
-rw-r--r--deskutils/zanshin/distinfo3
-rw-r--r--deskutils/zanshin/pkg-descr6
-rw-r--r--deskutils/zanshin/pkg-plist59
4 files changed, 95 insertions, 0 deletions
diff --git a/deskutils/zanshin/Makefile b/deskutils/zanshin/Makefile
new file mode 100644
index 000000000000..802582a9ceb2
--- /dev/null
+++ b/deskutils/zanshin/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD
+
+PORTNAME= zanshin
+DISTVERSION= 0.5.0
+CATEGORIES= deskutils kde
+MASTER_SITES= KDE/stable/${PORTNAME}/
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Daily organizer for KDE
+
+LIB_DEPENDS= libical.so:devel/libical
+
+USES= cmake:outsource compiler:c++14-lang gettext kde:5 qt:5 tar:xz
+USE_KDE= akonadi auth bookmarks codecs completion config configwidgets \
+ coreaddons crash ecm guiaddons i18n iconthemes itemmodels \
+ itemviews jobwidgets kdelibs4support kio notifications package \
+ parts plasma-framework runner service solid sonnet textwidgets \
+ unitconversion wallet widgetsaddons windowsystem xmlgui \
+# PIM Components
+USE_KDE+= akonadicalendar akonadicontacts akonadinotes akonadisearch \
+ calendarcore contacts identitymanagement kontactinterface ldap \
+ mime pimtextedit
+USE_QT= concurrent core dbus gui network printsupport qml testlib \
+ widgets xml \
+ buildtools_build qmake_build
+
+.include <bsd.port.mk>
diff --git a/deskutils/zanshin/distinfo b/deskutils/zanshin/distinfo
new file mode 100644
index 000000000000..cf70456c9421
--- /dev/null
+++ b/deskutils/zanshin/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1533125834
+SHA256 (zanshin-0.5.0.tar.xz) = 0781c088741186f3d9ff3027dc961103d33a59b0e3aeb6bc4c66ff24eb3adb4f
+SIZE (zanshin-0.5.0.tar.xz) = 438300
diff --git a/deskutils/zanshin/pkg-descr b/deskutils/zanshin/pkg-descr
new file mode 100644
index 000000000000..978a6392989d
--- /dev/null
+++ b/deskutils/zanshin/pkg-descr
@@ -0,0 +1,6 @@
+Zanshin is a powerful yet simple application for managing your day-to-day
+actions and notes. It helps you organize and reduce the cognitive pressure
+of what one has to do in his job and personal life. You'll never forget
+anything anymore, getting your mind like water.
+
+WWW: https://zanshin.kde.org/
diff --git a/deskutils/zanshin/pkg-plist b/deskutils/zanshin/pkg-plist
new file mode 100644
index 000000000000..9ef3b73ddddf
--- /dev/null
+++ b/deskutils/zanshin/pkg-plist
@@ -0,0 +1,59 @@
+bin/renku
+bin/zanshin
+bin/zanshin-migrator
+%%QT_PLUGINDIR%%/kontact_renkuplugin.so
+%%QT_PLUGINDIR%%/kontact_zanshinplugin.so
+%%QT_PLUGINDIR%%/krunner_zanshin.so
+%%QT_PLUGINDIR%%/renku_part.so
+%%QT_PLUGINDIR%%/zanshin_part.so
+share/applications/org.kde.renku.desktop
+share/applications/org.kde.zanshin.desktop
+share/icons/hicolor/128x128/apps/zanshin.png
+share/icons/hicolor/256x256/apps/zanshin.png
+share/icons/hicolor/48x48/apps/zanshin.png
+share/icons/hicolor/64x64/apps/zanshin.png
+share/icons/hicolor/scalable/apps/zanshin.svgz
+share/kservices5/kontact/renku_plugin.desktop
+share/kservices5/kontact/zanshin_plugin.desktop
+share/kservices5/plasma-runner-zanshin.desktop
+share/kservices5/renku_part.desktop
+share/kservices5/zanshin_part.desktop
+share/kxmlgui5/renku/renku_part.rc
+share/kxmlgui5/renku/renkuui.rc
+share/kxmlgui5/zanshin/zanshin_part.rc
+share/locale/ast/LC_MESSAGES/zanshin.mo
+share/locale/bs/LC_MESSAGES/zanshin.mo
+share/locale/ca/LC_MESSAGES/zanshin.mo
+share/locale/ca@valencia/LC_MESSAGES/zanshin.mo
+share/locale/cs/LC_MESSAGES/zanshin.mo
+share/locale/da/LC_MESSAGES/zanshin.mo
+share/locale/de/LC_MESSAGES/zanshin.mo
+share/locale/en_GB/LC_MESSAGES/zanshin.mo
+share/locale/es/LC_MESSAGES/zanshin.mo
+share/locale/et/LC_MESSAGES/zanshin.mo
+share/locale/fi/LC_MESSAGES/zanshin.mo
+share/locale/fr/LC_MESSAGES/zanshin.mo
+share/locale/ga/LC_MESSAGES/zanshin.mo
+share/locale/gl/LC_MESSAGES/zanshin.mo
+share/locale/hu/LC_MESSAGES/zanshin.mo
+share/locale/it/LC_MESSAGES/zanshin.mo
+share/locale/ja/LC_MESSAGES/zanshin.mo
+share/locale/lt/LC_MESSAGES/zanshin.mo
+share/locale/mr/LC_MESSAGES/zanshin.mo
+share/locale/nb/LC_MESSAGES/zanshin.mo
+share/locale/nds/LC_MESSAGES/zanshin.mo
+share/locale/nl/LC_MESSAGES/zanshin.mo
+share/locale/pl/LC_MESSAGES/zanshin.mo
+share/locale/pt/LC_MESSAGES/zanshin.mo
+share/locale/pt_BR/LC_MESSAGES/zanshin.mo
+share/locale/ru/LC_MESSAGES/zanshin.mo
+share/locale/sk/LC_MESSAGES/zanshin.mo
+share/locale/sl/LC_MESSAGES/zanshin.mo
+share/locale/sv/LC_MESSAGES/zanshin.mo
+share/locale/tr/LC_MESSAGES/zanshin.mo
+share/locale/ug/LC_MESSAGES/zanshin.mo
+share/locale/uk/LC_MESSAGES/zanshin.mo
+share/locale/zh_CN/LC_MESSAGES/zanshin.mo
+share/locale/zh_TW/LC_MESSAGES/zanshin.mo
+share/metainfo/org.kde.renku.appdata.xml
+share/metainfo/org.kde.zanshin.appdata.xml