aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-10-07 19:03:57 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-10-07 19:03:57 +0000
commit007426d8eab4ad6c63570c3bcccae527b5ed8a4a (patch)
treea3e87b9c35eb4e0c0c7f210d098ad8bbdc66ee60 /deskutils
parentf1cfd38116d27d7066b5fcb3622fa095d82a6341 (diff)
downloadports-007426d8eab4ad6c63570c3bcccae527b5ed8a4a.tar.gz
ports-007426d8eab4ad6c63570c3bcccae527b5ed8a4a.zip
Chase gegl changes.
Notes
Notes: svn path=/head/; revision=481476
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/gnome-photos/Makefile3
-rw-r--r--deskutils/gnome-photos/files/patch-configure61
2 files changed, 63 insertions, 1 deletions
diff --git a/deskutils/gnome-photos/Makefile b/deskutils/gnome-photos/Makefile
index db2113dc19c3..bcc9a96445e8 100644
--- a/deskutils/gnome-photos/Makefile
+++ b/deskutils/gnome-photos/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gnome-photos
PORTVERSION= 3.28.0
+PORTREVISION= 1
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -18,7 +19,7 @@ BUILD_DEPENDS= geoclue>=0:net/geoclue \
LIB_DEPENDS= libexempi.so:textproc/exempi \
libfribidi.so:converters/fribidi \
libgfbgraph-0.2.so:net/gfbgraph \
- libgegl-0.3.so:graphics/gegl3 \
+ libgegl-0.4.so:graphics/gegl \
libgrilo-0.3.so:net/grilo \
libexiv2.so:graphics/exiv2 \
libgexiv2.so:graphics/gexiv2 \
diff --git a/deskutils/gnome-photos/files/patch-configure b/deskutils/gnome-photos/files/patch-configure
new file mode 100644
index 000000000000..215bf98260e2
--- /dev/null
+++ b/deskutils/gnome-photos/files/patch-configure
@@ -0,0 +1,61 @@
+--- configure.orig 2018-09-30 15:09:19.044612000 +0200
++++ configure 2018-09-30 15:10:32.457663000 +0200
+@@ -6940,7 +6940,7 @@
+ DAZZLE_MIN_VERSION=3.26.0
+ GDATA_MIN_VERSION=0.15.2
+ GDK_PIXBUF_MIN_VERSION=2.32
+-GEGL_MIN_VERSION=0.3.28
++GEGL_MIN_VERSION=0.4.0
+ GFBGRAPH_MIN_VERSION=0.2.1
+ GLIB_MIN_VERSION=2.44.0
+ GOA_MIN_VERSION=3.8.0
+@@ -17403,12 +17403,12 @@
+ pkg_cv_GEGL_CFLAGS="$GEGL_CFLAGS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gegl-0.3 >= \$GEGL_MIN_VERSION\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "gegl-0.3 >= $GEGL_MIN_VERSION") 2>&5
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gegl-0.4 >= \$GEGL_MIN_VERSION\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "gegl-0.4 >= $GEGL_MIN_VERSION") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+- pkg_cv_GEGL_CFLAGS=`$PKG_CONFIG --cflags "gegl-0.3 >= $GEGL_MIN_VERSION" 2>/dev/null`
++ pkg_cv_GEGL_CFLAGS=`$PKG_CONFIG --cflags "gegl-0.4 >= $GEGL_MIN_VERSION" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+ else
+ pkg_failed=yes
+@@ -17420,12 +17420,12 @@
+ pkg_cv_GEGL_LIBS="$GEGL_LIBS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gegl-0.3 >= \$GEGL_MIN_VERSION\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "gegl-0.3 >= $GEGL_MIN_VERSION") 2>&5
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gegl-0.4 >= \$GEGL_MIN_VERSION\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "gegl-0.4 >= $GEGL_MIN_VERSION") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+- pkg_cv_GEGL_LIBS=`$PKG_CONFIG --libs "gegl-0.3 >= $GEGL_MIN_VERSION" 2>/dev/null`
++ pkg_cv_GEGL_LIBS=`$PKG_CONFIG --libs "gegl-0.4 >= $GEGL_MIN_VERSION" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+ else
+ pkg_failed=yes
+@@ -17446,14 +17446,14 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- GEGL_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "gegl-0.3 >= $GEGL_MIN_VERSION" 2>&1`
++ GEGL_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "gegl-0.4 >= $GEGL_MIN_VERSION" 2>&1`
+ else
+- GEGL_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "gegl-0.3 >= $GEGL_MIN_VERSION" 2>&1`
++ GEGL_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "gegl-0.4 >= $GEGL_MIN_VERSION" 2>&1`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$GEGL_PKG_ERRORS" >&5
+
+- as_fn_error $? "Package requirements (gegl-0.3 >= $GEGL_MIN_VERSION) were not met:
++ as_fn_error $? "Package requirements (gegl-0.4 >= $GEGL_MIN_VERSION) were not met:
+
+ $GEGL_PKG_ERRORS
+