aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-10-26 20:00:42 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-10-26 20:00:42 +0000
commit78f82ea2d9b63f97cea526ab38c63b2d94c2f370 (patch)
tree927eccb42b892e118e86ff824890dc195df0d29c /deskutils
parent6fb943d672173f95742d0ea9e6aec59fc01f0bb4 (diff)
downloadports-78f82ea2d9b63f97cea526ab38c63b2d94c2f370.tar.gz
ports-78f82ea2d9b63f97cea526ab38c63b2d94c2f370.zip
deskutils/copyq: Update to 3.6.1
- Switch to CMake build - Install data (themes, icons, translations) and optional plugins - Fix LICENSE and add LICENSE_FILE - Reset maintainer (no response for 15 months) PR: 221100 Submitted by: <bsd@bontempi.net> (update request); jhale (patch) Approved by: maintainer timeout (15 months)
Notes
Notes: svn path=/head/; revision=483047
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/copyq/Makefile32
-rw-r--r--deskutils/copyq/distinfo6
-rw-r--r--deskutils/copyq/files/patch-qt51166
-rw-r--r--deskutils/copyq/pkg-plist62
4 files changed, 84 insertions, 82 deletions
diff --git a/deskutils/copyq/Makefile b/deskutils/copyq/Makefile
index 4614ae200178..d6893d33aab4 100644
--- a/deskutils/copyq/Makefile
+++ b/deskutils/copyq/Makefile
@@ -1,30 +1,36 @@
# $FreeBSD$
PORTNAME= copyq
-PORTVERSION= 2.7.1
-PORTREVISION= 1
+PORTVERSION= 3.6.1
DISTVERSIONPREFIX= v
CATEGORIES= deskutils
-MAINTAINER= kris@ixsystems.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Qt5 based clipboard manager
-LICENSE= GPLv3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= qmake qt:5
-USE_XORG= x11 xfixes xtst
-USE_QT= core gui network svg multimedia imageformats \
- buildtools_build x11extras concurrent widgets xml \
- script
-USE_GL= gl
+USES= cmake:outsource qt:5
+USE_XORG= ice sm x11 xext xfixes xtst
+USE_QT= core gui network script svg widgets x11extras xml \
+ buildtools_build linguist_build qmake_build \
+ imageformats_run
USE_GITHUB= yes
GH_ACCOUNT= hluk
GH_PROJECT= CopyQ
-PLIST_FILES= bin/copyq
+CMAKE_ARGS= -DMANPAGE_INSTALL_PREFIX:PATH=${MANPREFIX}/man/man1
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/copyq ${STAGEDIR}${PREFIX}/bin
+OPTIONS_DEFINE= PLUGINS WEBKIT
+OPTIONS_DEFAULT= PLUGINS WEBKIT
+OPTIONS_SUB= yes
+
+PLUGINS_CMAKE_BOOL= WITH_PLUGINS
+
+WEBKIT_USE= qt=webkit
+WEBKIT_CMAKE_BOOL= WITH_WEBKIT
+WEBKIT_IMPLIES= PLUGINS
.include <bsd.port.mk>
diff --git a/deskutils/copyq/distinfo b/deskutils/copyq/distinfo
index 23d321d83cff..e8402243ed8d 100644
--- a/deskutils/copyq/distinfo
+++ b/deskutils/copyq/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1469125509
-SHA256 (hluk-CopyQ-v2.7.1_GH0.tar.gz) = 4b8efd6e4041a0aa5f3361eb3aef93f51b5919c14502138e9f4a0b756b290d91
-SIZE (hluk-CopyQ-v2.7.1_GH0.tar.gz) = 1490106
+TIMESTAMP = 1540572316
+SHA256 (hluk-CopyQ-v3.6.1_GH0.tar.gz) = 79bb76c0afcfd769932a9d3b6cfa985dadc1b71443be2277ef0367fa6a4a658f
+SIZE (hluk-CopyQ-v3.6.1_GH0.tar.gz) = 2906930
diff --git a/deskutils/copyq/files/patch-qt511 b/deskutils/copyq/files/patch-qt511
deleted file mode 100644
index da4828366fca..000000000000
--- a/deskutils/copyq/files/patch-qt511
+++ /dev/null
@@ -1,66 +0,0 @@
-Fix build with Qt 5.11 (backported from upstream commits)
-
---- plugins/itemencrypted/itemencrypted.cpp.orig 2018-09-07 13:52:55 UTC
-+++ plugins/itemencrypted/itemencrypted.cpp
-@@ -30,9 +30,11 @@
- #include "gui/iconwidget.h"
- #include "item/serialize.h"
-
-+#include <QAbstractItemModel>
- #include <QDir>
- #include <QFile>
- #include <QLabel>
-+#include <QModelIndex>
- #include <QTextEdit>
- #include <QtPlugin>
- #include <QVBoxLayout>
---- src/gui/commanddialog.cpp.orig 2018-09-07 13:54:06 UTC
-+++ src/gui/commanddialog.cpp
-@@ -31,6 +31,7 @@
- #include "gui/icons.h"
- #include "platform/platformnativeinterface.h"
-
-+#include <QAction>
- #include <QFileDialog>
- #include <QMenu>
- #include <QMessageBox>
---- src/gui/configtabappearance.cpp.orig 2018-09-07 14:05:13 UTC
-+++ src/gui/configtabappearance.cpp
-@@ -32,6 +32,7 @@
- #include "platform/platformnativeinterface.h"
-
- #include <QAbstractScrollArea>
-+#include <QAction>
- #include <QColorDialog>
- #include <QFileDialog>
- #include <QFontDialog>
---- src/gui/processmanagerdialog.cpp.orig 2018-09-07 13:56:41 UTC
-+++ src/gui/processmanagerdialog.cpp
-@@ -26,6 +26,7 @@
- #include "gui/icons.h"
- #include "gui/windowgeometryguard.h"
-
-+#include <QAction>
- #include <QDateTime>
- #include <QPushButton>
-
---- src/gui/traymenu.cpp.orig 2018-09-07 13:55:30 UTC
-+++ src/gui/traymenu.cpp
-@@ -25,6 +25,7 @@
- #include "platform/platformnativeinterface.h"
- #include "platform/platformwindow.h"
-
-+#include <QAction>
- #include <QApplication>
- #include <QKeyEvent>
- #include <QModelIndex>
---- src/gui/traymenu.h.orig 2018-09-07 13:57:46 UTC
-+++ src/gui/traymenu.h
-@@ -23,6 +23,7 @@
- #include <QMenu>
- #include <QPointer>
-
-+class QAction;
- class QModelIndex;
-
- class TrayMenu : public QMenu
diff --git a/deskutils/copyq/pkg-plist b/deskutils/copyq/pkg-plist
new file mode 100644
index 000000000000..7d16fd973849
--- /dev/null
+++ b/deskutils/copyq/pkg-plist
@@ -0,0 +1,62 @@
+bin/copyq
+%%PLUGINS%%lib/copyq/plugins/libitemdata.so
+%%PLUGINS%%lib/copyq/plugins/libitemencrypted.so
+%%PLUGINS%%lib/copyq/plugins/libitemfakevim.so
+%%PLUGINS%%lib/copyq/plugins/libitemimage.so
+%%PLUGINS%%lib/copyq/plugins/libitemnotes.so
+%%PLUGINS%%lib/copyq/plugins/libitempinned.so
+%%PLUGINS%%lib/copyq/plugins/libitemsync.so
+%%PLUGINS%%lib/copyq/plugins/libitemtags.so
+%%PLUGINS%%lib/copyq/plugins/libitemtext.so
+%%PLUGINS%%%%WEBKIT%%lib/copyq/plugins/libitemweb.so
+man/man1/copyq.1.gz
+share/applications/com.github.hluk.copyq.desktop
+%%DATADIR%%/themes/dark.ini
+%%DATADIR%%/themes/forest.ini
+%%DATADIR%%/themes/light.ini
+%%DATADIR%%/themes/paper.ini
+%%DATADIR%%/themes/simple.ini
+%%DATADIR%%/themes/solarized-dark.ini
+%%DATADIR%%/themes/solarized-light.ini
+%%DATADIR%%/themes/wine.ini
+%%DATADIR%%/translations/copyq_ar.qm
+%%DATADIR%%/translations/copyq_cs.qm
+%%DATADIR%%/translations/copyq_da.qm
+%%DATADIR%%/translations/copyq_de.qm
+%%DATADIR%%/translations/copyq_es.qm
+%%DATADIR%%/translations/copyq_fr.qm
+%%DATADIR%%/translations/copyq_hu.qm
+%%DATADIR%%/translations/copyq_it.qm
+%%DATADIR%%/translations/copyq_ja.qm
+%%DATADIR%%/translations/copyq_lt.qm
+%%DATADIR%%/translations/copyq_nb.qm
+%%DATADIR%%/translations/copyq_nl.qm
+%%DATADIR%%/translations/copyq_pl.qm
+%%DATADIR%%/translations/copyq_pt_BR.qm
+%%DATADIR%%/translations/copyq_pt_PT.qm
+%%DATADIR%%/translations/copyq_ru.qm
+%%DATADIR%%/translations/copyq_sk.qm
+%%DATADIR%%/translations/copyq_sv.qm
+%%DATADIR%%/translations/copyq_tr.qm
+%%DATADIR%%/translations/copyq_uk.qm
+%%DATADIR%%/translations/copyq_zh_CN.qm
+%%DATADIR%%/translations/copyq_zh_TW.qm
+share/icons/hicolor/128x128/apps/copyq-busy.png
+share/icons/hicolor/128x128/apps/copyq.png
+share/icons/hicolor/16x16/apps/copyq-busy.png
+share/icons/hicolor/16x16/apps/copyq.png
+share/icons/hicolor/22x22/apps/copyq-busy.png
+share/icons/hicolor/22x22/apps/copyq.png
+share/icons/hicolor/24x24/apps/copyq-busy.png
+share/icons/hicolor/24x24/apps/copyq.png
+share/icons/hicolor/32x32/apps/copyq-busy.png
+share/icons/hicolor/32x32/apps/copyq.png
+share/icons/hicolor/48x48/apps/copyq-busy.png
+share/icons/hicolor/48x48/apps/copyq.png
+share/icons/hicolor/64x64/apps/copyq-busy.png
+share/icons/hicolor/64x64/apps/copyq.png
+share/icons/hicolor/scalable/apps/copyq-busy-mask.svg
+share/icons/hicolor/scalable/apps/copyq-busy.svg
+share/icons/hicolor/scalable/apps/copyq-mask.svg
+share/icons/hicolor/scalable/apps/copyq.svg
+share/metainfo/com.github.hluk.copyq.appdata.xml