aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-11-19 18:16:34 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-11-19 18:16:34 +0000
commitb42496f503439db3b572dabfc91f516f5ca03817 (patch)
treef24e2f4c50293230db75311235c47fef1c659dd7 /deskutils
parente07d975a00c96d893eb3f6fc15f31fbe85f90813 (diff)
downloadports-b42496f503439db3b572dabfc91f516f5ca03817.tar.gz
ports-b42496f503439db3b572dabfc91f516f5ca03817.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/etoile-hardware/Makefile32
-rw-r--r--deskutils/etoile-hardware/distinfo3
-rw-r--r--deskutils/etoile-hardware/pkg-descr10
-rw-r--r--deskutils/etoile-hardware/pkg-plist74
5 files changed, 120 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 1ba42eeda917..f3a59b276bd5 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -40,6 +40,7 @@
SUBDIR += etoile
SUBDIR += etoile-etoileextensionskit
SUBDIR += etoile-extendedworkspacekit
+ SUBDIR += etoile-hardware
SUBDIR += etoile-preferenceskit
SUBDIR += etoile-servicesbarkit
SUBDIR += etoile-trackerkit
diff --git a/deskutils/etoile-hardware/Makefile b/deskutils/etoile-hardware/Makefile
new file mode 100644
index 000000000000..1cf55738f0c2
--- /dev/null
+++ b/deskutils/etoile-hardware/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: etoile-hardware
+# Date created: 19 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= hardware
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= deskutils
+MASTER_SITES= http://florida.ethz.ch/ports/distfiles/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile_0+${SNAPSHOT}+dfsg.orig
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project Hardware application
+
+SNAPSHOT= 20060917
+WRKSRC= ${WRKDIR}/etoile-0+${SNAPSHOT}+dfsg/Etoile/
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+USE_GNUSTEP_SYSTEM_LIBS+= PreferencesKit:${PREFERENCESKIT_PORT}
+USE_GNUSTEP_MAKE_DIRS+= Services/User/Hardware
+
+PREFERENCESKIT_PORT?= deskutils/etoile-preferenceskit
+
+.include <bsd.port.mk>
diff --git a/deskutils/etoile-hardware/distinfo b/deskutils/etoile-hardware/distinfo
new file mode 100644
index 000000000000..2d5c7ccf5d13
--- /dev/null
+++ b/deskutils/etoile-hardware/distinfo
@@ -0,0 +1,3 @@
+MD5 (etoile_0+20060917+dfsg.orig.tar.gz) = bc96dcaba7ac66abb1320d5cfc98f05e
+SHA256 (etoile_0+20060917+dfsg.orig.tar.gz) = de7cb026ccebdbb72d115ca800a13910cd51c9df27f5578ad7059b13f88eb334
+SIZE (etoile_0+20060917+dfsg.orig.tar.gz) = 10478850
diff --git a/deskutils/etoile-hardware/pkg-descr b/deskutils/etoile-hardware/pkg-descr
new file mode 100644
index 000000000000..c8e6d3969508
--- /dev/null
+++ b/deskutils/etoile-hardware/pkg-descr
@@ -0,0 +1,10 @@
+Etoile intends to be an innovative GNUstep based user environnement built
+from the ground up on highly modular and light components with project and
+document orientation in mind, in order to allow users to create their own
+workflow by reshaping or recombining provided Services (aka Applications),
+Components etc. Flexibility and modularity on both User Interface and code
+level should allow us to scale from PDA to computer environment.
+
+This package installs the Hardware application.
+
+WWW: http://www.etoile-project.org/
diff --git a/deskutils/etoile-hardware/pkg-plist b/deskutils/etoile-hardware/pkg-plist
new file mode 100644
index 000000000000..4c1092113252
--- /dev/null
+++ b/deskutils/etoile-hardware/pkg-plist
@@ -0,0 +1,74 @@
+Local/Applications/Hardware.app/Hardware
+Local/Applications/Hardware.app/PlugIns/EnergyPrefPane.prefPane/EnergyPrefPane
+Local/Applications/Hardware.app/PlugIns/EnergyPrefPane.prefPane/Resources/Energy.gorm/data.classes
+Local/Applications/Hardware.app/PlugIns/EnergyPrefPane.prefPane/Resources/Energy.gorm/data.info
+Local/Applications/Hardware.app/PlugIns/EnergyPrefPane.prefPane/Resources/Energy.gorm/objects.gorm
+Local/Applications/Hardware.app/PlugIns/EnergyPrefPane.prefPane/Resources/EnergyPrefPaneInfo.plist
+Local/Applications/Hardware.app/PlugIns/EnergyPrefPane.prefPane/Resources/Info-gnustep.plist
+Local/Applications/Hardware.app/PlugIns/EnergyPrefPane.prefPane/stamp.make
+Local/Applications/Hardware.app/PlugIns/KeyboardPrefPane.prefPane/KeyboardPrefPane
+Local/Applications/Hardware.app/PlugIns/KeyboardPrefPane.prefPane/Resources/Info-gnustep.plist
+Local/Applications/Hardware.app/PlugIns/KeyboardPrefPane.prefPane/Resources/Keyboard.gorm/data.classes
+Local/Applications/Hardware.app/PlugIns/KeyboardPrefPane.prefPane/Resources/Keyboard.gorm/data.info
+Local/Applications/Hardware.app/PlugIns/KeyboardPrefPane.prefPane/Resources/Keyboard.gorm/objects.gorm
+Local/Applications/Hardware.app/PlugIns/KeyboardPrefPane.prefPane/Resources/KeyboardPrefPaneInfo.plist
+Local/Applications/Hardware.app/PlugIns/KeyboardPrefPane.prefPane/stamp.make
+Local/Applications/Hardware.app/PlugIns/MonitorPrefPane.prefPane/MonitorPrefPane
+Local/Applications/Hardware.app/PlugIns/MonitorPrefPane.prefPane/Resources/Info-gnustep.plist
+Local/Applications/Hardware.app/PlugIns/MonitorPrefPane.prefPane/Resources/Monitor.gorm/data.classes
+Local/Applications/Hardware.app/PlugIns/MonitorPrefPane.prefPane/Resources/Monitor.gorm/data.info
+Local/Applications/Hardware.app/PlugIns/MonitorPrefPane.prefPane/Resources/Monitor.gorm/objects.gorm
+Local/Applications/Hardware.app/PlugIns/MonitorPrefPane.prefPane/Resources/Monitor.png
+Local/Applications/Hardware.app/PlugIns/MonitorPrefPane.prefPane/Resources/MonitorPrefPaneInfo.plist
+Local/Applications/Hardware.app/PlugIns/MonitorPrefPane.prefPane/stamp.make
+Local/Applications/Hardware.app/PlugIns/MousePrefPane.prefPane/MousePrefPane
+Local/Applications/Hardware.app/PlugIns/MousePrefPane.prefPane/Resources/Info-gnustep.plist
+Local/Applications/Hardware.app/PlugIns/MousePrefPane.prefPane/Resources/Mouse.gorm/data.classes
+Local/Applications/Hardware.app/PlugIns/MousePrefPane.prefPane/Resources/Mouse.gorm/data.info
+Local/Applications/Hardware.app/PlugIns/MousePrefPane.prefPane/Resources/Mouse.gorm/objects.gorm
+Local/Applications/Hardware.app/PlugIns/MousePrefPane.prefPane/Resources/MousePrefPaneInfo.plist
+Local/Applications/Hardware.app/PlugIns/MousePrefPane.prefPane/stamp.make
+Local/Applications/Hardware.app/PlugIns/SoundPrefPane.prefPane/Resources/Info-gnustep.plist
+Local/Applications/Hardware.app/PlugIns/SoundPrefPane.prefPane/Resources/Sound.gorm/data.classes
+Local/Applications/Hardware.app/PlugIns/SoundPrefPane.prefPane/Resources/Sound.gorm/data.info
+Local/Applications/Hardware.app/PlugIns/SoundPrefPane.prefPane/Resources/Sound.gorm/objects.gorm
+Local/Applications/Hardware.app/PlugIns/SoundPrefPane.prefPane/Resources/SoundPrefPaneInfo.plist
+Local/Applications/Hardware.app/PlugIns/SoundPrefPane.prefPane/SoundPrefPane
+Local/Applications/Hardware.app/PlugIns/SoundPrefPane.prefPane/stamp.make
+Local/Applications/Hardware.app/PlugIns/StartupPrefPane.prefPane/Resources/Info-gnustep.plist
+Local/Applications/Hardware.app/PlugIns/StartupPrefPane.prefPane/Resources/Startup.gorm/data.classes
+Local/Applications/Hardware.app/PlugIns/StartupPrefPane.prefPane/Resources/Startup.gorm/data.info
+Local/Applications/Hardware.app/PlugIns/StartupPrefPane.prefPane/Resources/Startup.gorm/objects.gorm
+Local/Applications/Hardware.app/PlugIns/StartupPrefPane.prefPane/Resources/StartupPrefPaneInfo.plist
+Local/Applications/Hardware.app/PlugIns/StartupPrefPane.prefPane/StartupPrefPane
+Local/Applications/Hardware.app/PlugIns/StartupPrefPane.prefPane/stamp.make
+Local/Applications/Hardware.app/Resources/Hardware.desktop
+Local/Applications/Hardware.app/Resources/HardwareInfo.plist
+Local/Applications/Hardware.app/Resources/Info-gnustep.plist
+Local/Applications/Hardware.app/Resources/MainMenu.gorm/data.classes
+Local/Applications/Hardware.app/Resources/MainMenu.gorm/data.info
+Local/Applications/Hardware.app/Resources/MainMenu.gorm/objects.gorm
+Local/Applications/Hardware.app/library_paths.openapp
+Local/Applications/Hardware.app/stamp.make
+@dirrm Local/Applications/Hardware.app/Resources/MainMenu.gorm
+@dirrm Local/Applications/Hardware.app/Resources
+@dirrm Local/Applications/Hardware.app/PlugIns/StartupPrefPane.prefPane/Resources/Startup.gorm
+@dirrm Local/Applications/Hardware.app/PlugIns/StartupPrefPane.prefPane/Resources
+@dirrm Local/Applications/Hardware.app/PlugIns/StartupPrefPane.prefPane
+@dirrm Local/Applications/Hardware.app/PlugIns/SoundPrefPane.prefPane/Resources/Sound.gorm
+@dirrm Local/Applications/Hardware.app/PlugIns/SoundPrefPane.prefPane/Resources
+@dirrm Local/Applications/Hardware.app/PlugIns/SoundPrefPane.prefPane
+@dirrm Local/Applications/Hardware.app/PlugIns/MousePrefPane.prefPane/Resources/Mouse.gorm
+@dirrm Local/Applications/Hardware.app/PlugIns/MousePrefPane.prefPane/Resources
+@dirrm Local/Applications/Hardware.app/PlugIns/MousePrefPane.prefPane
+@dirrm Local/Applications/Hardware.app/PlugIns/MonitorPrefPane.prefPane/Resources/Monitor.gorm
+@dirrm Local/Applications/Hardware.app/PlugIns/MonitorPrefPane.prefPane/Resources
+@dirrm Local/Applications/Hardware.app/PlugIns/MonitorPrefPane.prefPane
+@dirrm Local/Applications/Hardware.app/PlugIns/KeyboardPrefPane.prefPane/Resources/Keyboard.gorm
+@dirrm Local/Applications/Hardware.app/PlugIns/KeyboardPrefPane.prefPane/Resources
+@dirrm Local/Applications/Hardware.app/PlugIns/KeyboardPrefPane.prefPane
+@dirrm Local/Applications/Hardware.app/PlugIns/EnergyPrefPane.prefPane/Resources/Energy.gorm
+@dirrm Local/Applications/Hardware.app/PlugIns/EnergyPrefPane.prefPane/Resources
+@dirrm Local/Applications/Hardware.app/PlugIns/EnergyPrefPane.prefPane
+@dirrm Local/Applications/Hardware.app/PlugIns
+@dirrm Local/Applications/Hardware.app