aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-05-23 20:51:27 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-05-23 20:51:27 +0000
commitcf38b673c9d0d64f2f6303cbd51829725cbe9994 (patch)
treedecd4ea843a45a8c9335888f3542946d0a804f3a /deskutils
parent434871ff18beb46a362cd1c62c66944e27e2552c (diff)
downloadports-cf38b673c9d0d64f2f6303cbd51829725cbe9994.tar.gz
ports-cf38b673c9d0d64f2f6303cbd51829725cbe9994.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/helpviewer/Makefile8
-rw-r--r--deskutils/plopfolio/Makefile8
-rw-r--r--deskutils/preferences.app/files/patch-Keyboard.m10
3 files changed, 26 insertions, 0 deletions
diff --git a/deskutils/helpviewer/Makefile b/deskutils/helpviewer/Makefile
index 32eb4532a8f7..cb121e731566 100644
--- a/deskutils/helpviewer/Makefile
+++ b/deskutils/helpviewer/Makefile
@@ -22,4 +22,12 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
+FIXME= HandlerStructureXLP.h TextFormatterXLP.h
+
+post-patch:
+.for i in ${FIXME}
+ ${REINPLACE_CMD} -e 's|Foundation/GSXML.h|GNUstepBase/GSXML.h|' \
+ ${WRKSRC}/${i}
+.endfor
+
.include <bsd.port.mk>
diff --git a/deskutils/plopfolio/Makefile b/deskutils/plopfolio/Makefile
index cde32fd9642b..9897eb41f076 100644
--- a/deskutils/plopfolio/Makefile
+++ b/deskutils/plopfolio/Makefile
@@ -21,4 +21,12 @@ USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
+FIXME= Channel.m PlopFolio.m PreferencesPanelController.m
+
+post-patch:
+.for i in ${FIXME}
+ ${REINPLACE_CMD} -e 's|Foundation/GSXML.h|GNUstepBase/GSXML.h|' \
+ ${WRKSRC}/${i}
+.endfor
+
.include <bsd.port.mk>
diff --git a/deskutils/preferences.app/files/patch-Keyboard.m b/deskutils/preferences.app/files/patch-Keyboard.m
new file mode 100644
index 000000000000..bdf962baf8c3
--- /dev/null
+++ b/deskutils/preferences.app/files/patch-Keyboard.m
@@ -0,0 +1,10 @@
+--- Modules/Keyboard/Keyboard.m.orig 2002-06-08 10:29:36.000000000 +0200
++++ Modules/Keyboard/Keyboard.m 2010-05-22 11:24:43.000000000 +0200
+@@ -37,6 +37,7 @@
+ #import <AppKit/NSButton.h>
+ #import <AppKit/NSNibLoading.h>
+ #import <AppKit/NSOpenPanel.h>
++#import <Foundation/NSUserDefaults.h>
+
+ #import "Keyboard.h"
+ #import "KeyboardView.h"