aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2018-09-28 18:19:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2018-09-28 18:19:45 +0000
commitf712e0c7c9242e59cd17305d95ed2499d37ed299 (patch)
treea2e81a35e478c37209f52bad252a733cd11fb1a9 /deskutils
parentf0a027b4b6f4479da94454716926500258d26ce1 (diff)
downloadports-f712e0c7c9242e59cd17305d95ed2499d37ed299.tar.gz
ports-f712e0c7c9242e59cd17305d95ed2499d37ed299.zip
- Update to 3.4.0
PR: 230553 Submitted by: ndowens@yahoo.com Approved by: maintainer timeout Sponsored by: iXsystems Inc.
Notes
Notes: svn path=/head/; revision=480874
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/gcalcli/Makefile10
-rw-r--r--deskutils/gcalcli/distinfo5
-rw-r--r--deskutils/gcalcli/files/patch-gcalcli33
3 files changed, 10 insertions, 38 deletions
diff --git a/deskutils/gcalcli/Makefile b/deskutils/gcalcli/Makefile
index 9b08bf9d2613..6373a0f568b1 100644
--- a/deskutils/gcalcli/Makefile
+++ b/deskutils/gcalcli/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= gcalcli
-PORTVERSION= 3.2
+PORTVERSION= 3.4.0
DISTVERSIONPREFIX= v
-PORTREVISION= 3
CATEGORIES= deskutils python
MAINTAINER= ports@thelanman.net
@@ -16,7 +15,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}gdata>=0:devel/py-gdata@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}google-api-python-client>=0:www/py-google-api-python-client@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}httplib2>=0:www/py-httplib2@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}python-gflags>=0:devel/py-python-gflags@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}python-gflags>=0:devel/py-python-gflags@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}oauth2client>0:security/py-oauth2client@${PY_FLAVOR}
USES= python:-2.7 shebangfix
USE_GITHUB= yes
@@ -41,6 +41,10 @@ NO_ARCH= yes
PORTDOCS= README.md gcalcli_?.png
PLIST_FILES= bin/gcalcli
+pre-install:
+ @${REINPLACE_CMD} -e '197s|run|run_flow|' \
+ -e '676s|run|run_flow|' ${WRKSRC}/gcalcli
+
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/deskutils/gcalcli/distinfo b/deskutils/gcalcli/distinfo
index 5f0f016dea23..0a0bccd6e79a 100644
--- a/deskutils/gcalcli/distinfo
+++ b/deskutils/gcalcli/distinfo
@@ -1,2 +1,3 @@
-SHA256 (insanum-gcalcli-v3.2_GH0.tar.gz) = 9b3465be8e64c291ffe4582f8cb779a7025c700e6a83aae74722d87a3b88d55a
-SIZE (insanum-gcalcli-v3.2_GH0.tar.gz) = 1672457
+TIMESTAMP = 1534035958
+SHA256 (insanum-gcalcli-v3.4.0_GH0.tar.gz) = 1297f7082b4d33ac6d5ea3edfc11bdd329b8a6f28926aeda412806d45b7afdd1
+SIZE (insanum-gcalcli-v3.4.0_GH0.tar.gz) = 1675456
diff --git a/deskutils/gcalcli/files/patch-gcalcli b/deskutils/gcalcli/files/patch-gcalcli
deleted file mode 100644
index 46f21639c191..000000000000
--- a/deskutils/gcalcli/files/patch-gcalcli
+++ /dev/null
@@ -1,33 +0,0 @@
-# ERROR: Missing module - cannot import name run (revisit #204)
-# https://github.com/insanum/gcalcli/issues/229
-
---- gcalcli.orig 2014-12-17 01:50:24 UTC
-+++ gcalcli
-@@ -185,7 +185,8 @@ try:
- from apiclient.discovery import build
- from oauth2client.file import Storage
- from oauth2client.client import OAuth2WebServerFlow
-- from oauth2client.tools import run
-+ from oauth2client.tools import run_flow
-+ from oauth2client.tools import argparser
- except ImportError as e:
- print "ERROR: Missing module - %s" % e.args[0]
- sys.exit(1)
-@@ -627,14 +628,15 @@ class gcalcli:
- credentials = storage.get()
-
- if credentials is None or credentials.invalid:
-- credentials = run(
-+ args, unknown = argparser.parse_known_args(sys.argv)
-+ credentials = run_flow(
- OAuth2WebServerFlow(
- client_id=self.client_id,
- client_secret=self.client_secret,
- scope=['https://www.googleapis.com/auth/calendar',
- 'https://www.googleapis.com/auth/urlshortener'],
- user_agent=__program__+'/'+__version__),
-- storage)
-+ storage, args)
-
- self.authHttp = credentials.authorize(httplib2.Http())
-