aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-01-18 04:16:22 +0000
committerSteve Price <steve@FreeBSD.org>1999-01-18 04:16:22 +0000
commit97b24974affbda02e05b4af26b6feb81bf66defb (patch)
treef68786c052f4c1bb75d60073aabc9afa6051b1a8 /deskutils
parentcc40b07181615f1de54513a2f4fffd988feb569e (diff)
downloadports-97b24974affbda02e05b4af26b6feb81bf66defb.tar.gz
ports-97b24974affbda02e05b4af26b6feb81bf66defb.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/xrolo/Makefile29
-rw-r--r--deskutils/xrolo/distinfo1
-rw-r--r--deskutils/xrolo/files/patch-aa65
-rw-r--r--deskutils/xrolo/files/patch-ab26
-rw-r--r--deskutils/xrolo/files/patch-ac20
-rw-r--r--deskutils/xrolo/files/patch-ad43
-rw-r--r--deskutils/xrolo/files/patch-ae72
-rw-r--r--deskutils/xrolo/files/patch-af38
-rw-r--r--deskutils/xrolo/pkg-comment1
-rw-r--r--deskutils/xrolo/pkg-descr10
-rw-r--r--deskutils/xrolo/pkg-plist1
11 files changed, 306 insertions, 0 deletions
diff --git a/deskutils/xrolo/Makefile b/deskutils/xrolo/Makefile
new file mode 100644
index 000000000000..881b96f6ee8d
--- /dev/null
+++ b/deskutils/xrolo/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xrolo
+# Version required: 2.6
+# Date created: 17 January 1999
+# Whom: Lars Koeller <Lars.Koeller@Uni-Bielefeld.DE>
+#
+# $Id$
+#
+
+DISTNAME= xrolo.v2p6
+PKGNAME= xrolo-2.6
+CATEGORIES= deskutils
+MASTER_SITES= ftp://gatekeeper.dec.com/pub/X11-contrib/ \
+ ftp://ftp.postech.ac.kr/pub/X11/R5contrib/ \
+ ftp://ftp.uni-potsdam.de/pub/X11/open-look/ \
+ ftp://ftp.khoral.com/pub/dist/X/X11R5.contrib/ \
+ ftp://ftp.imag.fr/pub1/x11/xrolo/ \
+ ftp://ftp.uni-bielefeld.de/pub/systems/FreeBSD/lkoeller/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
+
+LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview-lib
+
+WRKSRC= ${WRKDIR}/xrolo
+
+USE_IMAKE= yes
+MAN1= xrolo.1
+
+.include <bsd.port.mk>
diff --git a/deskutils/xrolo/distinfo b/deskutils/xrolo/distinfo
new file mode 100644
index 000000000000..0753cdf4f9f4
--- /dev/null
+++ b/deskutils/xrolo/distinfo
@@ -0,0 +1 @@
+MD5 (xrolo.v2p6.tar.Z) = fc48c0b3e869fc4930999c019c730d56
diff --git a/deskutils/xrolo/files/patch-aa b/deskutils/xrolo/files/patch-aa
new file mode 100644
index 000000000000..8a6067b6b768
--- /dev/null
+++ b/deskutils/xrolo/files/patch-aa
@@ -0,0 +1,65 @@
+*** Imakefile.orig Tue Dec 3 23:29:46 1991
+--- Imakefile Sat Jan 9 23:01:51 1999
+***************
+*** 9,15 ****
+ # patching ol_button.c. see README for details.
+ # LOCAL_LIBRARIES = -lxview -lolgx
+
+! CDEBUGFLAGS = -g
+ SRCS = main.c panel.c cards.c popup.c send_mail.c soundex.c phone.c
+ OBJS = main.o panel.o cards.o popup.o send_mail.o soundex.o phone.o
+ INCLUDES = -I$$OPENWINHOME/include
+--- 9,15 ----
+ # patching ol_button.c. see README for details.
+ # LOCAL_LIBRARIES = -lxview -lolgx
+
+! # CDEBUGFLAGS = -g
+ SRCS = main.c panel.c cards.c popup.c send_mail.c soundex.c phone.c
+ OBJS = main.o panel.o cards.o popup.o send_mail.o soundex.o phone.o
+ INCLUDES = -I$$OPENWINHOME/include
+***************
+*** 24,35 ****
+ # in DEFINES if your system is not a sparcstation w/ installed
+ # sound libraries.
+
+! MAILER = /bin/mail
+ VERSION = 2.0
+! SOUNDS = /usr/local/lib/sounds # or /usr/demo/SOUNDS/sounds
+ DEFINES = -DSTANDALONE -DMAILER=\"$(MAILER)\" -DVERSION=\"$(VERSION)\" \
+ # -Wf,-XNl4096 # -DSOUNDS=\"$(SOUNDS)\" # -DOL
+
+ #
+ # comment this out if you do not have SOUNDS defined above
+ #AUDIOLIB = -laudio -lm
+--- 24,37 ----
+ # in DEFINES if your system is not a sparcstation w/ installed
+ # sound libraries.
+
+! MAILER = /usr/bin/mail
+ VERSION = 2.0
+! SOUNDS = /usr/local/share/sounds # or /usr/demo/SOUNDS/sounds
+ DEFINES = -DSTANDALONE -DMAILER=\"$(MAILER)\" -DVERSION=\"$(VERSION)\" \
++ -DDONT_USE_MALLOC_LIST
+ # -Wf,-XNl4096 # -DSOUNDS=\"$(SOUNDS)\" # -DOL
+
++
+ #
+ # comment this out if you do not have SOUNDS defined above
+ #AUDIOLIB = -laudio -lm
+***************
+*** 38,44 ****
+ # linking against openlook libraries on suns after patching ol_button.c.
+ # see README for details.
+ #LOCAL_LIBRARIES = -L$$OPENWINHOME/lib -lxview -Bstatic -lolgx -Bdynamic $(AUDIOLIB)
+! LOCAL_LIBRARIES = -L$$OPENWINHOME/lib -lxview -lolgx $(AUDIOLIB)
+ AllTarget(xrolo)
+ NormalProgramTarget(xrolo,$(OBJS),$(DEPLIBS), $(LOCAL_LIBRARIES), $(XLIB))
+ InstallProgram(xrolo, $(BINDIR))
+--- 40,46 ----
+ # linking against openlook libraries on suns after patching ol_button.c.
+ # see README for details.
+ #LOCAL_LIBRARIES = -L$$OPENWINHOME/lib -lxview -Bstatic -lolgx -Bdynamic $(AUDIOLIB)
+! LOCAL_LIBRARIES = -L$$OPENWINHOME/lib -lxview -lolgx $(AUDIOLIB) -lgnuregex
+ AllTarget(xrolo)
+ NormalProgramTarget(xrolo,$(OBJS),$(DEPLIBS), $(LOCAL_LIBRARIES), $(XLIB))
+ InstallProgram(xrolo, $(BINDIR))
diff --git a/deskutils/xrolo/files/patch-ab b/deskutils/xrolo/files/patch-ab
new file mode 100644
index 000000000000..ff9817051b8d
--- /dev/null
+++ b/deskutils/xrolo/files/patch-ab
@@ -0,0 +1,26 @@
+*** main.c.org Sat Jan 9 22:25:04 1999
+--- main.c Sat Jan 9 22:26:03 1999
+***************
+*** 39,45 ****
+ #include <sys/param.h>
+ #include <stdio.h>
+ #include <sys/types.h>
+! #include <sys/dir.h>
+ #include <xview/xview.h>
+ #include <xview/panel.h>
+ #include <xview/textsw.h>
+--- 39,45 ----
+ #include <sys/param.h>
+ #include <stdio.h>
+ #include <sys/types.h>
+! #include <sys/dirent.h>
+ #include <xview/xview.h>
+ #include <xview/panel.h>
+ #include <xview/textsw.h>
+***************
+*** 320,323 ****
+
+ return (strcpy (q, p));
+ }
+-
+--- 320,322 ----
diff --git a/deskutils/xrolo/files/patch-ac b/deskutils/xrolo/files/patch-ac
new file mode 100644
index 000000000000..2f63945f2ee4
--- /dev/null
+++ b/deskutils/xrolo/files/patch-ac
@@ -0,0 +1,20 @@
+*** phone.c.org Sat Jan 9 22:25:15 1999
+--- phone.c Sat Jan 9 22:25:52 1999
+***************
+*** 7,13 ****
+
+ #include <xview/xview.h>
+ #include <xview/panel.h>
+! #include <sys/dir.h>
+ #include "defs.h"
+
+ static Frame volume_frame;
+--- 7,14 ----
+
+ #include <xview/xview.h>
+ #include <xview/panel.h>
+! #include <sys/types.h>
+! #include <sys/dirent.h>
+ #include "defs.h"
+
+ static Frame volume_frame;
diff --git a/deskutils/xrolo/files/patch-ad b/deskutils/xrolo/files/patch-ad
new file mode 100644
index 000000000000..9ae8adcf59b5
--- /dev/null
+++ b/deskutils/xrolo/files/patch-ad
@@ -0,0 +1,43 @@
+*** panel.c.orig Wed Dec 4 01:38:09 1991
+--- panel.c Sat Jan 9 22:49:59 1999
+***************
+*** 35,40 ****
+--- 35,48 ----
+ */
+
+
++ #ifdef HAVE_SYS_PARAM_H
++ #include <sys/param.h>
++ #endif
++
++ #if (defined(BSD) && (BSD >= 199306))
++ #include <stdlib.h>
++ #endif
++
+ #include <stdio.h>
+ #include <strings.h>
+ #include <xview/xview.h>
+***************
+*** 46,52 ****
+ #include <xview/svrimage.h>
+ #include <sys/param.h>
+ #include <ctype.h>
+! #if !defined (sgi)
+ #include <alloca.h>
+ #endif
+ #include <string.h>
+--- 54,60 ----
+ #include <xview/svrimage.h>
+ #include <sys/param.h>
+ #include <ctype.h>
+! #if !defined (sgi) && !(defined(BSD) && (BSD >= 199306))
+ #include <alloca.h>
+ #endif
+ #include <string.h>
+***************
+*** 2462,2465 ****
+ return(--s1);
+ return( NULL );
+ }
+-
+--- 2470,2472 ----
diff --git a/deskutils/xrolo/files/patch-ae b/deskutils/xrolo/files/patch-ae
new file mode 100644
index 000000000000..e005821e7620
--- /dev/null
+++ b/deskutils/xrolo/files/patch-ae
@@ -0,0 +1,72 @@
+*** cards.c.orig Tue Dec 3 23:33:56 1991
+--- cards.c Sat Jan 9 22:52:45 1999
+***************
+*** 36,47 ****
+ */
+
+
+
+ #include <stdio.h>
+ #include <xview/xview.h>
+ #include <sys/file.h>
+ #include <ctype.h>
+! #if !defined(sgi)
+ #include <alloca.h>
+ #endif
+ #include <pwd.h>
+--- 36,56 ----
+ */
+
+
++ #ifdef HAVE_SYS_PARAM_H
++ #include <sys/param.h>
++ #endif
++
++ #if (defined(BSD) && (BSD >= 199306))
++ #include <stdlib.h>
++ #include <strings.h>
++ #include <errno.h>
++ #endif
+
+ #include <stdio.h>
+ #include <xview/xview.h>
+ #include <sys/file.h>
+ #include <ctype.h>
+! #if !defined(sgi) && !(defined(BSD) && (BSD >= 199306))
+ #include <alloca.h>
+ #endif
+ #include <pwd.h>
+***************
+*** 71,85 ****
+
+ extern void show_card (), set_slider_max ();
+
+ extern char *malloc(), *realloc (), *calloc (), *getenv();
+ #if !defined(sgi)
+ extern char *strcpy(), *strcat(), *strncpy (), *index ();
+ #endif
+ extern char *sys_errlist [];
+
+ extern int errno;
+
+-
+ /* --------------------------- Locals -------------------------------------- */
+
+ static struct card *dead;
+--- 80,95 ----
+
+ extern void show_card (), set_slider_max ();
+
++ #if !(defined (BSD) && (BSD >= 199306))
+ extern char *malloc(), *realloc (), *calloc (), *getenv();
+ #if !defined(sgi)
+ extern char *strcpy(), *strcat(), *strncpy (), *index ();
+ #endif
+ extern char *sys_errlist [];
++ #endif
+
+ extern int errno;
+
+ /* --------------------------- Locals -------------------------------------- */
+
+ static struct card *dead;
diff --git a/deskutils/xrolo/files/patch-af b/deskutils/xrolo/files/patch-af
new file mode 100644
index 000000000000..105af2e8b411
--- /dev/null
+++ b/deskutils/xrolo/files/patch-af
@@ -0,0 +1,38 @@
+*** popup.c.org Sat Jan 9 22:53:12 1999
+--- popup.c Sat Jan 9 22:54:07 1999
+***************
+*** 6,11 ****
+--- 6,14 ----
+ * popup - pop up error dialog windows
+ */
+
++ #ifdef HAVE_SYS_PARAM_H
++ #include <sys/param.h>
++ #endif
+
+ #include <xview/xview.h>
+ #include <xview/panel.h>
+***************
+*** 26,32 ****
+
+ /* ---------------------------- Imports -------------------------------- */
+
+! #if !defined(sgi)
+ extern char *sprintf ();
+ #endif
+
+--- 29,35 ----
+
+ /* ---------------------------- Imports -------------------------------- */
+
+! #if !defined(sgi) && !(defined(BSD) && (BSD >= 199306))
+ extern char *sprintf ();
+ #endif
+
+***************
+*** 92,95 ****
+ (void) sprintf (temp, s, a0, a1, a2, a3, a4, a5, a6, a7, a8, a9);
+ return (do_pop (frame, temp, FALSE));
+ }
+-
+--- 95,97 ----
diff --git a/deskutils/xrolo/pkg-comment b/deskutils/xrolo/pkg-comment
new file mode 100644
index 000000000000..c36d404eaa6b
--- /dev/null
+++ b/deskutils/xrolo/pkg-comment
@@ -0,0 +1 @@
+This is an Xview port of Ron Hitchens rolo tool.
diff --git a/deskutils/xrolo/pkg-descr b/deskutils/xrolo/pkg-descr
new file mode 100644
index 000000000000..a7ac16de2a32
--- /dev/null
+++ b/deskutils/xrolo/pkg-descr
@@ -0,0 +1,10 @@
+Rolo is a tool for the Sun workstation which presents a
+user interface to a simple database of notes in a manner
+which approximates a Rolodex file.
+
+Each note in your Rolo file is meant to simulate a 3x5
+card upon which you may scribble anything you like. You
+can have any number of cards in your rolodex, Rolo will
+keep track of them for you. You may browse around through
+them, create new ones, throw old ones away, search for
+strings in them, etc.
diff --git a/deskutils/xrolo/pkg-plist b/deskutils/xrolo/pkg-plist
new file mode 100644
index 000000000000..402154c3642e
--- /dev/null
+++ b/deskutils/xrolo/pkg-plist
@@ -0,0 +1 @@
+bin/xrolo