aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-10-10 14:03:00 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-10-10 14:03:00 +0000
commit3a55a118dde2f1cef80ad8ed446044449cb8417d (patch)
tree4ac25229c12e49e974a92ecd82e01b92eea15c00 /deskutils
parent630b5a689e7c6ead73c118b24cff9156918e9155 (diff)
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/fbreader/Makefile12
-rw-r--r--deskutils/ljclive/Makefile10
-rw-r--r--deskutils/owncloudclient/Makefile3
-rw-r--r--deskutils/owncloudclient/files/patch-cmake-modules-FindIconv.cmake13
4 files changed, 28 insertions, 10 deletions
diff --git a/deskutils/fbreader/Makefile b/deskutils/fbreader/Makefile
index ec47b45fda25..a64b26048566 100644
--- a/deskutils/fbreader/Makefile
+++ b/deskutils/fbreader/Makefile
@@ -4,7 +4,7 @@
PORTNAME= fbreader
PORTVERSION= 0.99.6
DISTVERSIONSUFFIX= -freebsdport
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MAINTAINER= ports@FreeBSD.org
@@ -53,8 +53,7 @@ QT4_LDFLAGS= -L${QT_LIBDIR}
QT4_MAKE_ENV= UI_TYPE=qt4
post-patch:
- @${REINPLACE_CMD} -e '/^CFLAGS/s,-pipe.*$$,${CFLAGS} -DLIBICONV_PLUG,' \
- -e '/^CC/d;/^LD/d;/QTINCLUDE/s,-I.*$$,-I${QT_INCDIR},' \
+ @${REINPLACE_CMD} -e '/^CC/d;/^LD/d;/QTINCLUDE/s,-I.*$$,-I${QT_INCDIR},' \
${WRKSRC}/makefiles/arch/desktop.mk
@${REINPLACE_CMD} -e 's,-O3,,;s,-ldl,${ICONV_LIB},' \
${WRKSRC}/makefiles/config.mk ${WRKSRC}/zlibrary/core/Makefile
@@ -64,4 +63,11 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} \
-e 's,make ,gmake ,'
+pre-configure:
+# This cannot be done in post-patch because build dependencies are installed
+# after patching and they can pull in libiconv which can affect CFLAGS in
+# Mk/Uses/iconv.mk.
+ @${REINPLACE_CMD} 's|^CFLAGS =.*$$|CFLAGS = ${CFLAGS}|' \
+ ${WRKSRC}/makefiles/arch/desktop.mk
+
.include <bsd.port.mk>
diff --git a/deskutils/ljclive/Makefile b/deskutils/ljclive/Makefile
index 7c04943dcea5..43c03c62fad8 100644
--- a/deskutils/ljclive/Makefile
+++ b/deskutils/ljclive/Makefile
@@ -13,12 +13,10 @@ COMMENT= Command line client for posting LiveJournal entries
USES= iconv
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= ac_cv_search_iconv=${ICONV_LIB}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFLICTS= *clive-[1-9]*
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${REINPLACE_CMD} 's/iconv "iconv/"iconv/' ${WRKSRC}/configure
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/owncloudclient/Makefile b/deskutils/owncloudclient/Makefile
index 4034450697df..81092faeee99 100644
--- a/deskutils/owncloudclient/Makefile
+++ b/deskutils/owncloudclient/Makefile
@@ -3,6 +3,7 @@
PORTNAME= owncloudclient
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://download.owncloud.com/desktop/stable/
@@ -14,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libinotify.so:${PORTSDIR}/devel/libinotify \
libqt5keychain.so:${PORTSDIR}/security/qtkeychain-qt5
-USES= cmake:outsource compiler:c++11-lib gmake pkgconfig tar:xz
+USES= cmake:outsource compiler:c++11-lib gmake iconv pkgconfig tar:xz
USE_QT5= buildtools_build concurrent core dbus gui linguist_build network \
qmake_build webkit xml
USE_OPENSSL= yes
diff --git a/deskutils/owncloudclient/files/patch-cmake-modules-FindIconv.cmake b/deskutils/owncloudclient/files/patch-cmake-modules-FindIconv.cmake
new file mode 100644
index 000000000000..637a6c609880
--- /dev/null
+++ b/deskutils/owncloudclient/files/patch-cmake-modules-FindIconv.cmake
@@ -0,0 +1,13 @@
+--- cmake/modules/FindIconv.cmake.orig 2015-07-09 17:51:37 UTC
++++ cmake/modules/FindIconv.cmake
+@@ -36,9 +36,7 @@ find_library(ICONV_LIBRARY
+ )
+
+ if (ICONV_LIBRARY)
+- get_filename_component(_ICONV_NAME ${ICONV_LIBRARY} NAME)
+- get_filename_component(_ICONV_PATH ${ICONV_LIBRARY} PATH)
+- check_library_exists(${_ICONV_NAME} iconv ${_ICONV_PATH} HAVE_ICONV)
++ set(HAVE_ICONV TRUE)
+ else()
+ check_function_exists(iconv HAVE_ICONV)
+ endif()