aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2015-07-16 20:10:25 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2015-07-16 20:10:25 +0000
commit409dd2f9069e2e4a945c5df69dc96817aa2661b3 (patch)
treea8371412b50d40ce5fdd9b144fd28db66b1a60a2 /deskutils
parent80f422dad616bc3a5aed7fca7f606c5515f2bdfb (diff)
downloadports-409dd2f9069e2e4a945c5df69dc96817aa2661b3.tar.gz
ports-409dd2f9069e2e4a945c5df69dc96817aa2661b3.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/recoll/Makefile6
-rw-r--r--deskutils/recoll/distinfo4
-rw-r--r--deskutils/recoll/files/patch-mk-commondefs11
-rw-r--r--deskutils/recoll/files/patch-query-Makefile11
-rw-r--r--deskutils/recoll/files/patch-utils-Makefile11
-rw-r--r--deskutils/recoll/files/patch-utils-md5.h13
-rw-r--r--deskutils/recoll/pkg-plist5
7 files changed, 55 insertions, 6 deletions
diff --git a/deskutils/recoll/Makefile b/deskutils/recoll/Makefile
index 17ec79862197..cf3d9279fa6d 100644
--- a/deskutils/recoll/Makefile
+++ b/deskutils/recoll/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= recoll
-PORTVERSION= 1.20.2
+PORTVERSION= 1.21.0
CATEGORIES= deskutils
MASTER_SITES= http://www.lesbonscomptes.com/${PORTNAME}/
-MAINTAINER= arved@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Personal full text search package, based on Xapian
LICENSE= GPLv2
@@ -20,7 +20,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
unrar:${PORTSDIR}/archivers/unrar \
unrtf:${PORTSDIR}/textproc/unrtf
-USES= gmake iconv shebangfix
+USES= bison gmake iconv shebangfix
SHEBANG_FILES= filters/rclimg desktop/hotrecoll.py
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-pic
diff --git a/deskutils/recoll/distinfo b/deskutils/recoll/distinfo
index ea57731c8e09..7c588ed8d172 100644
--- a/deskutils/recoll/distinfo
+++ b/deskutils/recoll/distinfo
@@ -1,2 +1,2 @@
-SHA256 (recoll-1.20.2.tar.gz) = 28f5e8d7e9bef41932b26fe48ee2718bcc800a294a0066eb202f8978cb27380c
-SIZE (recoll-1.20.2.tar.gz) = 2156597
+SHA256 (recoll-1.21.0.tar.gz) = 0450d85d5065d22e87ae600571e3be23a5ff2000f533c15f819a5bd77164a1be
+SIZE (recoll-1.21.0.tar.gz) = 2234834
diff --git a/deskutils/recoll/files/patch-mk-commondefs b/deskutils/recoll/files/patch-mk-commondefs
new file mode 100644
index 000000000000..d0e49d9c5a03
--- /dev/null
+++ b/deskutils/recoll/files/patch-mk-commondefs
@@ -0,0 +1,11 @@
+--- mk/commondefs.orig 2015-07-16 19:52:37 UTC
++++ mk/commondefs
+@@ -15,7 +15,7 @@ COMMONCXXFLAGS = -I. \
+ # the sys file or localdefs
+ SYSPICFLAGS = -fPIC -DPIC
+
+-LIBRECOLL = -L$(depth)/lib -lrecoll -Wl,-rpath=$(libdir)/recoll
++LIBRECOLL = -L$(depth)/lib -lrecoll -liconv -Wl,-rpath=$(libdir)/recoll
+
+ RANLIB = test -f
+ AR=ar
diff --git a/deskutils/recoll/files/patch-query-Makefile b/deskutils/recoll/files/patch-query-Makefile
new file mode 100644
index 000000000000..623e3e929ece
--- /dev/null
+++ b/deskutils/recoll/files/patch-query-Makefile
@@ -0,0 +1,11 @@
+--- query/Makefile.orig 2015-07-16 19:59:24 UTC
++++ query/Makefile
+@@ -13,7 +13,7 @@ wasaparse.tab.cpp : wasaparse.y
+ XADUMP_OBJS= xadump.o
+ xadump : $(XADUMP_OBJS)
+ $(CXX) $(ALL_CXXFLAGS) -o xadump $(XADUMP_OBJS) \
+- $(depth)/lib/librecoll.a $(LIBICONV) $(LIBXAPIAN) $(LIBSYS)
++ $(depth)/lib/librecoll.a -liconv $(LIBICONV) $(LIBXAPIAN) $(LIBSYS)
+ xadump.o : xadump.cpp
+ $(CXX) $(ALL_CXXFLAGS) -c xadump.cpp
+
diff --git a/deskutils/recoll/files/patch-utils-Makefile b/deskutils/recoll/files/patch-utils-Makefile
new file mode 100644
index 000000000000..89d26e8b98b6
--- /dev/null
+++ b/deskutils/recoll/files/patch-utils-Makefile
@@ -0,0 +1,11 @@
+--- utils/Makefile.orig 2015-07-16 19:56:54 UTC
++++ utils/Makefile
+@@ -4,7 +4,7 @@ include $(depth)/mk/sysconf
+ # Use a static link for some of the utility programs so that they can be
+ # executed independantly of the installed version of recoll. None of them
+ # are part of the official distrib anyway
+-LIBRECOLL = ../lib/librecoll.a
++LIBRECOLL = ../lib/librecoll.a -liconv
+
+ PROGS = pxattr trclosefrom trecrontab \
+ trnetcon trcopyfile trcircache trmd5 trreadfile trfileudi \
diff --git a/deskutils/recoll/files/patch-utils-md5.h b/deskutils/recoll/files/patch-utils-md5.h
new file mode 100644
index 000000000000..835ade897e73
--- /dev/null
+++ b/deskutils/recoll/files/patch-utils-md5.h
@@ -0,0 +1,13 @@
+--- utils/md5.h.orig 2015-07-16 19:46:26 UTC
++++ utils/md5.h
+@@ -19,6 +19,10 @@
+ #define MD5_DIGEST_LENGTH 16
+ #define MD5_DIGEST_STRING_LENGTH (MD5_DIGEST_LENGTH * 2 + 1)
+
++typedef uint32_t u_int32_t;
++typedef uint64_t u_int64_t;
++typedef uint8_t u_int8_t;
++
+ typedef struct MD5Context {
+ u_int32_t state[4]; /* state */
+ u_int64_t count; /* number of bits, mod 2^64 */
diff --git a/deskutils/recoll/pkg-plist b/deskutils/recoll/pkg-plist
index ddaef11c30f3..ba46d78efce9 100644
--- a/deskutils/recoll/pkg-plist
+++ b/deskutils/recoll/pkg-plist
@@ -17,7 +17,7 @@ man/man5/recoll.conf.5.gz
%%QT4%%share/applications/recoll-searchgui.desktop
%%QT4%%share/icons/hicolor/48x48/apps/recoll.png
%%QT4%%share/pixmaps/recoll.png
-%%DATADIR%%/doc/docbook.css
+%%DATADIR%%/doc/docbook-xsl.css
%%DATADIR%%/doc/usermanual.html
%%DATADIR%%/examples/fields
%%DATADIR%%/examples/fragbuts.xml
@@ -31,9 +31,11 @@ man/man5/recoll.conf.5.gz
%%DATADIR%%/filters/hotrecoll.py
%%DATADIR%%/filters/msodump.zip
%%DATADIR%%/filters/ppt-dump.py
+%%DATADIR%%/filters/rcl7z
%%DATADIR%%/filters/rclabw
%%DATADIR%%/filters/rclaptosidman
%%DATADIR%%/filters/rclaudio
+%%DATADIR%%/filters/rclcheckneedretry.sh
%%DATADIR%%/filters/rclchm
%%DATADIR%%/filters/rclconfig.py
%%DATADIR%%/filters/rcldia
@@ -109,6 +111,7 @@ man/man5/recoll.conf.5.gz
%%DATADIR%%/images/video.png
%%DATADIR%%/images/wordprocessing.png
%%DATADIR%%/translations/recoll_cs.qm
+%%DATADIR%%/translations/recoll_da.qm
%%DATADIR%%/translations/recoll_de.qm
%%DATADIR%%/translations/recoll_el.qm
%%DATADIR%%/translations/recoll_es.qm