aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-30 08:35:49 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-30 08:35:49 +0000
commit24794c61d6e3c9b86f9c4972eedb598c14266a10 (patch)
tree6834cae424635efc6fd5cecd039422f85bca412b /deskutils
parent53ae2abde5fff49698ad1598e013e4f7d8d0b721 (diff)
downloadports-24794c61d6e3c9b86f9c4972eedb598c14266a10.tar.gz
ports-24794c61d6e3c9b86f9c4972eedb598c14266a10.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/genius/Makefile19
-rw-r--r--deskutils/genius/distinfo4
-rw-r--r--deskutils/genius/files/patch-src::Makefile.in26
-rw-r--r--deskutils/genius/files/patch-src::mpwrap.c14
-rw-r--r--deskutils/genius/pkg-descr2
-rw-r--r--deskutils/genius/pkg-plist53
6 files changed, 101 insertions, 17 deletions
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index ab9cba3b5df6..0d933a1750f1 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= genius
-PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTVERSION= 0.7.2
CATEGORIES= deskutils gnome
-MASTER_SITES= http://ftp.5z.com/pub/genius/
+MASTER_SITES= ${MASTER_SITE_GNOME} \
+ http://ftp.5z.com/pub/genius/
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
MAINTAINER= ports@FreeBSD.org
COMMENT= Arbitrary precision calculator for Gnome Desktop Environment
@@ -18,20 +19,20 @@ LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
USE_PERL5_BUILD= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget gtksourceview libgnomeui \
- lthack vte
+USE_GNOME= gnomehack gnomeprefix gnometarget gtksourceview libgnomeui vte
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
+LIBTOOLFILES= configure mpfr/configure
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-extra-gcc-optimization
+INSTALLS_OMF= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500018
-IGNORE= "Requires readline 4.2 or newer"
+BROKEN= Does not compile on 4.x
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
-post-patch:
- @${PERL} -pi -e 's|-O3 ||g' ${WRKSRC}/configure
-
.include <bsd.port.post.mk>
diff --git a/deskutils/genius/distinfo b/deskutils/genius/distinfo
index 475756eaa05d..0454998ff643 100644
--- a/deskutils/genius/distinfo
+++ b/deskutils/genius/distinfo
@@ -1,2 +1,2 @@
-MD5 (genius-0.7.1.tar.gz) = c0e4e906bee0c14aaebfc3ecd17ceef4
-SIZE (genius-0.7.1.tar.gz) = 1551309
+MD5 (genius-0.7.2.tar.gz) = f1300f11e982fa10b7d10f738dd0a649
+SIZE (genius-0.7.2.tar.gz) = 2481534
diff --git a/deskutils/genius/files/patch-src::Makefile.in b/deskutils/genius/files/patch-src::Makefile.in
index 8f8408040069..cf943a3e0dfb 100644
--- a/deskutils/genius/files/patch-src::Makefile.in
+++ b/deskutils/genius/files/patch-src::Makefile.in
@@ -1,6 +1,24 @@
---- src/Makefile.in.bak Fri Oct 17 02:22:23 2003
-+++ src/Makefile.in Fri Oct 17 12:11:07 2003
-@@ -213,7 +213,7 @@
+--- src/Makefile.in.orig Fri Dec 24 04:47:06 2004
++++ src/Makefile.in Sat Dec 25 00:18:14 2004
+@@ -168,7 +168,7 @@
+ YFLAGS = -d -t
+ @INTERNAL_MPFR_TRUE@MPFR_INCLUDEDIR = -I$(top_srcdir)/mpfr -I$(top_builddir)/mpfr
+ @INTERNAL_MPFR_FALSE@MPFR_INCLUDEDIR =
+-@INTERNAL_MPFR_TRUE@MPFR_LIBDIR = -L$(top_srcdir)/mpfr -L$(top_builddir)/mpfr
++@INTERNAL_MPFR_TRUE@MPFR_LIBDIR = $(top_builddir)/mpfr/libmpfr.a
+ @INTERNAL_MPFR_FALSE@MPFR_LIBDIR =
+
+ INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" -DG_LOG_DOMAIN=\"Genius\" -DDATADIR=\""$(datadir)"\" -DLIBEXECDIR=\""$(libexecdir)"\" -DICONDIR=\""$(datadir)/pixmaps/genius"\" -DLIBRARY_DIR=\""$(datadir)/genius/"\" -I$(srcdir) -I$(includedir) -I$(top_srcdir) -I$(top_srcdir)/vicious-extensions -I$(top_srcdir)/gtkextra -I$(top_builddir) -I$(top_builddir)/vicious-extensions -I$(top_builddir)/gtkextra $(MPFR_INCLUDEDIR) $(GMP_INCLUDEDIR) $(GENIUS_CFLAGS) $(EXTRA_WARNING_CFLAGS)
+@@ -183,7 +183,7 @@
+ gnome_genius_SOURCES = genius-i18n.h calc.c calc.h eval.c eval.h gnome-genius.c gnome-genius.h util.c util.h dict.c dict.h funclib.c funclib.h mpwrap.c mpwrap.h mpzextra.c mpzextra.h matrix.c matrix.h matrixw.c matrixw.h matop.c matop.h compil.c compil.h structs.h lexer.l lexer.h parseutil.h parseutil.c inter.c inter.h plugin.c plugin.h plugread.c plugread.h plug_api.h parse.h parse.y genius_lists.c utype.c utype.h extra.h geloutput.c geloutput.h graphing.h graphing.c
+
+
+-gnome_genius_LDADD = -L$(top_builddir)/vicious-extensions -lviciousui -L$(top_builddir)/gtkextra -lgtkextra-genius -lm @GMP_LIB@ $(MPFR_LIBDIR) -lmpfr @LEXLIB@ $(GENIUS_LIBS) @READLINE_LIB@ @TERMCAP_LIB@
++gnome_genius_LDADD = -L$(top_builddir)/vicious-extensions -lviciousui -L$(top_builddir)/gtkextra -lgtkextra-genius -lm @GMP_LIB@ $(MPFR_LIBDIR) @LEXLIB@ $(GENIUS_LIBS) @READLINE_LIB@ @TERMCAP_LIB@
+
+
+ genius_readline_helper_fifo_SOURCES = genius_lists.c genius-readline-helper.c
+@@ -230,7 +230,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I..
LIBS = @LIBS@
@@ -8,4 +26,4 @@
+libtestplugin_la_LDFLAGS = -module -avoid-version
libtestplugin_la_LIBADD =
libtestplugin_la_OBJECTS = testplugin.lo
- bin_PROGRAMS = gnome-genius$(EXEEXT) genius$(EXEEXT)
+ bin_PROGRAMS = @GNOME_GENIUS@ genius$(EXEEXT)
diff --git a/deskutils/genius/files/patch-src::mpwrap.c b/deskutils/genius/files/patch-src::mpwrap.c
new file mode 100644
index 000000000000..d2f4625dd593
--- /dev/null
+++ b/deskutils/genius/files/patch-src::mpwrap.c
@@ -0,0 +1,14 @@
+--- src/mpwrap.c.orig Wed Nov 10 04:05:51 2004
++++ src/mpwrap.c Fri Dec 24 17:25:26 2004
+@@ -1933,8 +1933,9 @@
+ if G_UNLIKELY ( ! mpz_invert (r.data.ival,
+ r.data.ival,
+ mod->data.ival)) {
+- char *n1 = mpwl_getstring_for_error (&r);
+- char *n2 = mpwl_getstring_for_error (mod);
++ char *n1,*n2;
++ n1 = mpwl_getstring_for_error (&r);
++ n2 = mpwl_getstring_for_error (mod);
+ gel_errorout (_("Can't invert %s modulo %s "
+ "in %s"),
+ n1, n2, "powm");
diff --git a/deskutils/genius/pkg-descr b/deskutils/genius/pkg-descr
index b3e749ff0ba6..07e4addd17b0 100644
--- a/deskutils/genius/pkg-descr
+++ b/deskutils/genius/pkg-descr
@@ -16,4 +16,4 @@ Features of Genius:
* complex numbers
* more ...
-WWW: http://www.5z.com/jirka/genius.html
+WWW: http://www.jirka.org/genius.html
diff --git a/deskutils/genius/pkg-plist b/deskutils/genius/pkg-plist
index a8b096df7287..de925e44a8a9 100644
--- a/deskutils/genius/pkg-plist
+++ b/deskutils/genius/pkg-plist
@@ -27,6 +27,7 @@ share/gnome/genius/gel/combinatorics/factorial.gel
share/gnome/genius/gel/combinatorics/loader.gel
share/gnome/genius/gel/combinatorics/misc.gel
share/gnome/genius/gel/combinatorics/recursive_sequences.gel
+share/gnome/genius/gel/equation_solving/diffeqs.gel
share/gnome/genius/gel/equation_solving/find_root.gel
share/gnome/genius/gel/equation_solving/loader.gel
share/gnome/genius/gel/functions/complex_numbers.gel
@@ -56,11 +57,49 @@ share/gnome/genius/gel/sets/basic.gel
share/gnome/genius/gel/sets/loader.gel
share/gnome/genius/gel/statistics/basic.gel
share/gnome/genius/gel/statistics/loader.gel
+share/gnome/genius/genius.txt
share/gnome/genius/gtksourceview/genius.lang
-share/gnome/genius/manual.txt
share/gnome/genius/plugins/test.plugin
+share/gnome/help/genius/C/about.xml
+share/gnome/help/genius/C/examples.xml
+share/gnome/help/genius/C/figures/genius_window.png
+share/gnome/help/genius/C/gel-absolute-value-modulus.xml
+share/gnome/help/genius/C/gel-comparison-operators.xml
+share/gnome/help/genius/C/gel-conditionals.xml
+share/gnome/help/genius/C/gel-error-handling.xml
+share/gnome/help/genius/C/gel-function-list.xml
+share/gnome/help/genius/C/gel-functions.xml
+share/gnome/help/genius/C/gel-loading-programs.xml
+share/gnome/help/genius/C/gel-loops.xml
+share/gnome/help/genius/C/gel-lvalues.xml
+share/gnome/help/genius/C/gel-matrix-support.xml
+share/gnome/help/genius/C/gel-matrix-transpose.xml
+share/gnome/help/genius/C/gel-modular-evaluation.xml
+share/gnome/help/genius/C/gel-operator-list.xml
+share/gnome/help/genius/C/gel-polynomials.xml
+share/gnome/help/genius/C/gel-previous-result.xml
+share/gnome/help/genius/C/gel-references.xml
+share/gnome/help/genius/C/gel-returning.xml
+share/gnome/help/genius/C/gel-separator.xml
+share/gnome/help/genius/C/gel-startup-procedure.xml
+share/gnome/help/genius/C/gel-sums-products.xml
+share/gnome/help/genius/C/gel-values.xml
+share/gnome/help/genius/C/gel-variables.xml
+share/gnome/help/genius/C/genius.xml
+share/gnome/help/genius/C/legal.xml
+share/gnome/help/genius/C/prefs-display.xml
+share/gnome/help/genius/C/prefs-precision.xml
+share/gnome/help/genius/C/prefs-terminal.xml
+share/gnome/help/genius/C/starting-to-start.xml
+share/gnome/help/genius/C/starting-when-start.xml
+share/gnome/help/genius/C/usage-create-program.xml
+share/gnome/help/genius/C/usage-open-program.xml
+share/gnome/help/genius/C/usage-workarea.xml
share/gnome/mime-info/genius.keys
share/gnome/mime-info/genius.mime
+share/gnome/omf/genius/genius-C.omf
+share/icons/hicolor/32x32/apps/gnome-genius.png
+share/icons/hicolor/48x48/apps/gnome-genius.png
share/locale/az/LC_MESSAGES/genius.mo
share/locale/ca/LC_MESSAGES/genius.mo
share/locale/cs/LC_MESSAGES/genius.mo
@@ -74,9 +113,11 @@ share/locale/ga/LC_MESSAGES/genius.mo
share/locale/hi/LC_MESSAGES/genius.mo
share/locale/hr/LC_MESSAGES/genius.mo
share/locale/it/LC_MESSAGES/genius.mo
+share/locale/ja/LC_MESSAGES/genius.mo
share/locale/ko/LC_MESSAGES/genius.mo
share/locale/nl/LC_MESSAGES/genius.mo
share/locale/no/LC_MESSAGES/genius.mo
+share/locale/pa/LC_MESSAGES/genius.mo
share/locale/pl/LC_MESSAGES/genius.mo
share/locale/pt/LC_MESSAGES/genius.mo
share/locale/pt_BR/LC_MESSAGES/genius.mo
@@ -85,6 +126,10 @@ share/locale/sr/LC_MESSAGES/genius.mo
share/locale/sr@Latn/LC_MESSAGES/genius.mo
share/locale/sv/LC_MESSAGES/genius.mo
share/locale/zh_CN/LC_MESSAGES/genius.mo
+@dirrm share/gnome/omf/genius
+@dirrm share/gnome/help/genius/C/figures
+@dirrm share/gnome/help/genius/C
+@dirrm share/gnome/help/genius
@dirrm share/gnome/genius/gtksourceview
@dirrm share/gnome/genius/plugins
@dirrm share/gnome/genius/gel/statistics
@@ -100,3 +145,9 @@ share/locale/zh_CN/LC_MESSAGES/genius.mo
@dirrm share/gnome/genius
@dirrm lib/genius
@dirrm include/genius
+@unexec rmdir %D/share/icons/hicolor/48x48/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/48x48 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
+@unexec rmdir %D/share/icons 2>/dev/null || true