aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
commit4ca0e60800b90ba4a6de31beabeee8ccce611649 (patch)
tree8324ab31f68eba587c532d238cd3f502d0a56322 /deskutils
parent7530f93a62fb8bcd686d08f2bfa5dc0f623f3c73 (diff)
downloadports-4ca0e60800b90ba4a6de31beabeee8ccce611649.tar.gz
ports-4ca0e60800b90ba4a6de31beabeee8ccce611649.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/bitnotes/Makefile2
-rw-r--r--deskutils/bulb/Makefile2
-rw-r--r--deskutils/genius/Makefile2
-rw-r--r--deskutils/gnofin/Makefile2
-rw-r--r--deskutils/gnome-pim/Makefile2
-rw-r--r--deskutils/gnome-utils/Makefile2
-rw-r--r--deskutils/gnomepim/Makefile2
-rw-r--r--deskutils/gnomeutils2/Makefile2
-rw-r--r--deskutils/gnucash/Makefile2
-rw-r--r--deskutils/yank/Makefile2
10 files changed, 10 insertions, 10 deletions
diff --git a/deskutils/bitnotes/Makefile b/deskutils/bitnotes/Makefile
index 0fc66587aab9..c5ec666d21b2 100644
--- a/deskutils/bitnotes/Makefile
+++ b/deskutils/bitnotes/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
AUTOCONF= autoconf && \
- ${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ ${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' \
${WRKSRC}/configure
diff --git a/deskutils/bulb/Makefile b/deskutils/bulb/Makefile
index cab2b75907c9..66c588fe47bc 100644
--- a/deskutils/bulb/Makefile
+++ b/deskutils/bulb/Makefile
@@ -19,7 +19,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index 49a6d8dc2596..386ba89e104d 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -20,7 +20,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/deskutils/gnofin/Makefile b/deskutils/gnofin/Makefile
index 1fa7f102328e..d170faf3d953 100644
--- a/deskutils/gnofin/Makefile
+++ b/deskutils/gnofin/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gnofin.1
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/deskutils/gnome-pim/Makefile b/deskutils/gnome-pim/Makefile
index b43099783102..b688bc0ac521 100644
--- a/deskutils/gnome-pim/Makefile
+++ b/deskutils/gnome-pim/Makefile
@@ -38,7 +38,7 @@ pre-extract:
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/deskutils/gnome-utils/Makefile b/deskutils/gnome-utils/Makefile
index 0200e1f452ff..255eb9d58b55 100644
--- a/deskutils/gnome-utils/Makefile
+++ b/deskutils/gnome-utils/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/deskutils/gnomepim/Makefile b/deskutils/gnomepim/Makefile
index b43099783102..b688bc0ac521 100644
--- a/deskutils/gnomepim/Makefile
+++ b/deskutils/gnomepim/Makefile
@@ -38,7 +38,7 @@ pre-extract:
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/deskutils/gnomeutils2/Makefile b/deskutils/gnomeutils2/Makefile
index 0200e1f452ff..255eb9d58b55 100644
--- a/deskutils/gnomeutils2/Makefile
+++ b/deskutils/gnomeutils2/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/deskutils/gnucash/Makefile b/deskutils/gnucash/Makefile
index 591a4a4755eb..32d5fd6a4d9b 100644
--- a/deskutils/gnucash/Makefile
+++ b/deskutils/gnucash/Makefile
@@ -41,7 +41,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
MAN1= gnc-prices.1 gnucash.1
pre-patch:
- @${PERL} -pi -e 's^-l(pthread|c_r)^-pthread^g ; \
+ @${PERL} -pi -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's^\$\{datadir\}/gnome/^\$\(datadir\)/^g ; \
diff --git a/deskutils/yank/Makefile b/deskutils/yank/Makefile
index 4af9d9ecc050..b237a4d99640 100644
--- a/deskutils/yank/Makefile
+++ b/deskutils/yank/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's^-l(pthread|c_r)^-pthread^g ; \
+ @${PERL} -pi -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's^\$\(datadir\)/gnome/^\$\(datadir\)/^g ; \