aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-05 17:09:32 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-05 17:09:32 +0000
commit4d191364fd83e2cd16adfc86b1111724a171d3e0 (patch)
tree3c20f3decdf3d378f2e55fa2512864ef5bd1531c /deskutils
parentdf990667c8802cf00ed90748c2063e843faa764e (diff)
downloadports-4d191364fd83e2cd16adfc86b1111724a171d3e0.tar.gz
ports-4d191364fd83e2cd16adfc86b1111724a171d3e0.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/genius/Makefile2
-rw-r--r--deskutils/genius/files/patch-src_genius-readline-helper.c11
-rw-r--r--deskutils/genius/files/patch-src_inter.c9
3 files changed, 21 insertions, 1 deletions
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index aea0c0b2330f..b5cbc89bb4b9 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libmpfr.so:${PORTSDIR}/math/mpfr
RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
- shared-mime-info tar:xz
+ readline shared-mime-info tar:xz
USE_GNOME= gnomedocutils gnomeprefix gtksourceview2 gnomevfs2 vte
USE_CSTD= gnu89
GNU_CONFIGURE= yes
diff --git a/deskutils/genius/files/patch-src_genius-readline-helper.c b/deskutils/genius/files/patch-src_genius-readline-helper.c
new file mode 100644
index 000000000000..b420f52d6069
--- /dev/null
+++ b/deskutils/genius/files/patch-src_genius-readline-helper.c
@@ -0,0 +1,11 @@
+--- src/genius-readline-helper.c.orig 2009-10-19 01:06:52.000000000 +0000
++++ src/genius-readline-helper.c
+@@ -164,7 +164,7 @@ main(int argc, char *argv[])
+ rl_terminal_name = "xterm";
+ rl_readline_name = "Genius";
+ rl_attempted_completion_function =
+- (CPPFunction *)tab_completion;
++ (rl_completion_func_t *)tab_completion;
+
+ while(fgets(buf,4096,infp)) {
+ int count;
diff --git a/deskutils/genius/files/patch-src_inter.c b/deskutils/genius/files/patch-src_inter.c
new file mode 100644
index 000000000000..f65b8da0ab08
--- /dev/null
+++ b/deskutils/genius/files/patch-src_inter.c
@@ -0,0 +1,9 @@
+--- src/inter.c.orig 2009-04-19 23:44:43.000000000 +0000
++++ src/inter.c
+@@ -368,5 +368,5 @@ init_inter(void)
+ {
+ rl_readline_name = "Genius";
+ rl_attempted_completion_function =
+- (CPPFunction *)tab_completion;
++ (rl_completion_func_t *)tab_completion;
+ }