aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-03 21:54:14 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-03 21:54:14 +0000
commit01da1d3d6cf30b21f44b8cdec6111c1581fdb020 (patch)
treeab5ce506e32784d5c0f435c1e3d56915f38eba14 /deskutils
parent4586d2ad5c8db1208ef17384b5c1df8aa36a3f9e (diff)
downloadports-01da1d3d6cf30b21f44b8cdec6111c1581fdb020.tar.gz
ports-01da1d3d6cf30b21f44b8cdec6111c1581fdb020.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/gnote/Makefile16
-rw-r--r--deskutils/hot-babe/Makefile4
-rw-r--r--deskutils/pinot/Makefile21
-rw-r--r--deskutils/pypanel/Makefile4
-rw-r--r--deskutils/qlabels/Makefile4
5 files changed, 19 insertions, 30 deletions
diff --git a/deskutils/gnote/Makefile b/deskutils/gnote/Makefile
index c6d28482bab8..d8b6a08e3372 100644
--- a/deskutils/gnote/Makefile
+++ b/deskutils/gnote/Makefile
@@ -35,14 +35,12 @@ CONFIGURE_ARGS= --disable-dbus
DOCS= AUTHORS ChangeLog NEWS README TODO
MAN1= gnote.1
-.if !defined(WITHOUT_APPLET)
-LIB_DEPENDS+= libpanelappletmm-2.6.so:${PORTSDIR}/x11-toolkits/libpanelappletmm
-CONFIGURE_ARGS+=--enable-applet
-PLIST_SUB+= APPLET=""
-.else
-CONFIGURE_ARGS+=--disable-applet
-PLIST_SUB+= APPLET="@comment "
-.endif
+OPTIONS_DEFINE= DOCS APPLET
+OPTIONS_DEFAULT=APPLET
+OPTIONS_SUB= yes
+
+APPLET_LIB_DEPENDS= libpanelappletmm-2.6.so:${PORTSDIR}/x11-toolkits/libpanelappletmm
+APPLET_CONFIGURE_ENABLE=applet
PLIST_SUB+= VERSION=${PORTVERSION}
@@ -50,12 +48,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/include/boost|${LOCALBASE}/include/boost|g' \
${WRKSRC}/configure
-.ifndef (NOPORTDOCS)
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/deskutils/hot-babe/Makefile b/deskutils/hot-babe/Makefile
index 9f89a270d64a..bf52d815b924 100644
--- a/deskutils/hot-babe/Makefile
+++ b/deskutils/hot-babe/Makefile
@@ -18,6 +18,8 @@ USE_GNOME= gtk20
PORTDOCS= ChangeLog NEWS TODO LICENSE CONTRIBUTORS copyright config.example
+OPTIONS_DEFINE= DOCS
+
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "Warning! This port contains some adults only content."
@@ -26,11 +28,9 @@ pre-everything::
post-install:
${INSTALL_MAN} ${WRKSRC}/hot-babe.1 ${STAGEDIR}${PREFIX}/man/man1
-.ifndef (NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index 5ff01389370d..056534cb368a 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -54,18 +54,13 @@ USE_LDCONFIG= ${PREFIX}/lib/pinot/backends ${PREFIX}/lib/pinot/filters
SHEBANG_LANG= bash
SHEBANG_FILES= scripts/bash/*.sh
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-debug=yes
-.endif
-
-.if defined(WITH_CHMLIB)
-CONFIGURE_ARGS+= --enable-chmlib=yes
-LIB_DEPENDS+= libchm.so:${PORTSDIR}/misc/chmlib
-PLIST_SUB+= CHMLIB=""
-.else
-CONFIGURE_ARGS+= --disable-chmlib
-PLIST_SUB+= CHMLIB="@comment "
-.endif
+OPTIONS_DEFINE= DEBUG CHMLIB DOCS
+OPTIONS_SUB= yes
+
+DEBUG_CONFIGURE_ENABLE= debug-yes
+
+CHMLIB_CONFIGURE_ENABLE= chmlib=yes
+CHMLIB_LIB_DEPENDS= libchm.so:${PORTSDIR}/misc/chmlib
INSTALLS_ICONS= yes
@@ -99,9 +94,7 @@ pre-configure:
post-install:
${TOUCH} ${STAGEDIR}${DATADIR}/stopwords/.empty_file
-.if !defined(NOPORTDOCS)
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/deskutils/pypanel/Makefile b/deskutils/pypanel/Makefile
index cd0e86ae4264..9db596fa9f33 100644
--- a/deskutils/pypanel/Makefile
+++ b/deskutils/pypanel/Makefile
@@ -24,6 +24,8 @@ PYDISTUTILS_PKGNAME= PyPanel
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/bin/freetype-config|${LOCALBASE}/bin/freetype-config|; \
@@ -40,9 +42,7 @@ post-patch:
${WRKSRC}/pypanelrc
post-install:
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/deskutils/qlabels/Makefile b/deskutils/qlabels/Makefile
index 6af6abc1ce05..f4b62e45b0a7 100644
--- a/deskutils/qlabels/Makefile
+++ b/deskutils/qlabels/Makefile
@@ -24,6 +24,8 @@ DESKTOP_ENTRIES= "qLabels" \
"Office;Qt;" \
"true"
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} 's|/usr|${PREFIX}|g' \
${WRKSRC}/qlabels.pro \
@@ -31,10 +33,8 @@ post-patch:
${WRKSRC}/lib/papers.cpp
post-install:
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Changelog ${WRKSRC}/LICENSE \
${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>