aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2007-02-04 23:10:52 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2007-02-04 23:10:52 +0000
commit885abf003fe4f81f4896bde23a750d844c2f4afd (patch)
tree9eaee603e16303b113438289e57c991abedc1cc6 /deskutils
parent160cdc1716ced56a67d2e3522b812a4540501a9f (diff)
downloadports-885abf003fe4f81f4896bde23a750d844c2f4afd.tar.gz
ports-885abf003fe4f81f4896bde23a750d844c2f4afd.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/tomboy/Makefile30
-rw-r--r--deskutils/tomboy/distinfo6
-rw-r--r--deskutils/tomboy/files/patch-Tomboy_Applet.cs13
-rw-r--r--deskutils/tomboy/files/patch-Tomboy_Defines.cs.in11
-rw-r--r--deskutils/tomboy/pkg-plist52
5 files changed, 92 insertions, 20 deletions
diff --git a/deskutils/tomboy/Makefile b/deskutils/tomboy/Makefile
index b8a7f691b560..9755ba394f92 100644
--- a/deskutils/tomboy/Makefile
+++ b/deskutils/tomboy/Makefile
@@ -3,12 +3,12 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.25 2006/09/15 02:47:48 tmclau02 Exp $
+# $Id: Makefile,v 1.37 2007/01/22 20:19:00 tmclau02 Exp $
#
PORTNAME= tomboy
-PORTVERSION= 0.4.1
-PORTREVISION= 2
+PORTVERSION= 0.5.4
+PORTREVISION= 1
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -17,25 +17,25 @@ DIST_SUBDIR= gnome2
MAINTAINER= bsd-sharp-list@forge.novell.com
COMMENT= Personal note taking system for the GNOME desktop
-LIB_DEPENDS= gtkspell.0:${PORTSDIR}/textproc/gtkspell \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-BUILD_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
- ${LOCALBASE}/lib/mono/gmime-sharp/gmime-sharp.dll:${PORTSDIR}/mail/gmime2-sharp
-RUN_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
- ${LOCALBASE}/lib/mono/gmime-sharp/gmime-sharp.dll:${PORTSDIR}/mail/gmime2-sharp
+LIB_DEPENDS= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+BUILD_DEPENDS= ${LOCALBASE}/lib/mono/gmime-sharp/gmime-sharp.dll:${PORTSDIR}/mail/gmime2-sharp
+RUN_DEPENDS= ${LOCALBASE}/lib/mono/gmime-sharp/gmime-sharp.dll:${PORTSDIR}/mail/gmime2-sharp \
+ dbus-daemon:${PORTSDIR}/devel/dbus
USE_BZIP2= yes
USE_GETTEXT= yes
-USE_GNOME= gnomehack gnometarget intltool gnomeprefix gnomepanel
-USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnometarget intltool gnomeprefix gnomesharp20
GNU_CONFIGURE= yes
USE_GMAKE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
-CONFIGURE_ARGS+=--enable-evolution=yes
+CONFIGURE_ARGS+=--enable-evolution=yes \
+ --enable-dbus=yes \
+ --enable-dbus-service-dir-check=no
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ DBUS_SERVICE_DIR="${PREFIX}/share/dbus-1/services"
MAN1= tomboy.1
GCONF_SCHEMAS= tomboy.schemas
@@ -43,9 +43,7 @@ GCONF_SCHEMAS= tomboy.schemas
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|(libdir)/dbus-1.0|(prefix)/share/dbus-1|g' \
- ${WRKSRC}/data/Makefile.in
- @${REINPLACE_CMD} -e 's|`$$PKG_CONFIG --variable=libdir libpanelapplet-2.0`|"$$libdir"|g; \
+ @${REINPLACE_CMD} 's|`$$PKG_CONFIG --variable=libdir libpanelapplet-2.0`|"$$libdir"|g; \
s|PANELAPPLET_SERVER_DIR="$$libdir|PANELAPPLET_SERVER_DIR="$$prefix/libdata|g; \
s|PANELAPPLET_SERVER_DIR="$$PANELAPPLET_LIBDIR|PANELAPPLET_SERVER_DIR="$$prefix/libdata|g' \
${WRKSRC}/configure
diff --git a/deskutils/tomboy/distinfo b/deskutils/tomboy/distinfo
index 107266dda727..916b14f18e59 100644
--- a/deskutils/tomboy/distinfo
+++ b/deskutils/tomboy/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/tomboy-0.4.1.tar.bz2) = 40e0f51d832d04f762851fc9a88c01ea
-SHA256 (gnome2/tomboy-0.4.1.tar.bz2) = 389f01838a2a597c78fca7066636ee4867f3896012c47a964278ad6639ae2338
-SIZE (gnome2/tomboy-0.4.1.tar.bz2) = 774805
+MD5 (gnome2/tomboy-0.5.4.tar.bz2) = 0cd4701cadd23cef76c0fe708a17c3d5
+SHA256 (gnome2/tomboy-0.5.4.tar.bz2) = aa87ebc9cb629f7c875c1b865bc499b97bcc13aebb35d243e40e94e7a12c12d2
+SIZE (gnome2/tomboy-0.5.4.tar.bz2) = 1012487
diff --git a/deskutils/tomboy/files/patch-Tomboy_Applet.cs b/deskutils/tomboy/files/patch-Tomboy_Applet.cs
new file mode 100644
index 000000000000..6c25d7305285
--- /dev/null
+++ b/deskutils/tomboy/files/patch-Tomboy_Applet.cs
@@ -0,0 +1,13 @@
+--- Tomboy/Applet.cs.orig Mon Jan 22 14:48:19 2007
++++ Tomboy/Applet.cs Mon Jan 22 14:48:22 2007
+@@ -91,7 +91,9 @@
+
+ void ShowHelpVerb ()
+ {
+- Tomboy.ActionManager ["ShowHelpAction"].Activate ();
++ // Don't use the ActionManager in this case because
++ // the handler won't know about the Screen.
++ GuiUtils.ShowHelp ("tomboy.xml", null, Screen, null);
+ }
+
+ void ShowAboutVerb ()
diff --git a/deskutils/tomboy/files/patch-Tomboy_Defines.cs.in b/deskutils/tomboy/files/patch-Tomboy_Defines.cs.in
new file mode 100644
index 000000000000..9c8c5b8c1719
--- /dev/null
+++ b/deskutils/tomboy/files/patch-Tomboy_Defines.cs.in
@@ -0,0 +1,11 @@
+--- Tomboy/Defines.cs.in.orig Thu Dec 7 19:06:17 2006
++++ Tomboy/Defines.cs.in Sun Jan 21 00:02:01 2007
+@@ -8,7 +8,7 @@
+ public const string VERSION = "@version@";
+ public const string DATADIR = "@datadir@";
+ public const string GNOME_LOCALE_DIR = "@datadir@/locale";
+- public const string GNOME_HELP_DIR = "@datadir@/gnome/help/tomboy";
++ public const string GNOME_HELP_DIR = "@datadir@/help/tomboy";
+ public const string PKGLIBDIR = "@pkglibdir@";
+ public const string SYS_PLUGINS_DIR = "@pkglibdir@/Plugins";
+ }
diff --git a/deskutils/tomboy/pkg-plist b/deskutils/tomboy/pkg-plist
index 0bf668361925..e9e3cad082b4 100644
--- a/deskutils/tomboy/pkg-plist
+++ b/deskutils/tomboy/pkg-plist
@@ -1,4 +1,6 @@
bin/tomboy
+lib/tomboy/Plugins/Backlinks.dll
+lib/tomboy/Plugins/Bugzilla.dll
lib/tomboy/Plugins/Evolution.dll
lib/tomboy/Plugins/ExportToHTML.dll
lib/tomboy/Plugins/FixedWidth.dll
@@ -11,9 +13,9 @@ lib/tomboy/libtomboy.la
lib/tomboy/libtomboy.so
libdata/bonobo/servers/GNOME_TomboyApplet.server
libdata/pkgconfig/tomboy-plugins.pc
-share/dbus-1/services/com.beatniksoftware.Tomboy.service
share/gnome/applications/DefaultPlugins.desktop
share/gnome/applications/tomboy.desktop
+share/dbus-1/services/org.gnome.Tomboy.service
share/gnome/help/tomboy/C/figures/tomboy-new-note.png
share/gnome/help/tomboy/C/figures/tomboy-panel.png
share/gnome/help/tomboy/C/figures/tomboy-preferences-editing.png
@@ -28,6 +30,13 @@ share/gnome/help/tomboy/es/figures/tomboy-preferences-hotkeys.png
share/gnome/help/tomboy/es/figures/tomboy-tools.png
share/gnome/help/tomboy/es/legal.xml
share/gnome/help/tomboy/es/tomboy.xml
+share/gnome/help/tomboy/fr/figures/tomboy-new-note.png
+share/gnome/help/tomboy/fr/figures/tomboy-panel.png
+share/gnome/help/tomboy/fr/figures/tomboy-preferences-editing.png
+share/gnome/help/tomboy/fr/figures/tomboy-preferences-hotkeys.png
+share/gnome/help/tomboy/fr/figures/tomboy-tools.png
+share/gnome/help/tomboy/fr/legal.xml
+share/gnome/help/tomboy/fr/tomboy.xml
share/gnome/help/tomboy/sv/figures/tomboy-new-note.png
share/gnome/help/tomboy/sv/figures/tomboy-panel.png
share/gnome/help/tomboy/sv/figures/tomboy-preferences-editing.png
@@ -37,12 +46,18 @@ share/gnome/help/tomboy/sv/legal.xml
share/gnome/help/tomboy/sv/tomboy.xml
share/gnome/omf/tomboy/tomboy-C.omf
share/gnome/omf/tomboy/tomboy-es.omf
+share/gnome/omf/tomboy/tomboy-fr.omf
share/gnome/omf/tomboy/tomboy-sv.omf
share/gnome/pixmaps/tomboy.png
+share/icons/hicolor/16x16/apps/tomboy-note.png
share/icons/hicolor/16x16/apps/tomboy.png
+share/icons/hicolor/22x22/apps/tomboy-note.png
share/icons/hicolor/22x22/apps/tomboy.png
+share/icons/hicolor/32x32/apps/tomboy.png
share/icons/hicolor/48x48/apps/tomboy.png
share/icons/hicolor/scalable/apps/tomboy.svg
+share/locale/ar/LC_MESSAGES/tomboy.mo
+share/locale/be/LC_MESSAGES/tomboy.mo
share/locale/bg/LC_MESSAGES/tomboy.mo
share/locale/bn/LC_MESSAGES/tomboy.mo
share/locale/bn_IN/LC_MESSAGES/tomboy.mo
@@ -83,6 +98,7 @@ share/locale/pt_BR/LC_MESSAGES/tomboy.mo
share/locale/ro/LC_MESSAGES/tomboy.mo
share/locale/ru/LC_MESSAGES/tomboy.mo
share/locale/rw/LC_MESSAGES/tomboy.mo
+share/locale/sl/LC_MESSAGES/tomboy.mo
share/locale/sq/LC_MESSAGES/tomboy.mo
share/locale/sr/LC_MESSAGES/tomboy.mo
share/locale/sr@Latn/LC_MESSAGES/tomboy.mo
@@ -95,19 +111,53 @@ share/locale/vi/LC_MESSAGES/tomboy.mo
share/locale/zh_CN/LC_MESSAGES/tomboy.mo
share/locale/zh_HK/LC_MESSAGES/tomboy.mo
share/locale/zh_TW/LC_MESSAGES/tomboy.mo
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/ro/LC_MESSAGES
+@dirrmtry share/locale/ro
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/ne/LC_MESSAGES
+@dirrmtry share/locale/ne
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be/LC_MESSAGES
+@dirrmtry share/locale/be
@dirrm share/gnome/omf/tomboy
@dirrm share/gnome/help/tomboy/sv/figures
@dirrm share/gnome/help/tomboy/sv
+@dirrm share/gnome/help/tomboy/fr/figures
+@dirrm share/gnome/help/tomboy/fr
@dirrm share/gnome/help/tomboy/es/figures
@dirrm share/gnome/help/tomboy/es
@dirrm share/gnome/help/tomboy/C/figures