aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-01-28 17:49:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-01-28 17:49:18 +0000
commitf239ddf49250286b3954ceb75abd24d85c38ff5a (patch)
tree821f6ca5d689d9bfb9448a9fc953e56c14c37d25 /deskutils
parent94f65ba9110a53a82c5ba281d1f218ec77252dba (diff)
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/griffith/Makefile37
-rw-r--r--deskutils/griffith/distinfo4
-rw-r--r--deskutils/griffith/pkg-plist19
3 files changed, 46 insertions, 14 deletions
diff --git a/deskutils/griffith/Makefile b/deskutils/griffith/Makefile
index 67ce39aa0c84..a9bac2e94b45 100644
--- a/deskutils/griffith/Makefile
+++ b/deskutils/griffith/Makefile
@@ -6,27 +6,28 @@
#
PORTNAME= griffith
-PORTVERSION= 0.12.1
-PORTREVISION= 2
+PORTVERSION= 0.13
CATEGORIES= deskutils
-MASTER_SITES= http://launchpadlibrarian.net/58153655/
+MASTER_SITES= http://launchpadlibrarian.net/87859599/
MAINTAINER= ports@FreeBSD.org
COMMENT= Lightweight film collection manager
-LICENSE= GPLv2 GPLv3
-LICENSE_COMB= dual
+LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlalchemy06>=0.5:${PORTSDIR}/databases/py-sqlalchemy06 \
${PYTHON_PKGNAMEPREFIX}imaging>=0:${PORTSDIR}/graphics/py-imaging \
- ${PYTHON_PKGNAMEPREFIX}reportlab>=1.19:${PORTSDIR}/print/py-reportlab \
- ${PYTHON_PKGNAMEPREFIX}chardet>=0:${PORTSDIR}/textproc/py-chardet \
${PYXML}
+OPTIONS= LXML "Enable lxml support" off \
+ REPORTLAB2 "Enable ReportLab2 support" off \
+ CHARDET "Enable chardet support" off \
+ PYGNOMEEXTRAS "Enable python-gnome-extras support" off
+
USE_XZ= yes
USE_GNOME= pygtk2
-WANT_GNOME= yes
USE_PYTHON= 2.5+
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -35,9 +36,23 @@ NO_BUILD= yes
MANLANG= "" pl pt
MAN1= ${PORTNAME}.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+.if defined(WITH_LXML)
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml
+.endif
+
+.if defined(WITH_REPORTLAB2)
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}reportlab2>=2:${PORTSDIR}/print/py-reportlab2
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}reportlab>=1.19:${PORTSDIR}/print/py-reportlab
+.endif
+
+.if defined(WITH_CHARDET)
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}chardet>=0:${PORTSDIR}/textproc/py-chardet
+.endif
-.if ${HAVE_GNOME:Mpygnomeextras}!=""
+.if defined(WITH_PYGNOMEEXTRAS)
USE_GNOME+= pygnomeextras
.endif
@@ -54,4 +69,4 @@ post-patch:
/^MANDIR/s|=.*|=${MANPREFIX}/man|g' ${WRKSRC}/${file}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/griffith/distinfo b/deskutils/griffith/distinfo
index 74fd6f6d6e10..c18a9af2abf7 100644
--- a/deskutils/griffith/distinfo
+++ b/deskutils/griffith/distinfo
@@ -1,2 +1,2 @@
-SHA256 (griffith-0.12.1.tar.xz) = b1cba8ba263cee2ab5bca2cadd485a61af93a7645f80c9d538c14795a60afa3a
-SIZE (griffith-0.12.1.tar.xz) = 734356
+SHA256 (griffith-0.13.tar.xz) = b704bf79109ffe787cf194af24152b897ef826ee54eab4b05f29a51f945af304
+SIZE (griffith-0.13.tar.xz) = 758668
diff --git a/deskutils/griffith/pkg-plist b/deskutils/griffith/pkg-plist
index df0b6b0945d2..1b4b40e19b95 100644
--- a/deskutils/griffith/pkg-plist
+++ b/deskutils/griffith/pkg-plist
@@ -25,6 +25,8 @@ share/applications/griffith.desktop
%%DATADIR%%/export_templates/latex/page.tpl
%%DATADIR%%/export_templates/xml/config.xml
%%DATADIR%%/export_templates/xml/page.tpl
+%%DATADIR%%/glade/add_poster.png
+%%DATADIR%%/glade/delete_poster.png
%%DATADIR%%/glade/exporthtml.glade
%%DATADIR%%/glade/griffith.glade
%%DATADIR%%/glade/griffith.png
@@ -44,6 +46,11 @@ share/applications/griffith.desktop
%%DATADIR%%/images/09.png
%%DATADIR%%/images/default.png
%%DATADIR%%/images/default_thumbnail.png
+%%DATADIR%%/images/ge_amazon.png
+%%DATADIR%%/images/ge_mark_seen.png
+%%DATADIR%%/images/ge_movieposterdb.png
+%%DATADIR%%/images/ge_player.png
+%%DATADIR%%/images/ge_remover.png
%%DATADIR%%/images/griffith.png
%%DATADIR%%/images/meter00.png
%%DATADIR%%/images/meter01.png
@@ -70,6 +77,7 @@ share/applications/griffith.desktop
%%DATADIR%%/lib/db/_movie.py
%%DATADIR%%/lib/db/_objects.py
%%DATADIR%%/lib/db/tables.py
+%%DATADIR%%/lib/db/validators.py
%%DATADIR%%/lib/dbupgrade.py
%%DATADIR%%/lib/delete.py
%%DATADIR%%/lib/edit.py
@@ -80,6 +88,7 @@ share/applications/griffith.desktop
%%DATADIR%%/lib/gutils.py
%%DATADIR%%/lib/initialize.py
%%DATADIR%%/lib/loan.py
+%%DATADIR%%/lib/macutils.py
%%DATADIR%%/lib/main_treeview.py
%%DATADIR%%/lib/movie.py
%%DATADIR%%/lib/people.py
@@ -101,6 +110,7 @@ share/applications/griffith.desktop
%%DATADIR%%/lib/plugins/extensions/ge_movieposterdb.py
%%DATADIR%%/lib/plugins/extensions/ge_player.py
%%DATADIR%%/lib/plugins/extensions/ge_remover.py
+%%DATADIR%%/lib/plugins/extensions/ge_sqlitemaintenance.py
%%DATADIR%%/lib/plugins/imp/AMC.py
%%DATADIR%%/lib/plugins/imp/AllMyMovies.py
%%DATADIR%%/lib/plugins/imp/BESTheMovieLibrary.py
@@ -117,7 +127,7 @@ share/applications/griffith.desktop
%%DATADIR%%/lib/plugins/imp/__init__.py
%%DATADIR%%/lib/plugins/imp/eXtremeMovieManager.py
%%DATADIR%%/lib/plugins/movie/PluginMovie7arte.py
-%%DATADIR%%/lib/plugins/movie/PluginMovieAllMovie.py
+%%DATADIR%%/lib/plugins/movie/PluginMovieAllRovi.py
%%DATADIR%%/lib/plugins/movie/PluginMovieAllocine.py
%%DATADIR%%/lib/plugins/movie/PluginMovieAmazon.py
%%DATADIR%%/lib/plugins/movie/PluginMovieAniDB.py
@@ -140,7 +150,9 @@ share/applications/griffith.desktop
%%DATADIR%%/lib/plugins/movie/PluginMovieIMDB-de.py
%%DATADIR%%/lib/plugins/movie/PluginMovieIMDB-es.py
%%DATADIR%%/lib/plugins/movie/PluginMovieIMDB-it.py
+%%DATADIR%%/lib/plugins/movie/PluginMovieIMDB-pt.py
%%DATADIR%%/lib/plugins/movie/PluginMovieIMDB.py
+%%DATADIR%%/lib/plugins/movie/PluginMovieInterfilmes.py
%%DATADIR%%/lib/plugins/movie/PluginMovieKinoDe.py
%%DATADIR%%/lib/plugins/movie/PluginMovieMediadis.py
%%DATADIR%%/lib/plugins/movie/PluginMovieMovieMeter.py
@@ -162,6 +174,7 @@ share/applications/griffith.desktop
%%DATADIR%%/lib/version.py
%%DATADIR%%/lib/view.py
%%DATADIR%%/lib/widgets.py
+share/locale/ar/LC_MESSAGES/griffith.mo
share/locale/bg/LC_MESSAGES/griffith.mo
share/locale/ca/LC_MESSAGES/griffith.mo
share/locale/cs/LC_MESSAGES/griffith.mo
@@ -171,9 +184,11 @@ share/locale/el/LC_MESSAGES/griffith.mo
share/locale/en_GB/LC_MESSAGES/griffith.mo
share/locale/es/LC_MESSAGES/griffith.mo
share/locale/et/LC_MESSAGES/griffith.mo
+share/locale/eu/LC_MESSAGES/griffith.mo
share/locale/fa/LC_MESSAGES/griffith.mo
share/locale/fi/LC_MESSAGES/griffith.mo
share/locale/fr/LC_MESSAGES/griffith.mo
+share/locale/gl/LC_MESSAGES/griffith.mo
share/locale/hr/LC_MESSAGES/griffith.mo
share/locale/hu/LC_MESSAGES/griffith.mo
share/locale/id/LC_MESSAGES/griffith.mo
@@ -189,10 +204,12 @@ share/locale/pl/LC_MESSAGES/griffith.mo
share/locale/ps/LC_MESSAGES/griffith.mo
share/locale/pt/LC_MESSAGES/griffith.mo
share/locale/pt_BR/LC_MESSAGES/griffith.mo
+share/locale/ro/LC_MESSAGES/griffith.mo
share/locale/ru/LC_MESSAGES/griffith.mo
share/locale/sk/LC_MESSAGES/griffith.mo
share/locale/sr/LC_MESSAGES/griffith.mo
share/locale/sv/LC_MESSAGES/griffith.mo
+share/locale/th/LC_MESSAGES/griffith.mo
share/locale/tr/LC_MESSAGES/griffith.mo
share/locale/uk/LC_MESSAGES/griffith.mo
share/locale/zh_CN/LC_MESSAGES/griffith.mo