aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-12 22:15:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-12 22:15:00 +0000
commit1cf0994802b522c40accfa1a120a4634f4abb69b (patch)
tree5ff0178e115ab6a05e7d710ce1bfc67f9c1da47d /deskutils
parent9e7c3716fede1494fc33f70e53dfad54d7e7323f (diff)
downloadports-1cf0994802b522c40accfa1a120a4634f4abb69b.tar.gz
ports-1cf0994802b522c40accfa1a120a4634f4abb69b.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/plasma-applet-daisy/Makefile26
-rw-r--r--deskutils/plasma-applet-daisy/distinfo3
-rw-r--r--deskutils/plasma-applet-daisy/pkg-descr11
-rw-r--r--deskutils/plasma-applet-daisy/pkg-plist19
5 files changed, 60 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 2155acedaeda..8fd29624fb56 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -202,6 +202,7 @@
SUBDIR += planner
SUBDIR += planner.el
SUBDIR += plans
+ SUBDIR += plasma-applet-daisy
SUBDIR += plasma-applet-panelspacer
SUBDIR += plasma-applet-playwolf
SUBDIR += plasma-applet-simpleweatherforecast
diff --git a/deskutils/plasma-applet-daisy/Makefile b/deskutils/plasma-applet-daisy/Makefile
new file mode 100644
index 000000000000..a3ab1bd185ec
--- /dev/null
+++ b/deskutils/plasma-applet-daisy/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: plasma-applet-daisy
+# Date Created: 2009-07-08
+# Whom: Jason E. Hale <bsdkaffee@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= daisy
+PORTVERSION= 0.0.4.19
+CATEGORIES= deskutils kde
+MASTER_SITES= http://daisyplasma.freehostia.com/downloads/
+PKGNAMEPREFIX= plasma-applet-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bsdkaffee@gmail.com
+COMMENT= Simple launcher plasma applet for KDE4
+
+USE_CMAKE= yes
+USE_KDE4= automoc4 kdeprefix kdelibs workspace
+USE_QT_VER= 4
+QT_COMPONENTS= gui dbus network opengl svg webkit xml \
+ qmake_build moc_build rcc_build uic_build
+USE_GETTEXT= yes
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.mk>
diff --git a/deskutils/plasma-applet-daisy/distinfo b/deskutils/plasma-applet-daisy/distinfo
new file mode 100644
index 000000000000..9c5082b63723
--- /dev/null
+++ b/deskutils/plasma-applet-daisy/distinfo
@@ -0,0 +1,3 @@
+MD5 (plasma-applet-daisy-0.0.4.19.tar.gz) = 74c4f6f207e361543f6b532d3e1091c6
+SHA256 (plasma-applet-daisy-0.0.4.19.tar.gz) = 9f81aafc94a0047ebe5fe326fe8752e2c259671cf08ef1a5c22d19b3af05efe3
+SIZE (plasma-applet-daisy-0.0.4.19.tar.gz) = 315789
diff --git a/deskutils/plasma-applet-daisy/pkg-descr b/deskutils/plasma-applet-daisy/pkg-descr
new file mode 100644
index 000000000000..befee9685b05
--- /dev/null
+++ b/deskutils/plasma-applet-daisy/pkg-descr
@@ -0,0 +1,11 @@
+Daisy is a simple launcher plasma applet for KDE4. Features include:
+ - Three types of roles: circular dock, media controller and linear dock
+ - Can dock in any screen position and be used in Horizontal or Vertical mode
+ - Configuration tools to access all configurable options
+ - Launchers can be edited with a simple right-click
+ - Hybrid launchers to launch applications and control running tasks
+ - Plugins to provide information and execute several tasks
+ - Various backgrounds available
+
+WWW: http://daisyplasma.freehostia.com/
+WWW: http://www.kde-look.org/content/show.php?content=102077
diff --git a/deskutils/plasma-applet-daisy/pkg-plist b/deskutils/plasma-applet-daisy/pkg-plist
new file mode 100644
index 000000000000..1e0267424477
--- /dev/null
+++ b/deskutils/plasma-applet-daisy/pkg-plist
@@ -0,0 +1,19 @@
+lib/kde4/plasma_applet_daisy.so
+share/apps/desktoptheme/default/widgets/circular-background.svgz
+share/apps/desktoptheme/default/widgets/dock-animations.svgz
+share/apps/desktoptheme/default/widgets/dock-background-blueish.svgz
+share/apps/desktoptheme/default/widgets/dock-background-cavalino-red.svgz
+share/apps/desktoptheme/default/widgets/dock-background-kiwi.svgz
+share/apps/desktoptheme/default/widgets/dock-background-mach.svgz
+share/apps/desktoptheme/default/widgets/dock-background-reddish.svgz
+share/apps/desktoptheme/default/widgets/dock-background-rubber-black.svgz
+share/apps/desktoptheme/default/widgets/dock-background-shiny-black.svgz
+share/apps/desktoptheme/default/widgets/dock-background-vidro.svgz
+share/apps/desktoptheme/default/widgets/dock-background.svgz
+share/apps/desktoptheme/default/widgets/tasks-indicators.svgz
+share/kde4/services/plasma-applet-daisy.desktop
+share/locale/fr/LC_MESSAGES/plasma_applet_daisy.mo
+share/locale/hu/LC_MESSAGES/plasma_applet_daisy.mo
+share/locale/it/LC_MESSAGES/plasma_applet_daisy.mo
+share/locale/pl/LC_MESSAGES/plasma_applet_daisy.mo
+share/locale/pt/LC_MESSAGES/plasma_applet_daisy.mo