aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-02-08 07:14:44 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-02-08 07:14:44 +0000
commit3138a6aef745b6fbe33f4aa45803e68d80c583c1 (patch)
tree476f38e6e45f5157af8db4bc6e36d4699e95c7b8 /deskutils
parent9a0799b2c45716d614ed19e6b1906943ecadd73f (diff)
downloadports-3138a6aef745b6fbe33f4aa45803e68d80c583c1.tar.gz
ports-3138a6aef745b6fbe33f4aa45803e68d80c583c1.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/preferences.app/Makefile58
-rw-r--r--deskutils/preferences.app/distinfo1
-rw-r--r--deskutils/preferences.app/pkg-comment1
-rw-r--r--deskutils/preferences.app/pkg-descr10
-rw-r--r--deskutils/preferences.app/pkg-plist64
6 files changed, 135 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index db1fd30b0341..38d42932bfb5 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -42,6 +42,7 @@
SUBDIR += offix-trash
SUBDIR += phpgroupware
SUBDIR += plan
+ SUBDIR += preferences.app
SUBDIR += rox-memo
SUBDIR += sliderule
SUBDIR += teapot
diff --git a/deskutils/preferences.app/Makefile b/deskutils/preferences.app/Makefile
new file mode 100644
index 000000000000..707470bd4e36
--- /dev/null
+++ b/deskutils/preferences.app/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: preferences.app
+# Date created: 04 Feb 2003
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= preferences.app
+PORTVERSION= 1.2.0
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= prefsapp
+DISTNAME= Preferences-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+
+BUILD_DEPENDS= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libcallback.a:${PORTSDIR}/devel/ffcall
+RUN_DEPENDS= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
+
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+PREFIX= ${LOCALBASE}/GNUstep
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+ALL_TARGET=
+NO_MTREE= yes
+MODIFY= GNUmakefile.preamble PrefsModule/GNUmakefile.preamble \
+ Modules/Keyboard/GNUmakefile.preamble \
+ Modules/PrefsApp/GNUmakefile.preamble
+
+BACKBUNDLEDIR= ${PREFIX}/System/Library/Bundles/libgnustep-back.bundle/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu
+
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "i386"
+GNU_ARCH= ix86
+.else
+GNU_ARCH= ${MACHINE_ARCH}
+.endif
+
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L}
+
+post-patch:
+.for i in ${MODIFY}
+ @${MV} ${WRKSRC}/${i} ${WRKSRC}/${i}.sed
+ ${SED} -e "s= -Werror==" ${WRKSRC}/${i}.sed > ${WRKSRC}/${i}
+.endfor
+
+do-build:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
+
+do-install:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/preferences.app/distinfo b/deskutils/preferences.app/distinfo
new file mode 100644
index 000000000000..30164bc5c6c8
--- /dev/null
+++ b/deskutils/preferences.app/distinfo
@@ -0,0 +1 @@
+MD5 (Preferences-1.2.0.tar.bz2) = 1f08ecab990fd91a14fc40d369e5ed9a
diff --git a/deskutils/preferences.app/pkg-comment b/deskutils/preferences.app/pkg-comment
new file mode 100644
index 000000000000..d7ac4040cf37
--- /dev/null
+++ b/deskutils/preferences.app/pkg-comment
@@ -0,0 +1 @@
+GNUstep workspace manager
diff --git a/deskutils/preferences.app/pkg-descr b/deskutils/preferences.app/pkg-descr
new file mode 100644
index 000000000000..60356e999f12
--- /dev/null
+++ b/deskutils/preferences.app/pkg-descr
@@ -0,0 +1,10 @@
+Preferences.app is, functionally, a clone of NeXTstep/OPENSTEP tool of
+the same name. Just like the original program, it's a simple application
+for setting preferences for the GNUstep system, with a friendly interface.
+The program is simple, but powerful -- people can create new modules,
+called "bundles", that add new things to the program that its original
+developers did not think of or even intend -- that don't require
+recompiling the main program. For more information on what bundles can do,
+see StepWise. They are a very powerful tool.
+
+WWW: http://prefsapp.sourceforge.net/about.php
diff --git a/deskutils/preferences.app/pkg-plist b/deskutils/preferences.app/pkg-plist
new file mode 100644
index 000000000000..b9856345c879
--- /dev/null
+++ b/deskutils/preferences.app/pkg-plist
@@ -0,0 +1,64 @@
+System/Applications/Preferences.app/Preferences
+System/Applications/Preferences.app/Resources/Info-gnustep.plist
+System/Applications/Preferences.app/Resources/Preferences.desktop
+System/Applications/Preferences.app/Resources/Preferences.tiff
+System/Applications/Preferences.app/Resources/PreferencesInfo.plist
+System/Applications/Preferences.app/Resources/PrefsIcon_Appearances.tiff
+System/Applications/Preferences.app/Resources/PrefsIcon_Keyboard.tiff
+System/Applications/Preferences.app/Resources/PrefsIcon_Localisation.tiff
+System/Applications/Preferences.app/Resources/PrefsIcon_Login.tiff
+System/Applications/Preferences.app/Resources/PrefsIcon_Mouse.tiff
+System/Applications/Preferences.app/Resources/PrefsIcon_Screen.tiff
+System/Applications/Preferences.app/Resources/PrefsIcon_SelectSpooler.tiff
+System/Applications/Preferences.app/Resources/PrefsModule.tiff
+System/Applications/Preferences.app/Resources/English.lproj/Localizable.strings
+System/Applications/Preferences.app/Resources/English.lproj/Preferences.gorm
+System/Applications/Preferences.app/Resources/PrefsApp.prefs/Resources/Info-gnustep.plist
+System/Applications/Preferences.app/Resources/PrefsApp.prefs/Resources/PrefsApp.gorm
+System/Applications/Preferences.app/Resources/PrefsApp.prefs/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/PrefsApp
+System/Applications/Preferences.app/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/Preferences
+System/Applications/Preferences.app/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/library_paths.openapp
+System/Libraries/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/libPrefsModule.so
+System/Libraries/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/libPrefsModule.so.1
+System/Libraries/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/libPrefsModule.so.1.0.0
+System/Library/Frameworks/PrefsModule.framework/Resources
+System/Library/Frameworks/PrefsModule.framework/Versions/A/Headers/PrefsModule.h
+System/Library/Frameworks/PrefsModule.framework/Versions/A/Resources/Info-gnustep.plist
+System/Library/Frameworks/PrefsModule.framework/Versions/A/Resources/Info.plist
+System/Library/Frameworks/PrefsModule.framework/Versions/A/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/libPrefsModule.so
+System/Library/Frameworks/PrefsModule.framework/Versions/A/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/libPrefsModule.so.1
+System/Library/Frameworks/PrefsModule.framework/Versions/A/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/libPrefsModule.so.1.0.0
+@exec ln -fs Versions/Current/Headers %D/System/Library/Frameworks/PrefsModule.framework/Headers
+@exec ln -fs Versions/Current/Resources %D/System/Library/Frameworks/PrefsModule.framework/Resources
+@exec ln -fs A %D/System/Library/Frameworks/PrefsModule.framework/Versions/Current
+@unexec rm -f %D/System/Library/Frameworks/PrefsModule.framework/Headers
+@unexec rm -f %D/System/Library/Frameworks/PrefsModule.framework/Resources
+@unexec rm -f %D/System/Library/Frameworks/PrefsModule.framework/Versions/Current
+System/Library/Preferences/Keyboard.prefs/Resources/Info-gnustep.plist
+System/Library/Preferences/Keyboard.prefs/Resources/Keyboard.gorm
+System/Library/Preferences/Keyboard.prefs/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/Keyboard
+@dirrm System/Applications/Preferences.app/Resources/English.lproj
+@dirrm System/Applications/Preferences.app/Resources/PrefsApp.prefs/Resources
+@dirrm System/Applications/Preferences.app/Resources/PrefsApp.prefs/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu
+@dirrm System/Applications/Preferences.app/Resources/PrefsApp.prefs/%%GNU_ARCH%%/%%OPSYS%%
+@dirrm System/Applications/Preferences.app/Resources/PrefsApp.prefs/%%GNU_ARCH%%
+@dirrm System/Applications/Preferences.app/Resources/PrefsApp.prefs
+@dirrm System/Applications/Preferences.app/Resources
+@dirrm System/Applications/Preferences.app/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu
+@dirrm System/Applications/Preferences.app/%%GNU_ARCH%%/%%OPSYS%%
+@dirrm System/Applications/Preferences.app/%%GNU_ARCH%%
+@dirrm System/Applications/Preferences.app
+@dirrm System/Library/Frameworks/PrefsModule.framework/Versions/A/Headers
+@dirrm System/Library/Frameworks/PrefsModule.framework/Versions/A/Resources
+@dirrm System/Library/Frameworks/PrefsModule.framework/Versions/A/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu
+@dirrm System/Library/Frameworks/PrefsModule.framework/Versions/A/%%GNU_ARCH%%/%%OPSYS%%
+@dirrm System/Library/Frameworks/PrefsModule.framework/Versions/A/%%GNU_ARCH%%
+@dirrm System/Library/Frameworks/PrefsModule.framework/Versions/A
+@dirrm System/Library/Frameworks/PrefsModule.framework/Versions
+@dirrm System/Library/Frameworks/PrefsModule.framework
+@dirrm System/Library/Preferences/Keyboard.prefs/Resources
+@dirrm System/Library/Preferences/Keyboard.prefs/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu
+@dirrm System/Library/Preferences/Keyboard.prefs/%%GNU_ARCH%%/%%OPSYS%%
+@dirrm System/Library/Preferences/Keyboard.prefs/%%GNU_ARCH%%
+@dirrm System/Library/Preferences/Keyboard.prefs
+@dirrm System/Library/Preferences