aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2011-07-09 13:39:36 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2011-07-09 13:39:36 +0000
commit071cce5d00eb646a6fa1ddd887493b32f1458200 (patch)
tree7ac56b0dea7c3e79391149bca479ae20aba2aca7 /deskutils
parent21ec7cfc46ed58cd66d90c55be070dffeb8817df (diff)
downloadports-071cce5d00eb646a6fa1ddd887493b32f1458200.tar.gz
ports-071cce5d00eb646a6fa1ddd887493b32f1458200.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/virt-manager/Makefile35
-rw-r--r--deskutils/virt-manager/distinfo2
-rw-r--r--deskutils/virt-manager/pkg-descr9
-rw-r--r--deskutils/virt-manager/pkg-plist108
5 files changed, 155 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 7d468ae0b010..a9f62143a69a 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -287,6 +287,7 @@
SUBDIR += treeline
SUBDIR += tuxcards
SUBDIR += vboxgtk
+ SUBDIR += virt-manager
SUBDIR += vnc2flv
SUBDIR += vym
SUBDIR += wammu
diff --git a/deskutils/virt-manager/Makefile b/deskutils/virt-manager/Makefile
new file mode 100644
index 000000000000..9b82260c3c4b
--- /dev/null
+++ b/deskutils/virt-manager/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: virt-manager
+# Date created: 2011-05-28
+# Whom: Jason Helfman <jhelfman@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= virt-manager
+PORTVERSION= 0.8.7
+CATEGORIES= deskutils net-mgmt
+MASTER_SITES= http://virt-manager.et.redhat.com/download/sources/${PORTNAME}/
+
+MAINTAINER= jhelfman@experts-exchange.com
+COMMENT= Toolkit to interact with virtualization capabilities
+
+LICENSE= LGPL3
+
+LIB_DEPENDS= virt.9:${PORTSDIR}/devel/libvirt
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83.2:${PORTSDIR}/devel/py-dbus \
+ ${PYTHON_PKGNAMEPREFIX}libxml2>=2.7.8:${PORTSDIR}/textproc/py-libxml2 \
+ ${PYTHON_PKGNAMEPREFIX}virtinst>=0.500.6:${PORTSDIR}/net-mgmt/virtinst \
+ ${PYTHON_PKGNAMEPREFIX}vte>=0.26.2:${PORTSDIR}/x11-toolkits/py-vte \
+ gtk-vnc>=0.3.10:${PORTSDIR}/net/gtk-vnc \
+ librsvg2>=2.32.1:${PORTSDIR}/graphics/librsvg2
+
+USE_GNOME= pygtk2 pygnome2 libgnome gnomelibs
+GCONF_SCHEMAS= virt-manager.schemas
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --without-tui
+USE_GMAKE= yes
+USE_PYTHON= yes
+
+MAN1= virt-manager.1
+
+.include <bsd.port.mk>
diff --git a/deskutils/virt-manager/distinfo b/deskutils/virt-manager/distinfo
new file mode 100644
index 000000000000..407d5e76054a
--- /dev/null
+++ b/deskutils/virt-manager/distinfo
@@ -0,0 +1,2 @@
+SHA256 (virt-manager-0.8.7.tar.gz) = 1907ec0e5479d6af8b4882fc068b74fa8c04f8d36ab0a503b405a937fe765dd5
+SIZE (virt-manager-0.8.7.tar.gz) = 1879504
diff --git a/deskutils/virt-manager/pkg-descr b/deskutils/virt-manager/pkg-descr
new file mode 100644
index 000000000000..14c6adb17faf
--- /dev/null
+++ b/deskutils/virt-manager/pkg-descr
@@ -0,0 +1,9 @@
+The "Virtual Machine Manager" application (virt-manager for short package name)
+is a desktop user interface for managing virtual machines. It presents a summary
+view of running domains, their live performance & resource utilization
+statistics. The detailed view graphs performance & utilization over time.
+Wizards enable the creation of new domains, and configuration & adjustment of a
+domain's resource allocation & virtual hardware. An embedded VNC client viewer
+presents a full graphical console to the guest domain.
+
+WWW: http://virt-manager.org
diff --git a/deskutils/virt-manager/pkg-plist b/deskutils/virt-manager/pkg-plist
new file mode 100644
index 000000000000..96259d6acfb3
--- /dev/null
+++ b/deskutils/virt-manager/pkg-plist
@@ -0,0 +1,108 @@
+bin/virt-manager
+libexec/virt-manager-launch
+share/applications/virt-manager.desktop
+share/dbus-1/services/virt-manager.service
+%%DATADIR%%/pixmaps/device_cpu.png
+%%DATADIR%%/pixmaps/device_mem.png
+%%DATADIR%%/pixmaps/device_pci.png
+%%DATADIR%%/pixmaps/device_serial.png
+%%DATADIR%%/pixmaps/device_usb.png
+%%DATADIR%%/pixmaps/hicolor/16x16/actions/icon_console.png
+%%DATADIR%%/pixmaps/hicolor/16x16/actions/vm_new.png
+%%DATADIR%%/pixmaps/hicolor/22x22/actions/icon_console.png
+%%DATADIR%%/pixmaps/hicolor/22x22/actions/vm_new.png
+%%DATADIR%%/pixmaps/hicolor/24x24/actions/icon_console.png
+%%DATADIR%%/pixmaps/hicolor/24x24/actions/vm_new.png
+%%DATADIR%%/pixmaps/hicolor/32x32/actions/icon_console.png
+%%DATADIR%%/pixmaps/hicolor/32x32/actions/vm_new.png
+%%DATADIR%%/pixmaps/icon_details.png
+%%DATADIR%%/pixmaps/state_crashed.png
+%%DATADIR%%/pixmaps/state_paused.png
+%%DATADIR%%/pixmaps/state_progress.png
+%%DATADIR%%/pixmaps/state_running.png
+%%DATADIR%%/pixmaps/state_shutoff.png
+%%DATADIR%%/pixmaps/state_unknown.png
+%%DATADIR%%/pixmaps/virt-manager-icon.svg
+%%DATADIR%%/pixmaps/vm_clone_wizard.png
+%%DATADIR%%/pixmaps/vm_delete_wizard.png
+%%DATADIR%%/pixmaps/vm_import_wizard.png
+%%DATADIR%%/pixmaps/vm_large.png
+%%DATADIR%%/pixmaps/vm_medium.png
+%%DATADIR%%/pixmaps/vm_new_wizard.png
+%%DATADIR%%/pixmaps/vm_small.png
+%%DATADIR%%/pixmaps/vm_tiny.png
+%%DATADIR%%/virt-manager.py
+%%DATADIR%%/virtManager/IPy.py
+%%DATADIR%%/virtManager/__init__.py
+%%DATADIR%%/virtManager/about.py
+%%DATADIR%%/virtManager/addhardware.py
+%%DATADIR%%/virtManager/asyncjob.py
+%%DATADIR%%/virtManager/baseclass.py
+%%DATADIR%%/virtManager/choosecd.py
+%%DATADIR%%/virtManager/clone.py
+%%DATADIR%%/virtManager/config.py
+%%DATADIR%%/virtManager/connect.py
+%%DATADIR%%/virtManager/connection.py
+%%DATADIR%%/virtManager/console.py
+%%DATADIR%%/virtManager/create.py
+%%DATADIR%%/virtManager/createinterface.py
+%%DATADIR%%/virtManager/createmeter.py
+%%DATADIR%%/virtManager/createnet.py
+%%DATADIR%%/virtManager/createpool.py
+%%DATADIR%%/virtManager/createvol.py
+%%DATADIR%%/virtManager/delete.py
+%%DATADIR%%/virtManager/details.py
+%%DATADIR%%/virtManager/domain.py
+%%DATADIR%%/virtManager/engine.py
+%%DATADIR%%/virtManager/error.py
+%%DATADIR%%/virtManager/graphwidgets.py
+%%DATADIR%%/virtManager/halhelper.py
+%%DATADIR%%/virtManager/host.py
+%%DATADIR%%/virtManager/interface.py
+%%DATADIR%%/virtManager/keyring.py
+%%DATADIR%%/virtManager/libvirtobject.py
+%%DATADIR%%/virtManager/manager.py
+%%DATADIR%%/virtManager/mediadev.py
+%%DATADIR%%/virtManager/migrate.py
+%%DATADIR%%/virtManager/netdev.py
+%%DATADIR%%/virtManager/network.py
+%%DATADIR%%/virtManager/preferences.py
+%%DATADIR%%/virtManager/remote.py
+%%DATADIR%%/virtManager/secret.py
+%%DATADIR%%/virtManager/serialcon.py
+%%DATADIR%%/virtManager/storagebrowse.py
+%%DATADIR%%/virtManager/storagepool.py
+%%DATADIR%%/virtManager/storagevol.py
+%%DATADIR%%/virtManager/systray.py
+%%DATADIR%%/virtManager/uihelpers.py
+%%DATADIR%%/virtManager/util.py
+%%DATADIR%%/vmm-about.glade
+%%DATADIR%%/vmm-add-hardware.glade
+%%DATADIR%%/vmm-choose-cd.glade
+%%DATADIR%%/vmm-clone.glade
+%%DATADIR%%/vmm-create-interface.glade
+%%DATADIR%%/vmm-create-net.glade
+%%DATADIR%%/vmm-create-pool.glade
+%%DATADIR%%/vmm-create-vol.glade
+%%DATADIR%%/vmm-create.glade
+%%DATADIR%%/vmm-delete.glade
+%%DATADIR%%/vmm-details.glade
+%%DATADIR%%/vmm-host.glade
+%%DATADIR%%/vmm-manager.glade
+%%DATADIR%%/vmm-migrate.glade
+%%DATADIR%%/vmm-open-connection.glade
+%%DATADIR%%/vmm-preferences.glade
+%%DATADIR%%/vmm-progress.glade
+%%DATADIR%%/vmm-storage-browse.glade
+@dirrm %%DATADIR%%/virtManager
+@dirrm %%DATADIR%%/pixmaps/hicolor/16x16/actions
+@dirrm %%DATADIR%%/pixmaps/hicolor/16x16
+@dirrm %%DATADIR%%/pixmaps/hicolor/22x22/actions
+@dirrm %%DATADIR%%/pixmaps/hicolor/22x22
+@dirrm %%DATADIR%%/pixmaps/hicolor/24x24/actions
+@dirrm %%DATADIR%%/pixmaps/hicolor/24x24
+@dirrm %%DATADIR%%/pixmaps/hicolor/32x32/actions
+@dirrm %%DATADIR%%/pixmaps/hicolor/32x32
+@dirrm %%DATADIR%%/pixmaps/hicolor
+@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%