aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-09 13:16:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-09 13:16:49 +0000
commit9d79e7b1469f6887d302e13ce7c67c54408a2453 (patch)
tree263754af5ddd95f1ad55b06c101378a0cf71009b /deskutils
parenta0e384abe8236d5d12c69354d90c0de5342f7efb (diff)
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/gnote/Makefile6
-rw-r--r--deskutils/gnote/files/extra-src_base_macros.hpp46
-rw-r--r--deskutils/owncloudclient/Makefile2
3 files changed, 1 insertions, 53 deletions
diff --git a/deskutils/gnote/Makefile b/deskutils/gnote/Makefile
index a5287512d8ab..bc057551ae55 100644
--- a/deskutils/gnote/Makefile
+++ b/deskutils/gnote/Makefile
@@ -39,12 +39,6 @@ DOCS= AUTHORS ChangeLog NEWS README TODO
PLIST_SUB+= VERSION=${PORTVERSION}
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-EXTRA_PATCHES= ${FILESDIR}/extra-src_base_macros.hpp
-.endif
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${DOCS}
diff --git a/deskutils/gnote/files/extra-src_base_macros.hpp b/deskutils/gnote/files/extra-src_base_macros.hpp
deleted file mode 100644
index a04e604f38ab..000000000000
--- a/deskutils/gnote/files/extra-src_base_macros.hpp
+++ /dev/null
@@ -1,46 +0,0 @@
-Working around c++11 issues with the port compiler used on 9.3.
-
---- src/base/macros.hpp.orig 2016-01-06 21:33:38.207318000 +0100
-+++ src/base/macros.hpp 2016-01-06 21:45:25.932524000 +0100
-@@ -29,14 +29,16 @@
- #ifndef __BASE_MACROS_
- #define __BASE_MACROS_
-
--#if __cplusplus < 201103L
-+//#if __cplusplus < 201103L
- #include <tr1/memory>
- #include <boost/foreach.hpp>
- #include <boost/lexical_cast.hpp>
-+/*
- #else
- #include <memory>
- #include <string>
- #endif
-+*/
-
- #if __GNUC__
- #define _PRINTF_FORMAT(f,a) \
-@@ -46,7 +48,7 @@
- #endif
-
- // define 'final' and 'override' for pre-C++11 compilers
--#if __cplusplus < 201103L
-+//#if __cplusplus < 201103L
- #define final
- #define override
- #define FOREACH(var, container) BOOST_FOREACH(var, container)
-@@ -58,6 +60,7 @@
- using std::tr1::enable_shared_from_this;
- using std::tr1::dynamic_pointer_cast;
- using std::tr1::static_pointer_cast;
-+/*
- #else
- #define FOREACH(var, container) for(var : container)
- #define TO_STRING(x) std::to_string(x)
-@@ -69,5 +72,6 @@
- using std::dynamic_pointer_cast;
- using std::static_pointer_cast;
- #endif
-+*/
-
- #endif
diff --git a/deskutils/owncloudclient/Makefile b/deskutils/owncloudclient/Makefile
index ae45b4a8d838..3af8e9e85529 100644
--- a/deskutils/owncloudclient/Makefile
+++ b/deskutils/owncloudclient/Makefile
@@ -40,7 +40,7 @@ PLIST_SUB= VERSION=${PORTVERSION}
.include <bsd.port.options.mk>
-.if ${OPSYS} != FreeBSD || ${OSVERSION} < 1000015
+.if ${OPSYS} != FreeBSD
WITH_OPENSSL_PORT= yes
# CMake 3.3.x will use $PATH when looking for headers and libraries by default,