aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-07-12 15:19:15 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-07-12 15:19:15 +0000
commit5c5a6948c5e373f52c15e3918ca16bd7f08d2cba (patch)
tree481558938b4106eed23f3253151b38110da16311 /deskutils
parent5487c0e8cb1de62bd1ff7f7c13034497b9a0c6e7 (diff)
downloadports-5c5a6948c5e373f52c15e3918ca16bd7f08d2cba.tar.gz
ports-5c5a6948c5e373f52c15e3918ca16bd7f08d2cba.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/calibre/Makefile2
-rw-r--r--deskutils/calibre/distinfo4
-rw-r--r--deskutils/calibre/files/calibre.in8
-rw-r--r--deskutils/calibre/pkg-plist9
4 files changed, 15 insertions, 8 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index fd9a8ce2effd..71ff797fe1bb 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= calibre
-PORTVERSION= 1.43.0
+PORTVERSION= 1.44.0
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
diff --git a/deskutils/calibre/distinfo b/deskutils/calibre/distinfo
index 15bd61fbadbc..e6b917514b36 100644
--- a/deskutils/calibre/distinfo
+++ b/deskutils/calibre/distinfo
@@ -1,2 +1,2 @@
-SHA256 (calibre-1.43.0.tar.xz) = 3c4ef17591e033e39ba804d18442f63c3ebc1683da776833d47d8aa2900f724d
-SIZE (calibre-1.43.0.tar.xz) = 35549180
+SHA256 (calibre-1.44.0.tar.xz) = b2a49485ece16454169dfdd9da7481fabf0ae644b8e53f3fd114de4ceecf6992
+SIZE (calibre-1.44.0.tar.xz) = 36438768
diff --git a/deskutils/calibre/files/calibre.in b/deskutils/calibre/files/calibre.in
index 0081429b1d80..0a0b63a550d9 100644
--- a/deskutils/calibre/files/calibre.in
+++ b/deskutils/calibre/files/calibre.in
@@ -14,6 +14,8 @@
# Default is 8080
# calibre_user (string): user that calibre_server runs as
# Default is calibre
+# calibre_home (string): home directory for calibre_server
+# Default is the home directory of calibre_user
# calibre_username (string): username for calibre authentication
# Default is calibre
# calibre_password (string): If set then access is restricted
@@ -38,7 +40,7 @@ load_rc_config $name
pidfile=/var/run/${name}/${name}.pid
command=/usr/local/bin/calibre-server
-command_interpreter=python2.7
+command_interpreter=python2
required_dirs=${calibre_library}
start_cmd=${name}_start
@@ -57,9 +59,11 @@ calibre_start()
command_args="${command_args} --password=${calibre_password}"
fi
if [ ! -z "${calibre_url_prefix}" ]; then
- command_args="${command_args} --url_prefx=${calibre_url_prefix}"
+ command_args="${command_args} --url-prefx=${calibre_url_prefix}"
fi
+ calibre_home=${calibre_home:-$(getent passwd ${calibre_user} | awk -F: '{print $6}')}
+ HOME=${calibre_home:-/nonexistent}
/usr/sbin/daemon -f -u ${calibre_user} -p ${pidfile} ${command} ${command_args} --with-library ${calibre_library}
}
diff --git a/deskutils/calibre/pkg-plist b/deskutils/calibre/pkg-plist
index 7e1aa65b2deb..1fae1942afc3 100644
--- a/deskutils/calibre/pkg-plist
+++ b/deskutils/calibre/pkg-plist
@@ -1026,6 +1026,7 @@ lib/calibre/calibre/gui2/tweak_book/job.py
lib/calibre/calibre/gui2/tweak_book/live_css.py
lib/calibre/calibre/gui2/tweak_book/main.py
lib/calibre/calibre/gui2/tweak_book/manage_fonts.py
+lib/calibre/calibre/gui2/tweak_book/plugin.py
lib/calibre/calibre/gui2/tweak_book/polish.py
lib/calibre/calibre/gui2/tweak_book/preferences.py
lib/calibre/calibre/gui2/tweak_book/preview.py
@@ -1767,7 +1768,9 @@ share/applications/calibre-lrfviewer.desktop
%%DATADIR%%/localization/stats.pickle
%%DATADIR%%/metadata_sqlite.sql
%%DATADIR%%/mime.types
-%%DATADIR%%/quick_start.epub
+%%DATADIR%%/quick_start/deu.epub
+%%DATADIR%%/quick_start/eng.epub
+%%DATADIR%%/quick_start/fra.epub
%%DATADIR%%/scripts.pickle
%%DATADIR%%/template-functions.json
%%DATADIR%%/templates/book_details.css
@@ -1978,7 +1981,7 @@ share/applications/calibre-lrfviewer.desktop
%%DATADIR%%/viewer/mathjax/jax/output/SVG/fonts/TeX/fontdata.js
%%DATADIR%%/viewer/mathjax/jax/output/SVG/jax.js
%%DATADIR%%/viewer/referencing.js
-share/bash-completion/calibre
+share/bash-completion/completions/calibre
share/gnome/apps/calibre-ebook-edit.desktop
share/gnome/apps/calibre-ebook-viewer.desktop
share/gnome/apps/calibre-gui.desktop
@@ -2007,7 +2010,6 @@ share/mime/application/x-sony-bbeb.xml
share/mime/application/x-topaz-ebook.xml
share/mime/packages/calibre-mimetypes.xml
share/mime/text/lrs.xml
-share/zsh/site-functions/_calibre
@dirrmtry share/mime/text
@dirrmtry share/mime/packages
@dirrmtry share/mime/application
@@ -2075,6 +2077,7 @@ share/zsh/site-functions/_calibre
@dirrm %%DATADIR%%/viewer/hyphenate
@dirrm %%DATADIR%%/viewer
@dirrm %%DATADIR%%/templates
+@dirrm %%DATADIR%%/quick_start
@dirrm %%DATADIR%%/localization/pykakasi
@dirrm %%DATADIR%%/localization
@dirrm %%DATADIR%%/jacket