aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2018-06-30 18:47:32 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2018-06-30 18:47:32 +0000
commit692d77904d9ad8739d5b720a6c7875310f4ac295 (patch)
tree2bd4a347f077e6bcb86fb4995eb23868950f69dd /deskutils
parent410f2061c6d83d91e5ad738f731a3a293c706c3f (diff)
downloadports-692d77904d9ad8739d5b720a6c7875310f4ac295.tar.gz
ports-692d77904d9ad8739d5b720a6c7875310f4ac295.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/gnome-screenshot/Makefile26
-rw-r--r--deskutils/gnome-screenshot/distinfo5
-rw-r--r--deskutils/gnome-screenshot/files/extra-patch-intel20
-rw-r--r--deskutils/gnome-screenshot/pkg-descr5
-rw-r--r--deskutils/gnome-screenshot/pkg-plist192
5 files changed, 143 insertions, 105 deletions
diff --git a/deskutils/gnome-screenshot/Makefile b/deskutils/gnome-screenshot/Makefile
index 4fe0ded0455a..dfcca6ef2d5a 100644
--- a/deskutils/gnome-screenshot/Makefile
+++ b/deskutils/gnome-screenshot/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gnome-screenshot
-PORTVERSION= 3.18.0
+PORTVERSION= 3.22.0
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -10,17 +10,31 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 3 utility for making picutures of your screen
-LIB_DEPENDS= libcanberra-gtk3.so:audio/libcanberra-gtk3
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libcanberra-gtk3.so:audio/libcanberra-gtk3 \
+ libcanberra.so:audio/libcanberra
CONFLICTS= gnome-utils-2.[0-9]*
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome pathfix pkgconfig tar:xz
-USE_GNOME= gtk30 intlhack
+USES= gettext-tools gmake gnome localbase pathfix pkgconfig tar:xz
+USE_GNOME= cairo gdkpixbuf2 gtk30 intlhack
+USE_XORG= x11 xext
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.gnome.gnome-screenshot.gschema.xml
+OPTIONS_DEFINE= INTEL_FIX NLS
+OPTIONS_SUB= yes
+
+# Workaround garbled screenshot when 3D hardware acceleration is enabled
+# via x11-drivers/xf86-video-intel port
+INTEL_FIX_DESC= Don't try to use the gnome-shell interface
+INTEL_FIX_EXTRA_PATCHES+= ${FILESDIR}/extra-patch-intel
+
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_OFF= --disable-nls
+
.include <bsd.port.mk>
diff --git a/deskutils/gnome-screenshot/distinfo b/deskutils/gnome-screenshot/distinfo
index f70198013ed9..b7398986b2d8 100644
--- a/deskutils/gnome-screenshot/distinfo
+++ b/deskutils/gnome-screenshot/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gnome3/gnome-screenshot-3.18.0.tar.xz) = eba64dbf4acf0ab8222fec549d0a4f2dd7dbd51c255e7978dedf1f5c06a98841
-SIZE (gnome3/gnome-screenshot-3.18.0.tar.xz) = 281752
+TIMESTAMP = 1529110023
+SHA256 (gnome3/gnome-screenshot-3.22.0.tar.xz) = 8a05f14b3c7c6cb42f9848ad0332034c7fe5c34a69742910203588fd60b00230
+SIZE (gnome3/gnome-screenshot-3.22.0.tar.xz) = 258888
diff --git a/deskutils/gnome-screenshot/files/extra-patch-intel b/deskutils/gnome-screenshot/files/extra-patch-intel
new file mode 100644
index 000000000000..77d379e10690
--- /dev/null
+++ b/deskutils/gnome-screenshot/files/extra-patch-intel
@@ -0,0 +1,20 @@
+--- src/screenshot-utils.c.orig 2016-07-11 14:55:18 UTC
++++ src/screenshot-utils.c
+@@ -630,6 +630,9 @@ screenshot_get_pixbuf (GdkRectangle *rec
+ filename);
+ }
+
++ if (!g_strcmp0 (g_getenv ("XDG_CURRENT_DESKTOP"), "GNOME"))
++ screenshot = screenshot_fallback_get_pixbuf (rectangle);
++ else {
+ connection = g_application_get_dbus_connection (g_application_get_default ());
+ g_dbus_connection_call_sync (connection,
+ "org.gnome.Shell.Screenshot",
+@@ -659,6 +662,7 @@ screenshot_get_pixbuf (GdkRectangle *rec
+
+ screenshot = screenshot_fallback_get_pixbuf (rectangle);
+ }
++ }
+
+ g_free (path);
+ g_free (tmpname);
diff --git a/deskutils/gnome-screenshot/pkg-descr b/deskutils/gnome-screenshot/pkg-descr
index 267cbaac82e6..46d4866c8b18 100644
--- a/deskutils/gnome-screenshot/pkg-descr
+++ b/deskutils/gnome-screenshot/pkg-descr
@@ -1 +1,4 @@
-GNOME 3.0 utility for taking pictures of your screen.
+GNOME Screenshot is a small utility that takes a screenshot of the whole
+desktop; the currently focused window; or an area of the screen.
+
+WWW: https://gitlab.gnome.org/GNOME/gnome-screenshot
diff --git a/deskutils/gnome-screenshot/pkg-plist b/deskutils/gnome-screenshot/pkg-plist
index bd3418ffb8ba..becb28758c06 100644
--- a/deskutils/gnome-screenshot/pkg-plist
+++ b/deskutils/gnome-screenshot/pkg-plist
@@ -4,99 +4,99 @@ share/GConf/gsettings/gnome-screenshot.convert
share/appdata/org.gnome.Screenshot.appdata.xml
share/applications/org.gnome.Screenshot.desktop
share/dbus-1/services/org.gnome.Screenshot.service
-share/locale/af/LC_MESSAGES/gnome-screenshot.mo
-share/locale/am/LC_MESSAGES/gnome-screenshot.mo
-share/locale/an/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ar/LC_MESSAGES/gnome-screenshot.mo
-share/locale/as/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ast/LC_MESSAGES/gnome-screenshot.mo
-share/locale/az/LC_MESSAGES/gnome-screenshot.mo
-share/locale/be/LC_MESSAGES/gnome-screenshot.mo
-share/locale/be@latin/LC_MESSAGES/gnome-screenshot.mo
-share/locale/bg/LC_MESSAGES/gnome-screenshot.mo
-share/locale/bn/LC_MESSAGES/gnome-screenshot.mo
-share/locale/bn_IN/LC_MESSAGES/gnome-screenshot.mo
-share/locale/br/LC_MESSAGES/gnome-screenshot.mo
-share/locale/bs/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ca/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ca@valencia/LC_MESSAGES/gnome-screenshot.mo
-share/locale/crh/LC_MESSAGES/gnome-screenshot.mo
-share/locale/cs/LC_MESSAGES/gnome-screenshot.mo
-share/locale/cy/LC_MESSAGES/gnome-screenshot.mo
-share/locale/da/LC_MESSAGES/gnome-screenshot.mo
-share/locale/de/LC_MESSAGES/gnome-screenshot.mo
-share/locale/dz/LC_MESSAGES/gnome-screenshot.mo
-share/locale/el/LC_MESSAGES/gnome-screenshot.mo
-share/locale/en@shaw/LC_MESSAGES/gnome-screenshot.mo
-share/locale/en_CA/LC_MESSAGES/gnome-screenshot.mo
-share/locale/en_GB/LC_MESSAGES/gnome-screenshot.mo
-share/locale/eo/LC_MESSAGES/gnome-screenshot.mo
-share/locale/es/LC_MESSAGES/gnome-screenshot.mo
-share/locale/et/LC_MESSAGES/gnome-screenshot.mo
-share/locale/eu/LC_MESSAGES/gnome-screenshot.mo
-share/locale/fa/LC_MESSAGES/gnome-screenshot.mo
-share/locale/fi/LC_MESSAGES/gnome-screenshot.mo
-share/locale/fr/LC_MESSAGES/gnome-screenshot.mo
-share/locale/fur/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ga/LC_MESSAGES/gnome-screenshot.mo
-share/locale/gd/LC_MESSAGES/gnome-screenshot.mo
-share/locale/gl/LC_MESSAGES/gnome-screenshot.mo
-share/locale/gu/LC_MESSAGES/gnome-screenshot.mo
-share/locale/he/LC_MESSAGES/gnome-screenshot.mo
-share/locale/hi/LC_MESSAGES/gnome-screenshot.mo
-share/locale/hr/LC_MESSAGES/gnome-screenshot.mo
-share/locale/hu/LC_MESSAGES/gnome-screenshot.mo
-share/locale/id/LC_MESSAGES/gnome-screenshot.mo
-share/locale/is/LC_MESSAGES/gnome-screenshot.mo
-share/locale/it/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ja/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ka/LC_MESSAGES/gnome-screenshot.mo
-share/locale/kk/LC_MESSAGES/gnome-screenshot.mo
-share/locale/km/LC_MESSAGES/gnome-screenshot.mo
-share/locale/kn/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ko/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ku/LC_MESSAGES/gnome-screenshot.mo
-share/locale/lt/LC_MESSAGES/gnome-screenshot.mo
-share/locale/lv/LC_MESSAGES/gnome-screenshot.mo
-share/locale/mai/LC_MESSAGES/gnome-screenshot.mo
-share/locale/mg/LC_MESSAGES/gnome-screenshot.mo
-share/locale/mk/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ml/LC_MESSAGES/gnome-screenshot.mo
-share/locale/mn/LC_MESSAGES/gnome-screenshot.mo
-share/locale/mr/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ms/LC_MESSAGES/gnome-screenshot.mo
-share/locale/nb/LC_MESSAGES/gnome-screenshot.mo
-share/locale/nds/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ne/LC_MESSAGES/gnome-screenshot.mo
-share/locale/nl/LC_MESSAGES/gnome-screenshot.mo
-share/locale/nn/LC_MESSAGES/gnome-screenshot.mo
-share/locale/oc/LC_MESSAGES/gnome-screenshot.mo
-share/locale/or/LC_MESSAGES/gnome-screenshot.mo
-share/locale/pa/LC_MESSAGES/gnome-screenshot.mo
-share/locale/pl/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ps/LC_MESSAGES/gnome-screenshot.mo
-share/locale/pt/LC_MESSAGES/gnome-screenshot.mo
-share/locale/pt_BR/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ro/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ru/LC_MESSAGES/gnome-screenshot.mo
-share/locale/rw/LC_MESSAGES/gnome-screenshot.mo
-share/locale/si/LC_MESSAGES/gnome-screenshot.mo
-share/locale/sk/LC_MESSAGES/gnome-screenshot.mo
-share/locale/sl/LC_MESSAGES/gnome-screenshot.mo
-share/locale/sq/LC_MESSAGES/gnome-screenshot.mo
-share/locale/sr/LC_MESSAGES/gnome-screenshot.mo
-share/locale/sr@latin/LC_MESSAGES/gnome-screenshot.mo
-share/locale/sv/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ta/LC_MESSAGES/gnome-screenshot.mo
-share/locale/te/LC_MESSAGES/gnome-screenshot.mo
-share/locale/tg/LC_MESSAGES/gnome-screenshot.mo
-share/locale/th/LC_MESSAGES/gnome-screenshot.mo
-share/locale/tr/LC_MESSAGES/gnome-screenshot.mo
-share/locale/ug/LC_MESSAGES/gnome-screenshot.mo
-share/locale/uk/LC_MESSAGES/gnome-screenshot.mo
-share/locale/vi/LC_MESSAGES/gnome-screenshot.mo
-share/locale/wa/LC_MESSAGES/gnome-screenshot.mo
-share/locale/xh/LC_MESSAGES/gnome-screenshot.mo
-share/locale/zh_CN/LC_MESSAGES/gnome-screenshot.mo
-share/locale/zh_HK/LC_MESSAGES/gnome-screenshot.mo
-share/locale/zh_TW/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/af/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/am/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/an/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/as/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/az/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/be/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/be@latin/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/bn/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/bn_IN/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/br/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/bs/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ca@valencia/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/crh/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/cy/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/da/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/dz/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/el/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/en@shaw/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/en_CA/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/et/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/fur/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/gd/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/gu/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/he/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/hi/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/id/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/is/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ka/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/km/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/kn/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ku/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/mai/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/mg/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/mk/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ml/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/mn/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/mr/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/nds/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ne/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/oc/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/or/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ps/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/si/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ta/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/te/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/tg/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/th/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/wa/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/xh/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/zh_HK/LC_MESSAGES/gnome-screenshot.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/gnome-screenshot.mo