aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorSanthosh Raju <fox@FreeBSD.org>2020-05-29 15:43:12 +0000
committerSanthosh Raju <fox@FreeBSD.org>2020-05-29 15:43:12 +0000
commit90c3c4f598f78da3358ea0fbb45dd1f21909629e (patch)
tree8576e450538e523177073bdc39b86b7203c47db2 /deskutils
parent7b98a2609229bf5d15243ef6c1daae093ed7b069 (diff)
downloadports-90c3c4f598f78da3358ea0fbb45dd1f21909629e.tar.gz
ports-90c3c4f598f78da3358ea0fbb45dd1f21909629e.zip
deskutils/foliate: Updates to 2.2.0
- Updates and documents a patch. Changes since 2.1.1: Library: * A library view showing recent books and reading progress (#119) * Search books by metadata * E-book discovery with OPDS (#6, #253) New supported formats: * FictionBook (.fb2, .fb2.zip) (#128) * Comic book archive (.cbr, .cbz, .cbt, .cb7) (#254) * Plain text (.txt) (#226) * Unpacked EPUB files Layout: * Option to set maximum page width (#192) * The "Automatic" layout will now show four columns when the page width is wide (#257) Image viewer: * Improved image viewer, with new shortcuts and the ability to rotate (#299) and invert images * Option to disable image viewer, or to open images on double, middle, or right click (#315) Text-to-speech: * Improved text-to-speech configuration UI * Ability to set text-to-speech voice based on book language (#134) Annotations * Import annotations from JSON * Search in annotations * Annotations are now sorted in the same order as they appear in the book (#318) * "Allow Unsafe Content" now only enables JavaScript; external content will no longer be loaded. This is an important security fix. If you are running an old version of Foliate and cannot upgrade, you should disable "Allow Unsafe Content". * WebKit processes are now sandboxed Other featues and fixes: * Improved support for vertical and right-to-left books * Support for StarDict dictionaries (#302) (requires new optional dependency sdcv) * Fixed current location not preserved when resizing (#152, #204) * Fixed auto-hiding header bar under some themes (#316) * Command-line options for showing version and adding books to library * Option to clear or disable cache * When an HTML page contains invalid self-closing anchor tags, it is now parsed as XHTML (#275, #288) Technical changes: * Foliate now stores file locations in ~/.local/share/com.github.johnfactotum.Foliate/library/uri-store.json, and saves book covers to ~/.cache/com.github.johnfactotum.Foliate. Both can be disabled. * New optional dependency tracker (gir1.2-tracker-2.0 on Debian based distributions), which can be used to get file locations. * New optional dependency libhandy (gir1.2-handy-0.0). It's not absolutely required, but installing it would make the experience better on larger as well as smaller screens. * To open remote files, Foliate now optionally depends on libsoup (gir1.2-soup-2.4). Foliate now bundles two additional libraries: * libarchivejs, which is MIT licensed. It is a WASM port of the popular libarchive C library. * crypto-js, which is MIT licensed. The MD5 module is used to generate identifiers for files that don't have unique identifiers.
Notes
Notes: svn path=/head/; revision=536979
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/foliate/Makefile5
-rw-r--r--deskutils/foliate/distinfo6
-rw-r--r--deskutils/foliate/files/patch-src_epubView.js10
-rw-r--r--deskutils/foliate/pkg-plist24
4 files changed, 30 insertions, 15 deletions
diff --git a/deskutils/foliate/Makefile b/deskutils/foliate/Makefile
index a5cf82b015f2..2d512d3f3074 100644
--- a/deskutils/foliate/Makefile
+++ b/deskutils/foliate/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= foliate
-PORTVERSION= 2.1.1
-PORTREVISION= 1
+PORTVERSION= 2.2.0
CATEGORIES= deskutils
MAINTAINER= fox@FreeBSD.org
@@ -44,7 +43,7 @@ post-install:
${STAGEDIR}${PREFIX}/libexec/foliate/com.github.johnfactotum.Foliate
@${RLN} ${STAGEDIR}${PREFIX}/libexec/foliate/com.github.johnfactotum.Foliate \
${STAGEDIR}${PREFIX}/bin/foliate
- @${REINPLACE_CMD} -e 's/Exec=com.github.johnfactotum.Foliate %F/Exec=foliate %F/g' \
+ @${REINPLACE_CMD} -e 's/Exec=com.github.johnfactotum.Foliate %U/Exec=foliate %U/g' \
${STAGEDIR}${PREFIX}/share/applications/com.github.johnfactotum.Foliate.desktop
.include <bsd.port.mk>
diff --git a/deskutils/foliate/distinfo b/deskutils/foliate/distinfo
index 587bc63d100f..9ef8c9e634a8 100644
--- a/deskutils/foliate/distinfo
+++ b/deskutils/foliate/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1586435575
-SHA256 (johnfactotum-foliate-2.1.1_GH0.tar.gz) = 6260e61886bc89b7798b9b1154daac5e0a8e17a572e8d8fea0f480ec874097cd
-SIZE (johnfactotum-foliate-2.1.1_GH0.tar.gz) = 3123638
+TIMESTAMP = 1590764134
+SHA256 (johnfactotum-foliate-2.2.0_GH0.tar.gz) = 667bf8a7205ad3b9c3359cf47a35fa80945175b30442437da7f4efffba3a5e78
+SIZE (johnfactotum-foliate-2.2.0_GH0.tar.gz) = 4293578
diff --git a/deskutils/foliate/files/patch-src_epubView.js b/deskutils/foliate/files/patch-src_epubView.js
index 9a2a94c13a55..88809a7260c6 100644
--- a/deskutils/foliate/files/patch-src_epubView.js
+++ b/deskutils/foliate/files/patch-src_epubView.js
@@ -1,8 +1,10 @@
---- src/epubView.js.orig 2020-04-06 13:22:39 UTC
+Adds variable to help substitute the correct python version suffix.
+
+--- src/epubView.js.orig 2020-05-29 07:10:48 UTC
+++ src/epubView.js
-@@ -21,7 +21,7 @@ const {
- mimetypes, execCommand, recursivelyDeleteDir
- } = imports.utils
+@@ -36,7 +36,7 @@ var enableAnnotations = [
+ mimetypes.kindleAlias,
+ ]
-const python = GLib.find_program_in_path('python') || GLib.find_program_in_path('python3')
+const python = GLib.find_program_in_path('@PYTHON_VERSION@')
diff --git a/deskutils/foliate/pkg-plist b/deskutils/foliate/pkg-plist
index 6a4e97a88a8e..e558b2530996 100644
--- a/deskutils/foliate/pkg-plist
+++ b/deskutils/foliate/pkg-plist
@@ -1,6 +1,7 @@
bin/foliate
libexec/foliate/com.github.johnfactotum.Foliate
share/applications/com.github.johnfactotum.Foliate.desktop
+share/applications/com.github.johnfactotum.Foliate.desktop.bak
share/com.github.johnfactotum.Foliate/assets/.eslintrc.json
share/com.github.johnfactotum.Foliate/assets/KindleUnpack/__init__.py
share/com.github.johnfactotum.Foliate/assets/KindleUnpack/compatibility_utils.py
@@ -24,20 +25,32 @@ share/com.github.johnfactotum.Foliate/assets/KindleUnpack/mobi_utils.py
share/com.github.johnfactotum.Foliate/assets/KindleUnpack/mobiml2xhtml.py
share/com.github.johnfactotum.Foliate/assets/KindleUnpack/unipath.py
share/com.github.johnfactotum.Foliate/assets/KindleUnpack/unpack_structure.py
+share/com.github.johnfactotum.Foliate/assets/client.html
+share/com.github.johnfactotum.Foliate/assets/epub-viewer-cb.html
share/com.github.johnfactotum.Foliate/assets/epub-viewer-nocsp.html
share/com.github.johnfactotum.Foliate/assets/epub-viewer.css
share/com.github.johnfactotum.Foliate/assets/epub-viewer.html
-share/com.github.johnfactotum.Foliate/assets/epub-viewer.js
-share/com.github.johnfactotum.Foliate/assets/epub.js
-share/com.github.johnfactotum.Foliate/assets/jszip.min.js
-share/com.github.johnfactotum.Foliate/assets/lookup.html
-share/com.github.johnfactotum.Foliate/assets/utils.js
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/LICENSE
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/README.md
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/dist/wasm-gen/libarchive.js
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/dist/wasm-gen/libarchive.wasm
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/dist/worker-bundle.js
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/package.json
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/src/compressed-file.js
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/src/libarchive.js
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/src/webworker/archive-reader.js
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/src/webworker/wasm-gen/libarchive.js
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/src/webworker/wasm-gen/libarchive.wasm
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/src/webworker/wasm-module.js
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/libarchivejs-1.3.0/src/webworker/worker.js
+share/com.github.johnfactotum.Foliate/assets/libarchivejs/main.js
share/com.github.johnfactotum.Foliate/com.github.johnfactotum.Foliate.data.gresource
share/com.github.johnfactotum.Foliate/com.github.johnfactotum.Foliate.src.gresource
share/glib-2.0/schemas/com.github.johnfactotum.Foliate.gschema.xml
share/icons/hicolor/scalable/apps/com.github.johnfactotum.Foliate.svg
share/icons/hicolor/symbolic/apps/com.github.johnfactotum.Foliate-symbolic.svg
share/locale/cs_CS/LC_MESSAGES/com.github.johnfactotum.Foliate.mo
+share/locale/de_DE/LC_MESSAGES/com.github.johnfactotum.Foliate.mo
share/locale/es/LC_MESSAGES/com.github.johnfactotum.Foliate.mo
share/locale/fr_FR/LC_MESSAGES/com.github.johnfactotum.Foliate.mo
share/locale/id_ID/LC_MESSAGES/com.github.johnfactotum.Foliate.mo
@@ -46,5 +59,6 @@ share/locale/nl/LC_MESSAGES/com.github.johnfactotum.Foliate.mo
share/locale/pt_BR/LC_MESSAGES/com.github.johnfactotum.Foliate.mo
share/locale/ru_RU/LC_MESSAGES/com.github.johnfactotum.Foliate.mo
share/locale/sv/LC_MESSAGES/com.github.johnfactotum.Foliate.mo
+share/locale/zh_CN/LC_MESSAGES/com.github.johnfactotum.Foliate.mo
share/locale/zh_TW/LC_MESSAGES/com.github.johnfactotum.Foliate.mo
share/metainfo/com.github.johnfactotum.Foliate.appdata.xml