aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-18 00:20:52 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-18 00:20:52 +0000
commit98de9f1313d74fbf31f429072a48f47aa026abe8 (patch)
tree28f2113930f843769cdb17a3752358da4abaaa74 /deskutils
parentb8980341895fd597b544b990f185b4fe48ecdec8 (diff)
downloadports-98de9f1313d74fbf31f429072a48f47aa026abe8.tar.gz
ports-98de9f1313d74fbf31f429072a48f47aa026abe8.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/libmrproject/Makefile32
-rw-r--r--deskutils/libmrproject/distinfo1
-rw-r--r--deskutils/libmrproject/files/patch-configure10
-rw-r--r--deskutils/libmrproject/pkg-descr6
-rw-r--r--deskutils/libmrproject/pkg-plist50
6 files changed, 100 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 4f333bf31dd9..c224c8d581db 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -26,6 +26,7 @@
SUBDIR += knowit
SUBDIR += kronolith
SUBDIR += krss
+ SUBDIR += libmrproject
SUBDIR += logjam
SUBDIR += logjam2
SUBDIR += loserjabber
diff --git a/deskutils/libmrproject/Makefile b/deskutils/libmrproject/Makefile
new file mode 100644
index 000000000000..371774ea9fba
--- /dev/null
+++ b/deskutils/libmrproject/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libmrproject
+# Date created: 17 February 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmrproject
+PORTVERSION= 0.9
+CATEGORIES= deskutils gnome
+MASTER_SITES= ftp://ftp.codefactory.se/pub/software/mrproject/source/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Library backend for MrProject project management application
+
+LIB_DEPENDS= gsf-1.8:${PORTSDIR}/devel/libgsf
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/deskutils/libmrproject/distinfo b/deskutils/libmrproject/distinfo
new file mode 100644
index 000000000000..16e05b1396a5
--- /dev/null
+++ b/deskutils/libmrproject/distinfo
@@ -0,0 +1 @@
+MD5 (libmrproject-0.9.tar.gz) = b8c818af9b37a0cad82191c6f558d1a8
diff --git a/deskutils/libmrproject/files/patch-configure b/deskutils/libmrproject/files/patch-configure
new file mode 100644
index 000000000000..d46ada0ffe2d
--- /dev/null
+++ b/deskutils/libmrproject/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Mon Feb 17 18:43:33 2003
++++ configure Mon Feb 17 18:45:00 2003
+@@ -8260,6 +8260,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/deskutils/libmrproject/pkg-descr b/deskutils/libmrproject/pkg-descr
new file mode 100644
index 000000000000..aee47600f764
--- /dev/null
+++ b/deskutils/libmrproject/pkg-descr
@@ -0,0 +1,6 @@
+MrProject is a project management program that can help build project plans,
+and track the progress of a project.
+
+This is the library backend needed for the application.
+
+WWW: http://mrproject.codefactory.se/
diff --git a/deskutils/libmrproject/pkg-plist b/deskutils/libmrproject/pkg-plist
new file mode 100644
index 000000000000..cd839e53cd24
--- /dev/null
+++ b/deskutils/libmrproject/pkg-plist
@@ -0,0 +1,50 @@
+include/mrproject-1.0/mrproject/mrp-application.h
+include/mrproject-1.0/mrproject/mrp-assignment.h
+include/mrproject-1.0/mrproject/mrp-calendar.h
+include/mrproject-1.0/mrproject/mrp-day.h
+include/mrproject-1.0/mrproject/mrp-error.h
+include/mrproject-1.0/mrproject/mrp-group.h
+include/mrproject-1.0/mrproject/mrp-object.h
+include/mrproject-1.0/mrproject/mrp-project.h
+include/mrproject-1.0/mrproject/mrp-property.h
+include/mrproject-1.0/mrproject/mrp-relation.h
+include/mrproject-1.0/mrproject/mrp-resource.h
+include/mrproject-1.0/mrproject/mrp-storage-module.h
+include/mrproject-1.0/mrproject/mrp-task.h
+include/mrproject-1.0/mrproject/mrp-time.h
+include/mrproject-1.0/mrproject/mrp-types.h
+include/mrproject-1.0/mrproject/mrproject.h
+lib/libmrproject.a
+lib/libmrproject.so
+lib/libmrproject.so.0
+lib/mrproject/file-modules/libmrp-mpx.so
+lib/mrproject/file-modules/libmrp-xml.so
+lib/mrproject/storage-modules/libstorage-mpx.so
+lib/mrproject/storage-modules/libstorage-mrproject-1.so
+libdata/pkgconfig/libmrproject.pc
+share/gnome/mrproject/dtd/mrproject-0.5.1.dtd
+share/gnome/mrproject/dtd/mrproject-0.6.dtd
+share/locale/am/LC_MESSAGES/libmrproject.mo
+share/locale/cs/LC_MESSAGES/libmrproject.mo
+share/locale/da/LC_MESSAGES/libmrproject.mo
+share/locale/de/LC_MESSAGES/libmrproject.mo
+share/locale/es/LC_MESSAGES/libmrproject.mo
+share/locale/fr/LC_MESSAGES/libmrproject.mo
+share/locale/hu/LC_MESSAGES/libmrproject.mo
+share/locale/it/LC_MESSAGES/libmrproject.mo
+share/locale/ja/LC_MESSAGES/libmrproject.mo
+share/locale/kn/LC_MESSAGES/libmrproject.mo
+share/locale/lv/LC_MESSAGES/libmrproject.mo
+share/locale/nn/LC_MESSAGES/libmrproject.mo
+share/locale/no/LC_MESSAGES/libmrproject.mo
+share/locale/pt/LC_MESSAGES/libmrproject.mo
+share/locale/ru/LC_MESSAGES/libmrproject.mo
+share/locale/sv/LC_MESSAGES/libmrproject.mo
+@dirrm share/gnome/mrproject/dtd
+@dirrm share/gnome/mrproject
+@dirrm share/doc/libmrproject
+@dirrm lib/mrproject/storage-modules
+@dirrm lib/mrproject/file-modules
+@dirrm lib/mrproject
+@dirrm include/mrproject-1.0/mrproject
+@dirrm include/mrproject-1.0