aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-06-09 14:18:17 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-06-09 14:18:17 +0000
commite818e0fa262923104fd5aec57e9dbccf3dd9bc91 (patch)
treee0d71d7c076a0067dad1eebd03e8a3f3ebd686e3 /deskutils
parent9fec2b7f76a4b365dc1d52fb037f132f3e74cf2a (diff)
downloadports-e818e0fa262923104fd5aec57e9dbccf3dd9bc91.tar.gz
ports-e818e0fa262923104fd5aec57e9dbccf3dd9bc91.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/taskcoach/Makefile16
-rw-r--r--deskutils/taskcoach/files/patch-setup.py4
2 files changed, 11 insertions, 9 deletions
diff --git a/deskutils/taskcoach/Makefile b/deskutils/taskcoach/Makefile
index c2837994be2a..c5a4c5c4958f 100644
--- a/deskutils/taskcoach/Makefile
+++ b/deskutils/taskcoach/Makefile
@@ -2,7 +2,7 @@
PORTNAME= taskcoach
PORTVERSION= 1.4.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Release-${PORTVERSION}
DISTNAME= TaskCoach-${PORTVERSION}
@@ -10,26 +10,28 @@ DISTNAME= TaskCoach-${PORTVERSION}
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Friendly task manager
-WRKSRC= ${WRKDIR}/${DISTNAME}
-
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= python twisted
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+NO_ARCH= yes
+USES= python shebangfix twisted
USE_PYTHON= distutils
PYDISTUTILS_EGGINFO=${DISTNAME}-py${PYTHON_VER}.egg-info
USE_WX= 3.0+
WX_COMPS= python:lib
WX_UNICODE= yes
+SHEBANG_FILES= taskcoach.py
+
post-patch:
@${REINPLACE_CMD} -e 's|taskcoach.py|taskcoach|' \
${WRKSRC}/build.in/linux_common/taskcoach.desktop
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/taskcoach.py \
${STAGEDIR}${PREFIX}/bin/taskcoach
- @${INSTALL_DATA} ${WRKSRC}/build.in/linux_common/taskcoach.desktop \
+ ${INSTALL_DATA} ${WRKSRC}/build.in/linux_common/taskcoach.desktop \
${STAGEDIR}${PREFIX}/share/applications/
- @${INSTALL_DATA} ${WRKSRC}/icons.in/taskcoach.png \
+ ${INSTALL_DATA} ${WRKSRC}/icons.in/taskcoach.png \
${STAGEDIR}${PREFIX}/share/pixmaps
.include <bsd.port.mk>
diff --git a/deskutils/taskcoach/files/patch-setup.py b/deskutils/taskcoach/files/patch-setup.py
index 01c987c29ced..c9d9effd7a93 100644
--- a/deskutils/taskcoach/files/patch-setup.py
+++ b/deskutils/taskcoach/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig 2011-12-14 04:24:18.000000000 +0800
-+++ setup.py 2012-01-05 17:57:29.000000000 +0800
+--- setup.py.orig 2011-12-13 20:24:18 UTC
++++ setup.py
@@ -52,8 +52,7 @@
'url': meta.url,
'license': meta.license,