aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-05-08 16:05:21 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-05-08 16:05:21 +0000
commitedee314615bd46f5757d9ff74619b24c367f146b (patch)
treec26ffb804332112a7d1e11a92de398c5b69a2462 /deskutils
parente869b98462f3f85b6c2164bc0028a59b4d2af597 (diff)
downloadports-edee314615bd46f5757d9ff74619b24c367f146b.tar.gz
ports-edee314615bd46f5757d9ff74619b24c367f146b.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/orage/Makefile10
-rw-r--r--deskutils/orage/pkg-plist2
-rw-r--r--deskutils/xfce4-generic-slider/Makefile2
-rw-r--r--deskutils/xfce4-notes-plugin/Makefile15
-rw-r--r--deskutils/xfce4-notification-daemon/Makefile2
-rw-r--r--deskutils/xfce4-notifyd/Makefile1
-rw-r--r--deskutils/xfce4-xkb-plugin/Makefile8
7 files changed, 17 insertions, 23 deletions
diff --git a/deskutils/orage/Makefile b/deskutils/orage/Makefile
index f913fb6cae72..7ad2deeb0f83 100644
--- a/deskutils/orage/Makefile
+++ b/deskutils/orage/Makefile
@@ -3,22 +3,23 @@
PORTNAME= orage
PORTVERSION= 4.8.4
+PORTREVISION= 1
CATEGORIES= deskutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
-COMMENT= A calendar application to manage your time with Xfce 4
+COMMENT= Calendar application to manage your time with Xfce 4
LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USES= pkgconfig gettext
+USES= pkgconfig gettext pathfix desktop-file-utils
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gtk20 intltool intlhack desktopfileutils
+USE_GNOME= gtk20 intltool intlhack
USE_XFCE= configenv libmenu panel
USE_XORG= xext xrender xinerama xi xrandr xcursor xcomposite xdamage x11 \
xfixes
@@ -79,7 +80,4 @@ post-patch:
${WRKSRC}/doc/C/Makefile.in \
${WRKSRC}/doc/C/images/Makefile.in
-post-install:
- @-update-desktop-database
-
.include <bsd.port.mk>
diff --git a/deskutils/orage/pkg-plist b/deskutils/orage/pkg-plist
index 52fe08ab9ad1..c42c68c646b7 100644
--- a/deskutils/orage/pkg-plist
+++ b/deskutils/orage/pkg-plist
@@ -685,8 +685,6 @@ share/locale/zh_TW/LC_MESSAGES/orage.mo
%%WITH_ICAL%%%%DATADIR%%/zoneinfo/tz_convert.par
%%WITH_ICAL%%%%DATADIR%%/zoneinfo/zones.tab
share/xfce4/panel-plugins/xfce4-orageclock-plugin.desktop
-@exec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || /usr/bin/true
@dirrmtry share/xfce4/panel-plugins
@dirrmtry share/xfce4
%%WITH_ICAL%%@dirrm %%DATADIR%%/zoneinfo/US
diff --git a/deskutils/xfce4-generic-slider/Makefile b/deskutils/xfce4-generic-slider/Makefile
index f2e8c61db511..58455aca2891 100644
--- a/deskutils/xfce4-generic-slider/Makefile
+++ b/deskutils/xfce4-generic-slider/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xfce4-generic-slider
PORTVERSION= 0.0.20100827
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= deskutils
MASTER_SITES= CRITICAL/
diff --git a/deskutils/xfce4-notes-plugin/Makefile b/deskutils/xfce4-notes-plugin/Makefile
index cb614d83393e..742c3709e122 100644
--- a/deskutils/xfce4-notes-plugin/Makefile
+++ b/deskutils/xfce4-notes-plugin/Makefile
@@ -1,29 +1,26 @@
-# New ports collection makefile for: xfce4-notes-plugin
-# Date created: 06 October 2003
-# Whom: Thorsten Greiner <thorsten.greiner@web.de>
-#
+# Created by: Thorsten Greiner <thorsten.greiner@web.de>
# $FreeBSD$
#
PORTNAME= xfce4-notes-plugin
PORTVERSION= 1.7.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR=/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITE_SUBDIR=src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Sticky notes panel plugin for Xfce4
-LIB_DEPENDS= unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
+LIB_DEPENDS= unique-1:${PORTSDIR}/x11-toolkits/unique
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USES= gettext
+USES= gettext pathfix pkgconfig
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack glib20 gtk20 intltool intlhack desktopfileutils pkgconfig
+USE_GNOME= glib20 gtk20 intltool intlhack
USE_XFCE= configenv libgui libutil panel xfconf
INSTALLS_ICONS= yes
diff --git a/deskutils/xfce4-notification-daemon/Makefile b/deskutils/xfce4-notification-daemon/Makefile
index 0427abff61be..8f1ce8997b48 100644
--- a/deskutils/xfce4-notification-daemon/Makefile
+++ b/deskutils/xfce4-notification-daemon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= notification-daemon
PORTVERSION= 0.3.7
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= deskutils xfce
MASTER_SITES= CRITICAL/
PKGNAMEPREFIX= xfce4-
diff --git a/deskutils/xfce4-notifyd/Makefile b/deskutils/xfce4-notifyd/Makefile
index bc72845a0bc8..96f8bd74266d 100644
--- a/deskutils/xfce4-notifyd/Makefile
+++ b/deskutils/xfce4-notifyd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xfce4-notifyd
PORTVERSION= 0.2.3
+PORTREVISION= 1
CATEGORIES= deskutils xfce
MASTER_SITES= XFCE
MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
diff --git a/deskutils/xfce4-xkb-plugin/Makefile b/deskutils/xfce4-xkb-plugin/Makefile
index 9684b30d8818..91b574264f01 100644
--- a/deskutils/xfce4-xkb-plugin/Makefile
+++ b/deskutils/xfce4-xkb-plugin/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xfce4-xkb-plugin
PORTVERSION= 0.5.4.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -10,13 +10,13 @@ MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9
MAINTAINER= xfce@FreeBSD.org
COMMENT= Keyboard layout switching plugin for Xfce4
-LIB_DEPENDS= xklavier.12:${PORTSDIR}/x11/libxklavier
+LIB_DEPENDS= xklavier:${PORTSDIR}/x11/libxklavier
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USES= gettext
+USES= gettext pkgconfig
USE_GMAKE= yes
-USE_GNOME= gtk20 intltool intlhack pkgconfig librsvg2
+USE_GNOME= gtk20 intltool intlhack librsvg2
USE_XFCE= configenv panel
.include <bsd.port.mk>