aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-25 16:13:38 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-25 16:13:38 +0000
commit21bc5c0345300431d6e3edc6c43d743c61fc7b5e (patch)
tree2cf1a158cf8540bcd6bed759d4e35240e31330bb /deskutils
parent5fe67ba9212540bea871dfec487d380ec3079f21 (diff)
downloadports-21bc5c0345300431d6e3edc6c43d743c61fc7b5e.tar.gz
ports-21bc5c0345300431d6e3edc6c43d743c61fc7b5e.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/fbreader/Makefile3
-rw-r--r--deskutils/growl-for-linux/Makefile3
-rw-r--r--deskutils/gworkspace-gwmetadata/Makefile3
-rw-r--r--deskutils/osmo/Makefile3
-rw-r--r--deskutils/pinot/Makefile3
5 files changed, 5 insertions, 10 deletions
diff --git a/deskutils/fbreader/Makefile b/deskutils/fbreader/Makefile
index 9161e81dc4dc..f008c61e246c 100644
--- a/deskutils/fbreader/Makefile
+++ b/deskutils/fbreader/Makefile
@@ -27,9 +27,8 @@ STATUS= debug
STATUS= release
.endif
-USES= compiler gmake iconv pkgconfig tar:tgz
+USES= compiler gmake iconv pkgconfig sqlite tar:tgz
USE_LDCONFIG= yes
-USE_SQLITE= yes
INSTALL_TARGET= do_install
diff --git a/deskutils/growl-for-linux/Makefile b/deskutils/growl-for-linux/Makefile
index 578352e5bd2f..c8255dba2f37 100644
--- a/deskutils/growl-for-linux/Makefile
+++ b/deskutils/growl-for-linux/Makefile
@@ -31,11 +31,10 @@ OPTIONS_DEFINE= LIBNOTIFY
PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,}
-USES= autoreconf compiler:nestedfct libtool pkgconfig
+USES= autoreconf compiler:nestedfct libtool pkgconfig sqlite:3
USE_GITHUB= yes
USE_GNOME= gtk20
USE_OPENSSL= yes
-USE_SQLITE= 3
post-patch:
@${REINPLACE_CMD} '/^gol_LDADD =/s/$$/ -lgmodule-2.0/' \
diff --git a/deskutils/gworkspace-gwmetadata/Makefile b/deskutils/gworkspace-gwmetadata/Makefile
index 228592f259f7..627d965e1c96 100644
--- a/deskutils/gworkspace-gwmetadata/Makefile
+++ b/deskutils/gworkspace-gwmetadata/Makefile
@@ -12,14 +12,13 @@ COMMENT= GWMetadata for GNUstep workspace manager
LICENSE= GPLv2
-USES= gnustep
+USES= gnustep sqlite
USE_GNUSTEP= back build
GNU_CONFIGURE= yes
LIB_DEPENDS= libDBKit.so:deskutils/gworkspace \
libPreferencePanes.so:deskutils/systempreferences
USE_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
-USE_SQLITE= yes
LDFLAGS+= -lpthread
WRKSRC= ${WRKDIR}/gworkspace-${PORTVERSION}/GWMetadata
diff --git a/deskutils/osmo/Makefile b/deskutils/osmo/Makefile
index c166e0b1c175..0b365bad1c3f 100644
--- a/deskutils/osmo/Makefile
+++ b/deskutils/osmo/Makefile
@@ -18,9 +18,8 @@ LIB_DEPENDS= libical.so:devel/libical \
libgtkspell.so:textproc/gtkspell \
libwebkitgtk-1.0.so:www/webkit-gtk2
-USES= gettext gmake libarchive pkgconfig
+USES= gettext gmake libarchive pkgconfig sqlite
USE_GNOME= gtk20 libxml2
-USE_SQLITE= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index 5a4460468f2d..c4e4ecc6a788 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -47,9 +47,8 @@ CONFIGURE_ENV= MKDIR_P="${MKDIR}"
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lboost_system
-USES= gettext libarchive libtool pkgconfig python shebangfix
+USES= gettext libarchive libtool pkgconfig python shebangfix sqlite:3
USE_OPENSSL= yes
-USE_SQLITE= 3
USE_XORG= pixman
USE_LDCONFIG= ${PREFIX}/lib/pinot/backends ${PREFIX}/lib/pinot/filters
SHEBANG_FILES= scripts/bash/*.sh