aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2014-10-15 14:36:36 +0000
committerKris Moore <kmoore@FreeBSD.org>2014-10-15 14:36:36 +0000
commit50918dc63d0eb9c14a3324cd140cb0964aad0733 (patch)
tree3d16e4fa6a9f8581507c4c889cf770e9d0325208 /deskutils
parentd3971c7b0c5fe001fcbfa7b86a2162a89c2b8982 (diff)
downloadports-50918dc63d0eb9c14a3324cd140cb0964aad0733.tar.gz
ports-50918dc63d0eb9c14a3324cd140cb0964aad0733.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/homerun/Makefile17
-rw-r--r--deskutils/homerun/distinfo2
-rw-r--r--deskutils/homerun/pkg-descr7
-rw-r--r--deskutils/homerun/pkg-plist86
5 files changed, 113 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index f761bc51e3bd..7856d99caba1 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -86,6 +86,7 @@
SUBDIR += hamster-applet
SUBDIR += hebcal
SUBDIR += helpviewer
+ SUBDIR += homerun
SUBDIR += horde-groupware
SUBDIR += horde-kronolith
SUBDIR += horde-mnemo
diff --git a/deskutils/homerun/Makefile b/deskutils/homerun/Makefile
new file mode 100644
index 000000000000..e7fc8f25de1c
--- /dev/null
+++ b/deskutils/homerun/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= homerun
+PORTVERSION= 0.2.3
+CATEGORIES= deskutils
+MASTER_SITES= http://download.kde.org/unstable/homerun/src/
+
+MAINTAINER= yurkis@gmail.com
+COMMENT= Homerun is a fullscreen launcher with content organized in tabs.
+
+USES= cmake tar:bzip2
+USE_KDE4= kdehier kdelibs kdeprefix automoc4 workspace
+USE_QT4= moc_build qmake_build rcc_build uic_build corelib gui
+USE_XORG= x11
+CMAKE_ARGS+= -DROOT_PREFIX:PATH=${STAGEDIR}
+
+.include <bsd.port.mk>
diff --git a/deskutils/homerun/distinfo b/deskutils/homerun/distinfo
new file mode 100644
index 000000000000..61e1318877b0
--- /dev/null
+++ b/deskutils/homerun/distinfo
@@ -0,0 +1,2 @@
+SHA256 (homerun-0.2.3.tar.bz2) = a6278c69ebcfa50efcbc6a472dc1e8d61a38c9413d771cfb6c51448a4d267657
+SIZE (homerun-0.2.3.tar.bz2) = 164800
diff --git a/deskutils/homerun/pkg-descr b/deskutils/homerun/pkg-descr
new file mode 100644
index 000000000000..96f2301cd033
--- /dev/null
+++ b/deskutils/homerun/pkg-descr
@@ -0,0 +1,7 @@
+Homerun is a fullscreen launcher with content organized in tabs.
+A tab is composed of several "sources". A source can provide one
+or more sections to a tab. Homerun comes with a few built-in sources,
+but custom sources can be written using libhomerun.
+
+WWW: https://userbase.kde.org/Homerun
+
diff --git a/deskutils/homerun/pkg-plist b/deskutils/homerun/pkg-plist
new file mode 100644
index 000000000000..8b879b4c98dd
--- /dev/null
+++ b/deskutils/homerun/pkg-plist
@@ -0,0 +1,86 @@
+bin/homerunviewer
+lib/libhomerun.so.0.0.0
+lib/libhomerun.so.0
+lib/libhomerun.so
+lib/cmake/Homerun/HomerunTargets.cmake
+lib/cmake/Homerun/HomerunTargets-release.cmake
+lib/cmake/Homerun/HomerunConfig.cmake
+lib/cmake/Homerun/HomerunConfigVersion.cmake
+lib/kde4/plasma_applet_homerunlauncher.so
+include/homerun/abstractsource.h
+include/homerun/actionlist.h
+include/homerun/homerun_export.h
+include/homerun/libhomerun_config.h
+include/homerun/pathmodel.h
+include/homerun/sourceconfigurationwidget.h
+lib/kde4/imports/org/kde/homerun/components/libcomponentsplugin.so
+lib/kde4/imports/org/kde/homerun/components/private/IconLoader.qml
+lib/kde4/imports/org/kde/homerun/components/private/TabGroup.js
+lib/kde4/imports/org/kde/homerun/components/Label.qml
+lib/kde4/imports/org/kde/homerun/components/TabGroup.qml
+lib/kde4/imports/org/kde/homerun/components/TabBar.qml
+lib/kde4/imports/org/kde/homerun/components/qmldir
+lib/kde4/imports/org/kde/homerun/components/TabButton.qml
+lib/kde4/imports/org/kde/homerun/fixes/libfixesplugin.so
+lib/kde4/imports/org/kde/homerun/fixes/TextField.qml
+lib/kde4/imports/org/kde/homerun/fixes/qmldir
+lib/kde4/imports/org/kde/homerun/fixes/private/TextFieldFocus.qml
+share/config/homerunrc
+share/kde4/services/homerunviewer.desktop
+share/kde4/servicetypes/homerun-source.desktop
+share/kde4/services/plasma-applet-homerunlauncher.desktop
+share/icons/hicolor/22x22/apps/homerun.png
+share/icons/hicolor/128x128/apps/homerun.png
+share/icons/hicolor/32x32/apps/homerun.png
+share/icons/hicolor/48x48/apps/homerun.png
+share/icons/hicolor/16x16/apps/homerun.png
+share/icons/hicolor/64x64/apps/homerun.png
+share/icons/hicolor/scalable/apps/homerun.svgz
+share/apps/plasma/plasmoids/org.kde.homerun/contents/config/main.xml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/code/LayoutManager.js
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/ActionMenu.qml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/TabSideButton.qml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/AvailableSourceItem.qml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/LogText.qml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/TabContent.qml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/ResultsView.qml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Page.qml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/main.qml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/config.ui
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/SlidingContainer.qml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/Result.qml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/TabContentInternal.js
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/SourceItem.qml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/DebugRectangle.qml
+share/apps/plasma/plasmoids/org.kde.homerun/contents/ui/KeyboardUtils.js
+share/apps/plasma/plasmoids/org.kde.homerun/metadata.desktop
+share/kde4/services/plasma-applet-homerun.desktop
+lib/kde4/homerun_source_recentdocuments.so
+share/kde4/services/homerun-source-recentdocuments.desktop
+share/locale/lt/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/pt/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/pt_BR/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/uk/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/fi/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/sl/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/pa/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/et/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/ru/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/de/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/nl/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/cs/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/zh_CN/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/gl/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/sk/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/fr/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/el/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/hu/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/pl/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/ga/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/es/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/mr/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/tr/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/bs/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/sv/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/ro/LC_MESSAGES/plasma_applet_org.kde.homerun.mo
+share/locale/da/LC_MESSAGES/plasma_applet_org.kde.homerun.mo