aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2020-09-21 19:45:42 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2020-09-21 19:45:42 +0000
commit52ec6d72bace7d40e9de189429cf8d5faebeab1d (patch)
tree4fd7aae904cd4eda49c26a7751e314ea04d98564 /deskutils
parent56b5808a8e51ec19ce3c1deb276f232dad4341ee (diff)
downloadports-52ec6d72bace7d40e9de189429cf8d5faebeab1d.tar.gz
ports-52ec6d72bace7d40e9de189429cf8d5faebeab1d.zip
Dstask is a personal task tracker designed to help you focus. It is
similar to taskwarrior but uses git to synchronise instead of a proprietary protocol. Dstask is mature enough for daily use. Features: o Powerful context system (automatically applies filter/tags to queries and new tasks) o Git powered sync/undo/resolve (passwordstore.org style) which means no need to set up a sync server, and sync between devices is easy! o Task listing won't break with long task text (unlike taskwarrior, currently) o note command -- edit a full markdown note for each task. Checklists are useful here. o open command -- open URLs found in specified task (including notes) in the browser o zsh/bash completion for speed o A single statically-linked binary WWW: https://github.com/naggie/dstask
Notes
Notes: svn path=/head/; revision=549485
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/dstask/Makefile39
-rw-r--r--deskutils/dstask/distinfo3
-rw-r--r--deskutils/dstask/pkg-descr21
4 files changed, 64 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 56b9434a1c75..d23b8c3074fe 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -39,6 +39,7 @@
SUBDIR += dfshow
SUBDIR += docear
SUBDIR += dosage
+ SUBDIR += dstask
SUBDIR += easystroke
SUBDIR += egroupware
SUBDIR += fasd
diff --git a/deskutils/dstask/Makefile b/deskutils/dstask/Makefile
new file mode 100644
index 000000000000..fdddcf677b14
--- /dev/null
+++ b/deskutils/dstask/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= dstask
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.20
+CATEGORIES= deskutils
+
+MAINTAINER= ashish@FreeBSD.org
+COMMENT= Single binary terminal-based TODO manager with git-based sync
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= git:devel/git
+
+USES= go:modules
+GO_TARGET= ./cmd/dstask.go
+
+USE_GITHUB= yes
+GH_ACCOUNT= naggie
+
+PLIST_FILES= bin/${PORTNAME} \
+ ${DOCSDIR_REL}/README.md \
+ etc/bash_completion.d/${PORTNAME}.sh \
+ share/zsh/site-functions/_${PORTNAME}
+
+post-install:
+ @${MV} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}.go \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${WRKSRC}/.${PORTNAME}-zsh-completions.sh \
+ ${STAGEDIR}${PREFIX}/share/zsh/site-functions/_${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
+ ${INSTALL_DATA} ${WRKSRC}/.${PORTNAME}-bash-completions.sh \
+ ${STAGEDIR}${PREFIX}/etc/bash_completion.d/${PORTNAME}.sh
+
+.include <bsd.port.mk>
diff --git a/deskutils/dstask/distinfo b/deskutils/dstask/distinfo
new file mode 100644
index 000000000000..c29dc60249d0
--- /dev/null
+++ b/deskutils/dstask/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1600714118
+SHA256 (naggie-dstask-v0.20_GH0.tar.gz) = a2a79e534896f16094df1e16033f63f7399326f15d689c1b22d8ceb6d9547b40
+SIZE (naggie-dstask-v0.20_GH0.tar.gz) = 2631936
diff --git a/deskutils/dstask/pkg-descr b/deskutils/dstask/pkg-descr
new file mode 100644
index 000000000000..f2a53ce35e8b
--- /dev/null
+++ b/deskutils/dstask/pkg-descr
@@ -0,0 +1,21 @@
+Dstask is a personal task tracker designed to help you focus. It is
+similar to taskwarrior but uses git to synchronise instead of a
+proprietary protocol.
+
+Dstask is mature enough for daily use.
+
+Features:
+ o Powerful context system (automatically applies filter/tags to
+ queries and new tasks)
+ o Git powered sync/undo/resolve (passwordstore.org style) which means
+ no need to set up a sync server, and sync between devices is easy!
+ o Task listing won't break with long task text (unlike taskwarrior,
+ currently)
+ o note command -- edit a full markdown note for each task. Checklists
+ are useful here.
+ o open command -- open URLs found in specified task (including notes)
+ in the browser
+ o zsh/bash completion for speed
+ o A single statically-linked binary
+
+WWW: https://github.com/naggie/dstask