aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2006-10-18 20:25:11 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2006-10-18 20:25:11 +0000
commit64802fefbc44abaaf05763814b086a208970d7c0 (patch)
tree1a9efdb7eb5e7d49b726a50ec8ac7a0b0afb4a79 /deskutils
parent5d10be3cde7b8744ebf44d239c3220d878d19203 (diff)
downloadports-64802fefbc44abaaf05763814b086a208970d7c0.tar.gz
ports-64802fefbc44abaaf05763814b086a208970d7c0.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/tomboy/Makefile1
-rw-r--r--deskutils/tomboy/files/patch-Tomboy_Utils.cs27
2 files changed, 28 insertions, 0 deletions
diff --git a/deskutils/tomboy/Makefile b/deskutils/tomboy/Makefile
index c3044c0cf9f2..af92cf27f690 100644
--- a/deskutils/tomboy/Makefile
+++ b/deskutils/tomboy/Makefile
@@ -8,6 +8,7 @@
PORTNAME= tomboy
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/deskutils/tomboy/files/patch-Tomboy_Utils.cs b/deskutils/tomboy/files/patch-Tomboy_Utils.cs
new file mode 100644
index 000000000000..129152c6d740
--- /dev/null
+++ b/deskutils/tomboy/files/patch-Tomboy_Utils.cs
@@ -0,0 +1,27 @@
+--- Tomboy/Utils.cs.orig Tue Oct 17 18:50:40 2006
++++ Tomboy/Utils.cs Thu Aug 10 09:12:49 2006
+@@ -767,24 +767,9 @@
+ RegisterSignalHandlers ();
+ }
+
+- [DllImport("libc")]
+- private static extern int prctl (int option,
+- byte [] arg2,
+- IntPtr arg3,
+- IntPtr arg4,
+- IntPtr arg5);
+-
+ // From Banshee: Banshee.Base/Utilities.cs
+ public static void SetProcessName (string name)
+ {
+- if (prctl (15 /* PR_SET_NAME */,
+- Encoding.ASCII.GetBytes (name + "\0"),
+- IntPtr.Zero,
+- IntPtr.Zero,
+- IntPtr.Zero) != 0)
+- throw new ApplicationException (
+- "Error setting process name: " +
+- Mono.Unix.Native.Stdlib.GetLastError ());
+ }
+
+ static void RegisterSignalHandlers ()