aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
commite1bfdfbe5665c963621e06f6bbfbbc2c000a804e (patch)
treeeaf052562fa1ad9b232918eb5e617ac1df0dd725 /deskutils
parentf57bc4af665126de839ff734a08e57726e84da84 (diff)
downloadports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.tar.gz
ports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/akonadi-calendar-tools/Makefile2
-rw-r--r--deskutils/akonadi-import-wizard/Makefile2
-rw-r--r--deskutils/akonadiconsole/Makefile2
-rw-r--r--deskutils/akregator/Makefile2
-rw-r--r--deskutils/gnote/Makefile2
-rw-r--r--deskutils/grantlee-editor/Makefile2
-rw-r--r--deskutils/grantleetheme/Makefile2
-rw-r--r--deskutils/kaddressbook/Makefile2
-rw-r--r--deskutils/kalarm/Makefile2
-rw-r--r--deskutils/kcharselect/Makefile2
-rw-r--r--deskutils/kdepim-addons/Makefile2
-rw-r--r--deskutils/kdepim-apps-libs/Makefile2
-rw-r--r--deskutils/kdepim-runtime/Makefile2
-rw-r--r--deskutils/keditbookmarks/Makefile2
-rw-r--r--deskutils/kfind/Makefile2
-rw-r--r--deskutils/kmail-account-wizard/Makefile2
-rw-r--r--deskutils/kmail/Makefile2
-rw-r--r--deskutils/knotes/Makefile2
-rw-r--r--deskutils/kontact/Makefile2
-rw-r--r--deskutils/korganizer/Makefile2
-rw-r--r--deskutils/kruler/Makefile2
-rw-r--r--deskutils/launchy/Makefile2
-rw-r--r--deskutils/libkdepim/Makefile2
-rw-r--r--deskutils/mbox-importer/Makefile2
-rw-r--r--deskutils/nautilus-actions/Makefile2
-rw-r--r--deskutils/notecase/Makefile2
-rw-r--r--deskutils/pim-data-exporter/Makefile2
-rw-r--r--deskutils/pim-sieve-editor/Makefile2
-rw-r--r--deskutils/taskd/Makefile2
-rw-r--r--deskutils/tasksh/Makefile2
30 files changed, 60 insertions, 0 deletions
diff --git a/deskutils/akonadi-calendar-tools/Makefile b/deskutils/akonadi-calendar-tools/Makefile
index 32072c6ae9f2..11d5403d4eeb 100644
--- a/deskutils/akonadi-calendar-tools/Makefile
+++ b/deskutils/akonadi-calendar-tools/Makefile
@@ -25,4 +25,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/akonadi-import-wizard/Makefile b/deskutils/akonadi-import-wizard/Makefile
index 75d4ae6d712c..3463864e350d 100644
--- a/deskutils/akonadi-import-wizard/Makefile
+++ b/deskutils/akonadi-import-wizard/Makefile
@@ -27,4 +27,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/akonadiconsole/Makefile b/deskutils/akonadiconsole/Makefile
index 3ffade32e679..74392a9cec3a 100644
--- a/deskutils/akonadiconsole/Makefile
+++ b/deskutils/akonadiconsole/Makefile
@@ -34,4 +34,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/akregator/Makefile b/deskutils/akregator/Makefile
index 5033496b74ee..b3afb4b80e95 100644
--- a/deskutils/akregator/Makefile
+++ b/deskutils/akregator/Makefile
@@ -31,4 +31,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/gnote/Makefile b/deskutils/gnote/Makefile
index ebddfd09fbc7..04f5061fe84f 100644
--- a/deskutils/gnote/Makefile
+++ b/deskutils/gnote/Makefile
@@ -39,6 +39,8 @@ DOCS= AUTHORS ChangeLog NEWS README TODO
PLIST_SUB+= VERSION=${PORTVERSION}
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${DOCS}
diff --git a/deskutils/grantlee-editor/Makefile b/deskutils/grantlee-editor/Makefile
index c5fbb811e476..cd4c308c4a21 100644
--- a/deskutils/grantlee-editor/Makefile
+++ b/deskutils/grantlee-editor/Makefile
@@ -32,4 +32,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/grantleetheme/Makefile b/deskutils/grantleetheme/Makefile
index c935098f27c8..f242438598d3 100644
--- a/deskutils/grantleetheme/Makefile
+++ b/deskutils/grantleetheme/Makefile
@@ -19,4 +19,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/kaddressbook/Makefile b/deskutils/kaddressbook/Makefile
index a27b371c88d3..4eb24f65fca0 100644
--- a/deskutils/kaddressbook/Makefile
+++ b/deskutils/kaddressbook/Makefile
@@ -29,4 +29,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/kalarm/Makefile b/deskutils/kalarm/Makefile
index ae8eaf1069bb..e5a96ea0c7fc 100644
--- a/deskutils/kalarm/Makefile
+++ b/deskutils/kalarm/Makefile
@@ -30,4 +30,6 @@ SHEBANG_FILES= src/kconf_update/kalarm*.pl
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/kcharselect/Makefile b/deskutils/kcharselect/Makefile
index 1c3c96b85168..89c0ef82ae38 100644
--- a/deskutils/kcharselect/Makefile
+++ b/deskutils/kcharselect/Makefile
@@ -16,4 +16,6 @@ USE_KDE= auth codecs config configwidgets coreaddons crash ecm bookmarks \
USE_QT= core dbus gui widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/kdepim-addons/Makefile b/deskutils/kdepim-addons/Makefile
index 10d4cf208d5b..0ca4015d617d 100644
--- a/deskutils/kdepim-addons/Makefile
+++ b/deskutils/kdepim-addons/Makefile
@@ -36,4 +36,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/kdepim-apps-libs/Makefile b/deskutils/kdepim-apps-libs/Makefile
index 6da57b355b22..c86dfd296fc9 100644
--- a/deskutils/kdepim-apps-libs/Makefile
+++ b/deskutils/kdepim-apps-libs/Makefile
@@ -28,4 +28,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/kdepim-runtime/Makefile b/deskutils/kdepim-runtime/Makefile
index 5b7007eaef81..e8f5242f2da8 100644
--- a/deskutils/kdepim-runtime/Makefile
+++ b/deskutils/kdepim-runtime/Makefile
@@ -35,4 +35,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/keditbookmarks/Makefile b/deskutils/keditbookmarks/Makefile
index f2b058004f7b..4ec6796984ac 100644
--- a/deskutils/keditbookmarks/Makefile
+++ b/deskutils/keditbookmarks/Makefile
@@ -14,4 +14,6 @@ USE_KDE= auth bookmarks codecs completion config configwidgets \
USE_QT= core dbus gui network widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/kfind/Makefile b/deskutils/kfind/Makefile
index af4a60655f3f..eea9219d562b 100644
--- a/deskutils/kfind/Makefile
+++ b/deskutils/kfind/Makefile
@@ -16,4 +16,6 @@ USE_KDE= archive auth bookmarks codecs completion config configwidgets \
USE_QT= core dbus gui network printsupport widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/kmail-account-wizard/Makefile b/deskutils/kmail-account-wizard/Makefile
index 70e2e4e69c3f..81194e9384a2 100644
--- a/deskutils/kmail-account-wizard/Makefile
+++ b/deskutils/kmail-account-wizard/Makefile
@@ -27,4 +27,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/kmail/Makefile b/deskutils/kmail/Makefile
index 85cf5364bce3..8b32b5eda9ba 100644
--- a/deskutils/kmail/Makefile
+++ b/deskutils/kmail/Makefile
@@ -42,4 +42,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/knotes/Makefile b/deskutils/knotes/Makefile
index ea082b5ab9ee..eb38a21f90d7 100644
--- a/deskutils/knotes/Makefile
+++ b/deskutils/knotes/Makefile
@@ -31,4 +31,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/kontact/Makefile b/deskutils/kontact/Makefile
index 7f668e1dd950..b7e9b9e1e981 100644
--- a/deskutils/kontact/Makefile
+++ b/deskutils/kontact/Makefile
@@ -24,4 +24,6 @@ DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/korganizer/Makefile b/deskutils/korganizer/Makefile
index bdc9d2fbf1cd..3b57c6085dd9 100644
--- a/deskutils/korganizer/Makefile
+++ b/deskutils/korganizer/Makefile
@@ -29,4 +29,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/kruler/Makefile b/deskutils/kruler/Makefile
index b0efa16f03fb..c96a7c68c231 100644
--- a/deskutils/kruler/Makefile
+++ b/deskutils/kruler/Makefile
@@ -14,4 +14,6 @@ USE_QT= core dbus gui widgets x11extras xml \
buildtools_build qmake_build
USE_XORG= x11 xcb
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/launchy/Makefile b/deskutils/launchy/Makefile
index 51b713a9c555..9a417a02900e 100644
--- a/deskutils/launchy/Makefile
+++ b/deskutils/launchy/Makefile
@@ -24,6 +24,8 @@ PORTDOCS= *
MAKE_JOBS_UNSAFE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} 's,/usr,${PREFIX},' \
${WRKSRC}/platforms/unix/unix.pro \
diff --git a/deskutils/libkdepim/Makefile b/deskutils/libkdepim/Makefile
index 494dc902e721..e18b381167e8 100644
--- a/deskutils/libkdepim/Makefile
+++ b/deskutils/libkdepim/Makefile
@@ -24,4 +24,6 @@ USE_QT= core dbus designer gui network testlib uiplugin uitools \
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/mbox-importer/Makefile b/deskutils/mbox-importer/Makefile
index da51e285573a..f35b78900cc7 100644
--- a/deskutils/mbox-importer/Makefile
+++ b/deskutils/mbox-importer/Makefile
@@ -26,4 +26,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/nautilus-actions/Makefile b/deskutils/nautilus-actions/Makefile
index 4f1b4fe00008..54423dae9930 100644
--- a/deskutils/nautilus-actions/Makefile
+++ b/deskutils/nautilus-actions/Makefile
@@ -32,6 +32,8 @@ PORTDOCS= AUTHORS ChangeLog ChangeLog-2008 ChangeLog-2009 ChangeLog-2010 \
ChangeLog-2011 ChangeLog-2012 COPYING COPYING-DOCS INSTALL \
MAINTAINERS NEWS README README-GCONF TODO
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/deskutils/notecase/Makefile b/deskutils/notecase/Makefile
index 571131b3dcf2..f24cf2ffd3f6 100644
--- a/deskutils/notecase/Makefile
+++ b/deskutils/notecase/Makefile
@@ -24,6 +24,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= help.ncd
+OPTIONS_DEFINE= DOCS
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/notecase
diff --git a/deskutils/pim-data-exporter/Makefile b/deskutils/pim-data-exporter/Makefile
index 8c2a9326574e..69aa2fce139a 100644
--- a/deskutils/pim-data-exporter/Makefile
+++ b/deskutils/pim-data-exporter/Makefile
@@ -29,4 +29,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/pim-sieve-editor/Makefile b/deskutils/pim-sieve-editor/Makefile
index dff38cad3fb0..6dfad70358a7 100644
--- a/deskutils/pim-sieve-editor/Makefile
+++ b/deskutils/pim-sieve-editor/Makefile
@@ -20,4 +20,6 @@ USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/deskutils/taskd/Makefile b/deskutils/taskd/Makefile
index 487028de12cd..849cc0cefffc 100644
--- a/deskutils/taskd/Makefile
+++ b/deskutils/taskd/Makefile
@@ -48,6 +48,8 @@ CFLAGS+= -g -O0
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
post-install:
(cd ${WRKSRC}/pki && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
${MKDIR} ${STAGEDIR}${TASKD_DBDIR}
diff --git a/deskutils/tasksh/Makefile b/deskutils/tasksh/Makefile
index aae605eeb3f0..120ed4b30da1 100644
--- a/deskutils/tasksh/Makefile
+++ b/deskutils/tasksh/Makefile
@@ -11,4 +11,6 @@ COMMENT= Shell command that wraps Taskwarrior commands
USES= cmake compiler:c++11-lang readline
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>