aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2017-03-29 08:49:20 +0000
committerJason E. Hale <jhale@FreeBSD.org>2017-03-29 08:49:20 +0000
commitb4555a2a12e09f451a71ba56fcad912fc6f961e5 (patch)
treef447ea787e5c114b0018090e8730dee2e0a91790 /deskutils
parentc710b18b06c4c06bbef6a92fedfb1da88e39bdfa (diff)
downloadports-b4555a2a12e09f451a71ba56fcad912fc6f961e5.tar.gz
ports-b4555a2a12e09f451a71ba56fcad912fc6f961e5.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/plasma-applet-daisy/Makefile8
-rw-r--r--deskutils/plasma-applet-daisy/files/patch-applet_CMakeLists.txt21
2 files changed, 26 insertions, 3 deletions
diff --git a/deskutils/plasma-applet-daisy/Makefile b/deskutils/plasma-applet-daisy/Makefile
index 1ef7b810fc89..4b9fbd11dd91 100644
--- a/deskutils/plasma-applet-daisy/Makefile
+++ b/deskutils/plasma-applet-daisy/Makefile
@@ -2,7 +2,7 @@
PORTNAME= daisy
PORTVERSION= 0.0.4.26
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= deskutils kde
MASTER_SITES= http://cdlszm.org/downloads/
PKGNAMEPREFIX= plasma-applet-
@@ -11,10 +11,12 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= jhale@FreeBSD.org
COMMENT= Simple launcher plasma applet for KDE4
-LICENSE= GPLv3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= cmake gettext kde:4
USE_KDE= automoc4 kdelibs workspace
-USE_QT4= qmake_build moc_build rcc_build uic_build
+USE_QT4= corelib dbus gui network svg xml \
+ qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/deskutils/plasma-applet-daisy/files/patch-applet_CMakeLists.txt b/deskutils/plasma-applet-daisy/files/patch-applet_CMakeLists.txt
new file mode 100644
index 000000000000..15ebf1a825c8
--- /dev/null
+++ b/deskutils/plasma-applet-daisy/files/patch-applet_CMakeLists.txt
@@ -0,0 +1,21 @@
+Specifically find taskmanager library with CMake
+
+--- applet/CMakeLists.txt.orig 2017-03-29 07:44:51 UTC
++++ applet/CMakeLists.txt
+@@ -4,6 +4,7 @@ project(daisy)
+
+ # Find the required Libaries
+ find_package(KDE4 REQUIRED)
++find_package(KDE4Workspace REQUIRED)
+ include(KDE4Defaults)
+
+ add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
+@@ -26,7 +27,7 @@ kde4_add_plugin(plasma_applet_daisy ${da
+
+ target_link_libraries(plasma_applet_daisy
+ ${KDE4_PLASMA_LIBS} ${KDE4_KDEUI_LIBS} ${KDE4_KUTILS_LIBS}
+- ${KDE4_KIO_LIBS} taskmanager )
++ ${KDE4_KIO_LIBS} ${KDE4WORKSPACE_TASKMANAGER_LIBRARY} )
+
+ install(TARGETS plasma_applet_daisy
+ DESTINATION ${PLUGIN_INSTALL_DIR})