aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2018-12-26 18:04:47 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2018-12-26 18:04:47 +0000
commitc3719c1bea696da951bdd2e7d871c4387e3f62e6 (patch)
tree9b33d64c73862aa94413b9e2b1a400920f05dc46 /deskutils
parente287e4f967e11a615735827ef94eebc10a9c204b (diff)
downloadports-c3719c1bea696da951bdd2e7d871c4387e3f62e6.tar.gz
ports-c3719c1bea696da951bdd2e7d871c4387e3f62e6.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/nextcloudclient/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/deskutils/nextcloudclient/Makefile b/deskutils/nextcloudclient/Makefile
index 46141ec04c5c..ea0b33040277 100644
--- a/deskutils/nextcloudclient/Makefile
+++ b/deskutils/nextcloudclient/Makefile
@@ -38,10 +38,18 @@ OPTIONS_DEFINE= DEBUG # DOCS doesn't build currently
#DOCS_USE= tex=dvipsk:build,latex:build
#DOCS_CMAKE_ON= -DWITH_DOC:BOOL=ON
-DEBUG_CMAKE_ON= -DCMAKE_BUILD_TYPE:STRING=Debug
-
PLIST_SUB= VERSION=${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.ifdef WITH_DEBUG
+CMAKE_ARGS+= -DCMAKE_BUILD_TYPE:STRING=Debug
+.endif
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085 && !${SSL_DEFAULT:Mopenssl111}
+BROKEN= nextcloudclient requires OpenSSL 1.1.0, add DEFAULT_VERSIONS+=ssl=openssl111 to /etc/make.conf
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|.lst |.lst.sample |' ${WRKSRC}/CMakeLists.txt
@@ -49,4 +57,4 @@ post-patch:
pre-configure:
@(cd ${WRKSRC} && ${CP} -f sync-exclude.lst sync-exclude.lst.sample)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>