aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 06:26:43 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 06:26:43 +0000
commitdb910bd9bb965021951c265e586776e2b4123879 (patch)
tree8c3e5d3cc2e77cb13f613dee08fca386981ab460 /deskutils
parent0069e762184a9ad4f93ef1ffdf3a8c4fd21d8e8a (diff)
downloadports-db910bd9bb965021951c265e586776e2b4123879.tar.gz
ports-db910bd9bb965021951c265e586776e2b4123879.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/phpcollab/Makefile11
-rw-r--r--deskutils/planner.el/Makefile33
2 files changed, 22 insertions, 22 deletions
diff --git a/deskutils/phpcollab/Makefile b/deskutils/phpcollab/Makefile
index fdbe03a4dd55..b518811f9992 100644
--- a/deskutils/phpcollab/Makefile
+++ b/deskutils/phpcollab/Makefile
@@ -25,20 +25,19 @@ PKGMESSAGE= ${WRKDIR}/${PORTNAME}/pkg-message
SUB_FILES= pkg-message
PLIST_DIRSTRY= %%WWWDIR%%
-OPTIONS= POSTGRE "Use PostgreSQL Database" off \
- APACHE "Use Apache webserver" on \
- LIGHTTPD "Use Lighttpd webserver" off
+OPTIONS_DEFINE= PGSQL APACHE LIGHTTPD
+LIGHTTPD_DESC= Use Lighttpd webserver
.include <bsd.port.options.mk>
-.if defined(WITH_POSTGRE)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
.endif
-.if defined(WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE= 22
.endif
-.if defined(WITH_LIGHTTPD)
+.if ${PORT_OPTIONS:MLIGHTTPD}
RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
.endif
diff --git a/deskutils/planner.el/Makefile b/deskutils/planner.el/Makefile
index 02077259db19..6616cc8bb7f2 100644
--- a/deskutils/planner.el/Makefile
+++ b/deskutils/planner.el/Makefile
@@ -22,13 +22,14 @@ USE_GMAKE= yes
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_SITE_LISPDIR}/muse/muse.el:${PORTSDIR}/textproc/muse
-OPTIONS= BBDB "BBDB support" off
-OPTIONS+= GNATS "GNATS support" off
-OPTIONS+= PSVN "PSVN support" off
-OPTIONS+= VM "View Mail support" off
-OPTIONS+= W3M "W3M support" off
-OPTIONS+= WL "Wanderlust support" off
-OPTIONS+= XTLA "XTLA support" off
+OPTIONS_DEFINE= BBDB GNATS PSVN VM W3M WL XTLA DOCS
+BBDB_DESC= BBDB support
+GNATS_DESC= GNATS support
+PSVN_DESC= PSVN support
+VM_DESC= View Mail support
+W3M_DESC= W3M support
+WL_DESC= Wanderlust support
+XTLA_DESC= XTLA support
.include <bsd.port.pre.mk>
@@ -42,7 +43,7 @@ PLIST_SUB+= HAS_ICAL="@comment "
PLIST_SUB+= HAS_ICAL=""
.endif
-.if defined(WITH_BBDB)
+.if ${PORT_OPTIONS:MBBDB}
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/bbdb/bbdb-com.el:${PORTSDIR}/databases/bbdb
PLIST_SUB+= HAS_BBDB=""
.else
@@ -56,42 +57,42 @@ PLIST_SUB+= HAS_ERC="@comment "
PLIST_SUB+= HAS_ERC=""
.endif
-.if defined(WITH_GNATS)
+.if ${PORT_OPTIONS:MGNATS}
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_SITE_LISPDIR}/gnats.el:${PORTSDIR}/databases/gnats4
PLIST_SUB+= HAS_GNATS=""
.else
PLIST_SUB+= HAS_GNATS="@comment "
.endif
-.if defined(WITH_PSVN)
+.if ${PORT_OPTIONS:MPSVN}
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/psvn/psvn.el:${PORTSDIR}/devel/psvn
PLIST_SUB+= HAS_PSVN=""
.else
PLIST_SUB+= HAS_PSVN="@comment "
.endif
-.if defined(WITH_VM)
+.if ${PORT_OPTIONS:MVM}
BUILD_DEPENDS+= qp-decode:${PORTSDIR}/mail/vm
PLIST_SUB+= HAS_VM=""
.else
PLIST_SUB+= HAS_VM="@comment "
.endif
-.if defined(WITH_W3M)
+.if ${PORT_OPTIONS:MW3M}
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/w3m/w3m.el:${PORTSDIR}/www/emacs-w3m
PLIST_SUB+= HAS_W3M=""
.else
PLIST_SUB+= HAS_W3M="@comment "
.endif
-.if defined(WITH_WL)
+.if ${PORT_OPTIONS:MWL}
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/wl/wl.el:${PORTSDIR}/mail/wanderlust
PLIST_SUB+= HAS_WL=""
.else
PLIST_SUB+= HAS_WL="@comment "
.endif
-.if defined(WITH_XTLA)
+.if ${PORT_OPTIONS:MXTLA}
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/xtla/xtla.el:${PORTSDIR}/devel/xtla
PLIST_SUB+= HAS_XTLA=""
.else
@@ -102,7 +103,7 @@ RUN_DEPENDS+= ${BUILD_DEPENDS}
LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/planner
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= AUTHORS ChangeLog.1 ChangeLog.2 ChangeLog.3 ChangeLog \
COMMENTARY NEWS README
.endif
@@ -114,7 +115,7 @@ pre-build:
${CP} ${WRKSRC}/contrib/schedule.el ${WRKSRC}/schedule.el
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
${CP} -R ${WRKSRC}/${i} ${DOCSDIR}