aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-07-29 19:04:23 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-07-29 19:04:23 +0000
commit825ab637c9a43e4cbca50bce49f1d6eb8792a7b0 (patch)
tree288c1489a57f8ab7d7a3bc83ac8934bf7dacb9a5 /deskutils
parentba5ece12b16f39b13bb1681952b4791c55fc11bc (diff)
downloadports-825ab637c9a43e4cbca50bce49f1d6eb8792a7b0.tar.gz
ports-825ab637c9a43e4cbca50bce49f1d6eb8792a7b0.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/alexandria/Makefile15
-rw-r--r--deskutils/alexandria/distinfo6
-rw-r--r--deskutils/alexandria/files/patch-Rakefile14
-rw-r--r--deskutils/alexandria/files/patch-tasks.rb11
-rw-r--r--deskutils/alexandria/pkg-plist43
5 files changed, 49 insertions, 40 deletions
diff --git a/deskutils/alexandria/Makefile b/deskutils/alexandria/Makefile
index 6845b483de76..64fc339307d8 100644
--- a/deskutils/alexandria/Makefile
+++ b/deskutils/alexandria/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= alexandria
-PORTVERSION= 0.6.5
-PORTREVISION= 3
+PORTVERSION= 0.6.6
CATEGORIES= deskutils ruby
MASTER_SITES= RF
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -22,7 +21,8 @@ RUN_DEPENDS= ${RUBY_SITELIBDIR}/gettext.rb:${PORTSDIR}/devel/ruby-gettext \
${RUBY_SITEARCHLIBDIR:S/${PREFIX}/${LOCALBASE}/}/gconf2.so:${PORTSDIR}/devel/ruby-gconf2 \
${RUBY_SITEARCHLIBDIR:S/${PREFIX}/${LOCALBASE}/}/libglade2.so:${PORTSDIR}/devel/ruby-libglade2 \
rubygem-zoom>=0:${PORTSDIR}/devel/rubygem-zoom \
- rubygem-hpricot>=0:${PORTSDIR}/www/rubygem-hpricot
+ rubygem-hpricot>=0:${PORTSDIR}/www/rubygem-hpricot \
+ rubygem-htmlentities>=0:${PORTSDIR}/textproc/rubygem-htmlentities
USE_GNOME= gnomehier intltool
INSTALLS_ICONS= yes
@@ -32,6 +32,8 @@ USE_RUBY= yes
MAN1= alexandria.1
+OPTIONS= IMAGESIZE "Cover images optimization" off
+
DOCS= NEWS README TODO
GCONF_SCHEMAS= alexandria.schemas
@@ -48,6 +50,10 @@ USR2FIX= Rakefile alexandria.desktop.in data/menu/alexandria \
IGNORE= only works with Ruby 1.8.0 or later
.endif
+.if defined(WITH_IMAGESIZE)
+RUN_DEPENDS+=${RUBY_SITELIBDIR}/image_size.rb:${PORTSDIR}/graphics/ruby-image_size
+.endif
+
pre-build:
${REINPLACE_CMD} -e 's|/usr/|${PREFIX}/|' \
${USR2FIX:S|^|${WRKSRC}/|}
@@ -64,9 +70,6 @@ do-install:
@cd ${WRKSRC} && rake PREFIX=${PREFIX} install
post-install:
- @${MKDIR} ${LOCALBASE}/etc/gconf/schemas
- @${INSTALL_DATA} ${WRKSRC}/schemas/alexandria.schemas \
- ${LOCALBASE}/etc/gconf/schemas/
#.if !defined(NOPORTDOCS)
# @${MKDIR} ${RUBY_MODDOCDIR}
#.for f in ${DOCS}
diff --git a/deskutils/alexandria/distinfo b/deskutils/alexandria/distinfo
index b2172bcf746a..d56256ef92c3 100644
--- a/deskutils/alexandria/distinfo
+++ b/deskutils/alexandria/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/alexandria-0.6.5.tar.gz) = 9c8655f361e6a0c6f8cdc97f36bd2d0f
-SHA256 (ruby/alexandria-0.6.5.tar.gz) = ecfd78c9be3cfe4c2a5732425ceb8f19fbc95a123f9a13fc36717f2b16ca358f
-SIZE (ruby/alexandria-0.6.5.tar.gz) = 2970519
+MD5 (ruby/alexandria-0.6.6.tar.gz) = 76bc7054b19e033c1448346fa3232d64
+SHA256 (ruby/alexandria-0.6.6.tar.gz) = 42a9c81288b13190928166c67592426d893a8fba98293fca98e1fb9f36054ce0
+SIZE (ruby/alexandria-0.6.6.tar.gz) = 2990953
diff --git a/deskutils/alexandria/files/patch-Rakefile b/deskutils/alexandria/files/patch-Rakefile
new file mode 100644
index 000000000000..61a2b1cc1e85
--- /dev/null
+++ b/deskutils/alexandria/files/patch-Rakefile
@@ -0,0 +1,14 @@
+--- Rakefile 2010-06-17 21:28:36.000000000 +0400
++++ Rakefile 2010-06-26 20:56:17.000000000 +0400
+@@ -103,9 +103,9 @@
+ install_task.install_icons(icon_files, "#{SHARE}/icons")
+ install_task.install('data/app-icon/32x32', 'data/app-icon/32x32/*.xpm', "#{SHARE}/pixmaps")
+
+- install_task.install('','schemas/alexandria.schemas', "#{SHARE}/gconf")
++ install_task.install('','schemas/alexandria.schemas', "#{PREFIX}/etc/gconf")
+ install_task.install('', 'alexandria.desktop', "#{SHARE}/applications")
+- install_task.install('doc','doc/alexandria.1', "#{SHARE}/man/man1")
++ install_task.install('doc','doc/alexandria.1', "#{PREFIX}/man/man1")
+
+ end
+
diff --git a/deskutils/alexandria/files/patch-tasks.rb b/deskutils/alexandria/files/patch-tasks.rb
deleted file mode 100644
index 70fd7ed16bbe..000000000000
--- a/deskutils/alexandria/files/patch-tasks.rb
+++ /dev/null
@@ -1,11 +0,0 @@
---- tasks.rb.org 2009-04-15 08:01:49.000000000 +0900
-+++ tasks.rb 2009-04-15 08:02:03.000000000 +0900
-@@ -397,7 +397,7 @@
- end
-
- def manpage_installation
-- man_dir = File.join(File.join(sharedir, 'man'), 'man1')
-+ man_dir = File.join(File.join(@prefix, 'man'), 'man1')
- [['doc', build.doc.man_files, man_dir, 0644]]
- end
-
diff --git a/deskutils/alexandria/pkg-plist b/deskutils/alexandria/pkg-plist
index ece689a004af..2b14d63cf3e5 100644
--- a/deskutils/alexandria/pkg-plist
+++ b/deskutils/alexandria/pkg-plist
@@ -5,15 +5,18 @@ bin/alexandria
%%RUBY_SITELIBDIR%%/alexandria/book_providers/adlibris.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/amazon_aws.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/amazon_ecs_util.rb
-%%RUBY_SITELIBDIR%%/alexandria/book_providers/bn.rb
+%%RUBY_SITELIBDIR%%/alexandria/book_providers/barnes_and_noble.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/bol_it.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/deastore.rb
+%%RUBY_SITELIBDIR%%/alexandria/book_providers/douban.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/ibs_it.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/mcu.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/proxis.rb
+%%RUBY_SITELIBDIR%%/alexandria/book_providers/pseudomarc.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/renaud.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/siciliano.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/thalia.rb
+%%RUBY_SITELIBDIR%%/alexandria/book_providers/web.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/webster_it.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/worldcat.rb
%%RUBY_SITELIBDIR%%/alexandria/book_providers/z3950.rb
@@ -23,6 +26,7 @@ bin/alexandria
%%RUBY_SITELIBDIR%%/alexandria/execution_queue.rb
%%RUBY_SITELIBDIR%%/alexandria/export_library.rb
%%RUBY_SITELIBDIR%%/alexandria/import_library.rb
+%%RUBY_SITELIBDIR%%/alexandria/import_library_csv.rb
%%RUBY_SITELIBDIR%%/alexandria/logging.rb
%%RUBY_SITELIBDIR%%/alexandria/models/book.rb
%%RUBY_SITELIBDIR%%/alexandria/models/library.rb
@@ -34,6 +38,7 @@ bin/alexandria
%%RUBY_SITELIBDIR%%/alexandria/smart_library.rb
%%RUBY_SITELIBDIR%%/alexandria/ui.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/callbacks.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/completion_models.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/dialogs/about_dialog.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/dialogs/acquire_dialog.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/dialogs/alert_dialog.rb
@@ -50,18 +55,18 @@ bin/alexandria
%%RUBY_SITELIBDIR%%/alexandria/ui/dialogs/smart_library_properties_dialog.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/dialogs/smart_library_properties_dialog_base.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/dndable.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/glade_base.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/gtk_thread_help.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/icons.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/iconview.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/iconview_tooltips.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/init.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/libraries_combo.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/listview.rb
+%%RUBY_SITELIBDIR%%/alexandria/ui/main_app.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/multi_drag_treeview.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/sidepane.rb
%%RUBY_SITELIBDIR%%/alexandria/ui/ui_manager.rb
-%%RUBY_SITELIBDIR%%/alexandria/ui/completion_models.rb
-%%RUBY_SITELIBDIR%%/alexandria/ui/glade_base.rb
-%%RUBY_SITELIBDIR%%/alexandria/ui/icons.rb
-%%RUBY_SITELIBDIR%%/alexandria/ui/main_app.rb
%%RUBY_SITELIBDIR%%/alexandria/undo_manager.rb
%%RUBY_SITELIBDIR%%/alexandria/utils.rb
%%RUBY_SITELIBDIR%%/alexandria/version.rb
@@ -85,8 +90,8 @@ bin/alexandria
%%DATADIR%%/icons/lookup.png
%%DATADIR%%/icons/more.png
%%DATADIR%%/icons/no_cover.png
-%%DATADIR%%/icons/smart_library_small.png
%%DATADIR%%/icons/smart_library.png
+%%DATADIR%%/icons/smart_library_small.png
%%DATADIR%%/icons/star_set.png
%%DATADIR%%/icons/star_unset.png
%%DATADIR%%/icons/view_as_icons.png
@@ -95,8 +100,8 @@ bin/alexandria
%%DATADIR%%/ui/popups.xml
%%DATADIR%%/web-themes/clean/clean.css
%%DATADIR%%/web-themes/clean/preview.jpg
-%%DATADIR%%/web-themes/list/preview.jpg
%%DATADIR%%/web-themes/list/list.css
+%%DATADIR%%/web-themes/list/preview.jpg
share/applications/alexandria.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/BUGS
@@ -135,7 +140,6 @@ share/gnome/help/alexandria/C/searching.xml
share/gnome/help/alexandria/C/settings.xml
share/gnome/help/alexandria/C/smart-libraries.xml
share/gnome/help/alexandria/C/working-with-libraries.xml
-share/gnome/help/alexandria/C/#settings.xml#
share/gnome/help/alexandria/fr/alexandria.xml
share/gnome/help/alexandria/fr/figures/alexandria_add_button.png
share/gnome/help/alexandria/fr/figures/alexandria_add_by_isbn_1.png
@@ -206,28 +210,27 @@ share/locale/sk/LC_MESSAGES/alexandria.mo
share/locale/sv/LC_MESSAGES/alexandria.mo
share/locale/uk/LC_MESSAGES/alexandria.mo
share/locale/zh_TW/LC_MESSAGES/alexandria.mo
-share/menu/alexandria
share/omf/alexandria/alexandria-C.omf
share/omf/alexandria/alexandria-fr.omf
+share/pixmaps/alexandria.xpm
share/sounds/alexandria/bad_scan.wav
share/sounds/alexandria/good_scan.wav
share/sounds/alexandria/scanning.wav
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/sounds/alexandria
@dirrm share/omf/alexandria
-@dirrmtry share/menu
-@dirrmtry share/icons/hicolor/16x16/apps
-@dirrmtry share/icons/hicolor/16x16
-@dirrmtry share/icons/hicolor/22x22/apps
-@dirrmtry share/icons/hicolor/22x22
-@dirrmtry share/icons/hicolor/24x24/apps
-@dirrmtry share/icons/hicolor/24x24
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
@dirrmtry share/icons/hicolor/scalable/apps
@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
@dirrmtry share/icons/hicolor
@dirrm share/gnome/help/alexandria/ja/figures
@dirrm share/gnome/help/alexandria/ja