aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-12-28 12:51:52 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-12-28 12:51:52 +0000
commitb1b69ea46cea514b97f9c1342929971ac17a1116 (patch)
treebb757a1e54f245d5150d6b003131166f3ce4a3ec /deskutils
parent6f3c1df282f842b7c5d49dfc3e65528867673d27 (diff)
downloadports-b1b69ea46cea514b97f9c1342929971ac17a1116.tar.gz
ports-b1b69ea46cea514b97f9c1342929971ac17a1116.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/howm/Makefile38
-rw-r--r--deskutils/howm/distinfo1
-rw-r--r--deskutils/howm/pkg-descr7
-rw-r--r--deskutils/howm/pkg-message10
-rw-r--r--deskutils/howm/pkg-plist23
6 files changed, 80 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 6be9b470e8cd..89775279a3f9 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -42,6 +42,7 @@
SUBDIR += gtodo
SUBDIR += gucharmap
SUBDIR += gworkspace
+ SUBDIR += howm
SUBDIR += ical
SUBDIR += ithought
SUBDIR += jlj
diff --git a/deskutils/howm/Makefile b/deskutils/howm/Makefile
new file mode 100644
index 000000000000..6a3a64b98a09
--- /dev/null
+++ b/deskutils/howm/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: howm
+# Date created: 28 Dec 2003
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= howm
+PORTVERSION= 1.1.0.1
+CATEGORIES= deskutils
+MASTER_SITES= http://www.me.ics.saitama-u.ac.jp/~hira/emacs/howm/
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Write fragmentarily and read collectively
+
+EMACS_PORT_NAME?= emacs21
+ELISP= action-lock.el \
+ howm-font-lock.el howm-menu.el howm-mode.el howm-view.el
+
+do-build:
+.for i in ${ELISP}
+ cd ${WRKSRC}; ${EMACS_CMD} -q -batch -L . -f batch-byte-compile ${i}
+.endfor
+
+do-install:
+ cd ${WRKSRC}; ${INSTALL_DATA} *.el *.elc ${PREFIX}/${EMACS_SITE_LISPDIR}
+ ${MKDIR} ${EXAMPLESDIR}/ja ${EXAMPLESDIR}/en
+ cd ${WRKSRC}; ${INSTALL_DATA} ja/* ${EXAMPLESDIR}/ja
+ cd ${WRKSRC}; ${INSTALL_DATA} en/* ${EXAMPLESDIR}/en
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}; ${INSTALL_DATA} *.html *.png ${DOCSDIR}
+
+post-install:
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/deskutils/howm/distinfo b/deskutils/howm/distinfo
new file mode 100644
index 000000000000..fa32327417f6
--- /dev/null
+++ b/deskutils/howm/distinfo
@@ -0,0 +1 @@
+MD5 (howm-1.1.0.1.tar.gz) = d11ff14a35076c5ef199baf52cd4ab3e
diff --git a/deskutils/howm/pkg-descr b/deskutils/howm/pkg-descr
new file mode 100644
index 000000000000..e9591b6e2403
--- /dev/null
+++ b/deskutils/howm/pkg-descr
@@ -0,0 +1,7 @@
+howm: Write fragmentarily and read collectively.
+
+Howm is a note-taking tool on Emacs. It is similar to emacs-wiki;
+you can enjoy hyperlinks and full-text search easily. It is not
+similar to emacs-wiki; it can be combined with any format.
+
+WWW: http://www.me.ics.saitama-u.ac.jp/~hira/emacs/howm/index.html
diff --git a/deskutils/howm/pkg-message b/deskutils/howm/pkg-message
new file mode 100644
index 000000000000..772179891f98
--- /dev/null
+++ b/deskutils/howm/pkg-message
@@ -0,0 +1,10 @@
+To use this port:
+
+ % mkdir ~/howm
+ % cp ${PREFIX}/share/examples/howm/en/* ~/howm/
+
+And write below to your ~/.emacs:
+
+ ;(setq howm-menu-lang 'ja)
+ (global-set-key "\C-c,," 'howm-menu)
+ (autoload 'howm-menu "howm-mode" "Hitori Otegaru Wiki Modoki" t)
diff --git a/deskutils/howm/pkg-plist b/deskutils/howm/pkg-plist
new file mode 100644
index 000000000000..584ea787744d
--- /dev/null
+++ b/deskutils/howm/pkg-plist
@@ -0,0 +1,23 @@
+%%EMACS_SITE_LISPDIR%%/action-lock.el
+%%EMACS_SITE_LISPDIR%%/action-lock.elc
+%%EMACS_SITE_LISPDIR%%/howm-font-lock.el
+%%EMACS_SITE_LISPDIR%%/howm-font-lock.elc
+%%EMACS_SITE_LISPDIR%%/howm-menu.el
+%%EMACS_SITE_LISPDIR%%/howm-menu.elc
+%%EMACS_SITE_LISPDIR%%/howm-mode.el
+%%EMACS_SITE_LISPDIR%%/howm-mode.elc
+%%EMACS_SITE_LISPDIR%%/howm-view.el
+%%EMACS_SITE_LISPDIR%%/howm-view.elc
+%%EXAMPLESDIR%%/en/0000-00-00-000000.howm
+%%EXAMPLESDIR%%/ja/0000-00-00-000000.howm
+%%DOCSDIR%%/README-j.html
+%%DOCSDIR%%/index-j.html
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/s-cat.png
+%%DOCSDIR%%/s-menu.png
+%%DOCSDIR%%/s-screen-shot.png
+%%DOCSDIR%%/s-search.png
+@dirrm %%EXAMPLESDIR%%/en
+@dirrm %%EXAMPLESDIR%%/ja
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%