aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-08-31 13:27:24 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-08-31 13:27:24 +0000
commite562107239ac8bddd5741310a54608f4f6b8fc93 (patch)
treee7debb8413b59716c06d63dc53c62b1f84359808 /deskutils
parent6f4cee7a82a24bfc90f097e65dfd2da98055c9d9 (diff)
downloadports-e562107239ac8bddd5741310a54608f4f6b8fc93.tar.gz
ports-e562107239ac8bddd5741310a54608f4f6b8fc93.zip
deskutils/coregarage: Settings manager for C Suite
Coregarage is a settings manager for C Suite, part of the CuboCore suite of simple, lighweight Qt applications. Coregarage is a centralized tool that manages settings for a variety of CuboCore apps.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/coregarage/Makefile36
-rw-r--r--deskutils/coregarage/distinfo3
-rw-r--r--deskutils/coregarage/files/patch-settings.cpp19
-rw-r--r--deskutils/coregarage/pkg-descr5
5 files changed, 64 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 8eab3e95423f..f5c6e9860b6e 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -37,6 +37,7 @@
SUBDIR += conkyforecast
SUBDIR += coolreader
SUBDIR += copyq
+ SUBDIR += coregarage
SUBDIR += countdown
SUBDIR += dailystrips
SUBDIR += deforaos-todo
diff --git a/deskutils/coregarage/Makefile b/deskutils/coregarage/Makefile
new file mode 100644
index 000000000000..269132706617
--- /dev/null
+++ b/deskutils/coregarage/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= coregarage
+DISTVERSION= 4.3.0
+PORTREVISION= 1
+CATEGORIES= deskutils
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Settings manager for C Suite
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libarchiveqt5.so:archivers/libarchive-qt \
+ libcprime-core.so:deskutils/libcprime
+
+USES= cmake localbase:ldflags qt:5
+USE_QT= buildtools_build core gui qmake_build widgets
+USE_GITLAB= yes
+
+GL_ACCOUNT= CuboCore
+GL_COMMIT= 684e579b4a03914b77ceccd6efcfc490c53ad730
+
+PLIST_FILES= bin/coregarage \
+ share/applications/org.cubocore.CoreGarage.desktop \
+ share/icons/hicolor/scalable/apps/org.cubocore.CoreGarage.svg
+
+pre-configure:
+ @${REINPLACE_CMD} \
+ -e 's|/usr/bin|${PREFIX}/bin|g' \
+ -e 's|/usr/lib|${PREFIX}/lib|g' \
+ -e 's|/usr/share|${PREFIX}/share|g' \
+ ${WRKSRC}/coregarage.cpp \
+ ${WRKSRC}/coregarage.h \
+ ${WRKSRC}/org.cubocore.CoreGarage.desktop \
+ ${WRKSRC}/settings.cpp
+
+.include <bsd.port.mk>
diff --git a/deskutils/coregarage/distinfo b/deskutils/coregarage/distinfo
new file mode 100644
index 000000000000..c9df90ac3944
--- /dev/null
+++ b/deskutils/coregarage/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1629410694
+SHA256 (CuboCore-coregarage-684e579b4a03914b77ceccd6efcfc490c53ad730_GL0.tar.gz) = 871e8513176cf54fb1b5de3c90569d012270c3f55d35d20d68564e4813780e56
+SIZE (CuboCore-coregarage-684e579b4a03914b77ceccd6efcfc490c53ad730_GL0.tar.gz) = 102003
diff --git a/deskutils/coregarage/files/patch-settings.cpp b/deskutils/coregarage/files/patch-settings.cpp
new file mode 100644
index 000000000000..ff42ff643a33
--- /dev/null
+++ b/deskutils/coregarage/files/patch-settings.cpp
@@ -0,0 +1,19 @@
+--- settings.cpp.orig 2021-08-19 22:05:32 UTC
++++ settings.cpp
+@@ -75,13 +75,13 @@ void settings::setDefaultSettings()
+ QFont genFont = QFontDatabase::systemFont(QFontDatabase::GeneralFont);
+ QFont monoFont = QFontDatabase::systemFont(QFontDatabase::FixedFont);
+ if ( not genFont.family().count() )
+- genFont = QFont("Cantarell", 9);
++ genFont = QFont("Cantarell", 12);
+
+ if ( not monoFont.family().count() )
+- monoFont = QFont("monospace", 9);
++ monoFont = QFont("monospace", 12);
+
+ if (monoFont.styleHint() != QFont::Monospace) {
+- monoFont = QFont("monospace", 9);
++ monoFont = QFont("monospace", 12);
+ }
+
+ // CoreAction
diff --git a/deskutils/coregarage/pkg-descr b/deskutils/coregarage/pkg-descr
new file mode 100644
index 000000000000..4e135ddbafc6
--- /dev/null
+++ b/deskutils/coregarage/pkg-descr
@@ -0,0 +1,5 @@
+Coregarage is a settings manager for C Suite, part of the CuboCore
+suite of simple, lighweight Qt applications. Coregarage is a
+centralized tool that manages settings for a variety of CuboCore apps.
+
+WWW: https://gitlab.com/cubocore/coregarage